summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Deutschmann <whissi@gentoo.org>2019-12-26 11:42:19 +0100
committerThomas Deutschmann <whissi@gentoo.org>2019-12-26 11:43:15 +0100
commit0c59d1cefdf63ef395b70993f81710112a9f5582 (patch)
tree056c808471bb70a5192960fc735e7736b0b12655 /sys-block/storcli/storcli-7.1211.ebuild
parentsys-apps/dbus: user-session is now safe (diff)
downloadgentoo-0c59d1cefdf63ef395b70993f81710112a9f5582.tar.gz
gentoo-0c59d1cefdf63ef395b70993f81710112a9f5582.tar.bz2
gentoo-0c59d1cefdf63ef395b70993f81710112a9f5582.zip
sys-block/storcli: bump to v7.1211
Package-Manager: Portage-2.3.83, Repoman-2.3.20 Signed-off-by: Thomas Deutschmann <whissi@gentoo.org>
Diffstat (limited to 'sys-block/storcli/storcli-7.1211.ebuild')
-rw-r--r--sys-block/storcli/storcli-7.1211.ebuild68
1 files changed, 68 insertions, 0 deletions
diff --git a/sys-block/storcli/storcli-7.1211.ebuild b/sys-block/storcli/storcli-7.1211.ebuild
new file mode 100644
index 000000000000..6646f7cbbfd4
--- /dev/null
+++ b/sys-block/storcli/storcli-7.1211.ebuild
@@ -0,0 +1,68 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="7"
+
+inherit pax-utils
+
+# Upstream is still using strange version numbers
+MY_PV="007.1211.0000.0000"
+
+DESCRIPTION="MegaRAID StorCLI (successor of the MegaCLI)"
+HOMEPAGE="https://www.broadcom.com/support/download-search?dk=storcli"
+SRC_URI="https://docs.broadcom.com/docs-and-downloads/raid-controllers/raid-controllers-common-files/${MY_PV}_Unified_StorCLI.zip -> ${P}.zip"
+
+LICENSE="Avago LSI BSD"
+SLOT="0/7.12"
+KEYWORDS="-* ~amd64 ~x86"
+IUSE=""
+
+RDEPEND=""
+DEPEND="app-arch/unzip"
+
+MY_STORCLI_BASEDIR="/opt/lsi/storcli"
+
+QA_PRESTRIPPED="${MY_STORCLI_BASEDIR:1}/storcli
+ ${MY_STORCLI_BASEDIR:1}/storcli32"
+QA_PREBUILT=${QA_PRESTRIPPED}
+
+src_unpack() {
+ mkdir srcfiles || die
+ pushd srcfiles &>/dev/null || die
+ default
+ mv Unified_storcli_all_os/Ubuntu/storcli_*.deb "${WORKDIR}" || die "Failed to move storcli_*.deb"
+ popd &>/dev/null || die
+
+ rm -rf srcfiles || die
+
+ # Unpack Ubuntu package which will be our $S content
+ unpack "${WORKDIR}"/storcli_*.deb
+ rm -f storcli_*.deb || die "Failed to cleanup storcli_*.deb package"
+ unpack "${WORKDIR}"/data.tar.xz
+
+ mkdir "${S}" || die "Failed to create '${S}'"
+}
+
+src_prepare() {
+ default
+
+ # Create clean $S
+ mv "${WORKDIR}"/opt/Mega*/storcli/* "${S}" || die "Failed to move storcli_.deb content to '${S}'"
+ rm -rf "${WORKDIR}"/{opt,control.tar.gz,data.tar.gz,debian-binary} || die "Failed to cleanup no longer needed files"
+}
+
+src_install() {
+ exeinto "${MY_STORCLI_BASEDIR}"
+
+ if use x86; then
+ doexe storcli
+ elif use amd64; then
+ # 32-bit version is less crashy than the 64bit (bug #656494)
+ newexe storcli storcli32
+ newexe storcli64 storcli
+ fi
+
+ dosym "${MY_STORCLI_BASEDIR}"/storcli /usr/sbin/storcli
+
+ pax-mark m "${D%/}${MY_STORCLI_BASEDIR}"/storcli
+}