summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiogo Pereira <sir.suriv@gmail.com>2018-02-17 14:09:47 +0000
committerPatrice Clement <monsieurp@gentoo.org>2018-02-18 18:15:18 +0100
commitcd6e98cf0105347632cc7aa8f22f777220b781c2 (patch)
treeb31defb839260110ea729528be91f78760131df3 /sys-block/targetcli-fb/targetcli-fb-2.1.48.ebuild
parentmedia-video/obs-studio: update references to 'speex'. (diff)
downloadgentoo-cd6e98cf0105347632cc7aa8f22f777220b781c2.tar.gz
gentoo-cd6e98cf0105347632cc7aa8f22f777220b781c2.tar.bz2
gentoo-cd6e98cf0105347632cc7aa8f22f777220b781c2.zip
sys-block/targetcli-fb: version bump to 2.1.48.
Package-Manager: Portage-2.3.19, Repoman-2.3.6 Closes: https://github.com/gentoo/gentoo/pull/7199
Diffstat (limited to 'sys-block/targetcli-fb/targetcli-fb-2.1.48.ebuild')
-rw-r--r--sys-block/targetcli-fb/targetcli-fb-2.1.48.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/sys-block/targetcli-fb/targetcli-fb-2.1.48.ebuild b/sys-block/targetcli-fb/targetcli-fb-2.1.48.ebuild
new file mode 100644
index 000000000000..525248d50006
--- /dev/null
+++ b/sys-block/targetcli-fb/targetcli-fb-2.1.48.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_{4,5} )
+
+inherit distutils-r1 versionator
+
+MY_PV=$(replace_version_separator 2 '.fb' ${PV})
+
+DESCRIPTION="Command shell for managing Linux LIO kernel target"
+HOMEPAGE="https://github.com/open-iscsi/targetcli-fb"
+SRC_URI="https://github.com/open-iscsi/${PN}/archive/v${MY_PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+RDEPEND="dev-python/configshell-fb[${PYTHON_USEDEP}]
+ dev-python/pygobject:3[${PYTHON_USEDEP}]
+ >=dev-python/rtslib-fb-2.1.62[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]
+ !sys-block/targetcli"
+
+S="${WORKDIR}/${PN}-${MY_PV}"
+
+src_install() {
+ distutils-r1_src_install
+
+ keepdir /etc/target /etc/target/backup
+ doman targetcli.8
+}