summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiogo Pereira <sir.suriv@gmail.com>2016-08-06 23:20:52 +0100
committerPatrice Clement <monsieurp@gentoo.org>2016-09-02 19:18:14 +0200
commitca36978e8cd1543a44300433742e9142aaa7a1c1 (patch)
treebc0b8e3f9d568439df8402837179083c5bb2d801 /sys-block/targetcli/targetcli-9999.ebuild
parentdev-python/rtslib: update live ebuild (diff)
downloadgentoo-ca36978e8cd1543a44300433742e9142aaa7a1c1.tar.gz
gentoo-ca36978e8cd1543a44300433742e9142aaa7a1c1.tar.bz2
gentoo-ca36978e8cd1543a44300433742e9142aaa7a1c1.zip
sys-block/targetcli: update live ebuild
* Update to EAPI 6 * Update git repository URI * Change license to Apache-2.0 * Remove DEPEND on sys-block/lio-utils * Add DEPEND on dev-python/prettytable * Add RDEPEND on dev-python/urwid Gentoo-Bug: https://bugs.gentoo.org/436814 Gentoo-Bug: https://bugs.gentoo.org/491668 Closes: https://github.com/gentoo/gentoo/pull/2034 Signed-off-by: Patrice Clement <monsieurp@gentoo.org>
Diffstat (limited to 'sys-block/targetcli/targetcli-9999.ebuild')
-rw-r--r--sys-block/targetcli/targetcli-9999.ebuild59
1 files changed, 35 insertions, 24 deletions
diff --git a/sys-block/targetcli/targetcli-9999.ebuild b/sys-block/targetcli/targetcli-9999.ebuild
index e9948c906695..5701d51f4ee8 100644
--- a/sys-block/targetcli/targetcli-9999.ebuild
+++ b/sys-block/targetcli/targetcli-9999.ebuild
@@ -1,35 +1,46 @@
-# Copyright 1999-2012 Gentoo Foundation
+# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
-EAPI=4
+EAPI=6
-EGIT_REPO_URI="git://linux-iscsi.org/${PN}.git"
-PYTHON_DEPEND="2"
-RESTRICT_PYTHON_ABIS="3.*"
-SUPPORT_PYTHON_ABIS="1"
+PYTHON_COMPAT=( python2_7 )
-inherit eutils distutils git-2 python linux-info
+inherit distutils-r1 linux-info
-DESCRIPTION="The targetcli administration shell"
-HOMEPAGE="http://linux-iscsi.org/"
-SRC_URI=""
+if [[ ${PV} == 9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="git://github.com/Datera/${PN}.git
+ https://github.com/Datera/${PN}.git"
+ KEYWORDS=""
+else
+ MY_PV=${PV/_/-}
+ SRC_URI="https://github.com/Datera/${PN}/archive/${PV/_/-}.tar.gz -> ${P}.tar.gz"
+ S="${WORKDIR}/${PN}-${MY_PV}"
+ KEYWORDS="~amd64"
+fi
-LICENSE="AGPL-3"
+DESCRIPTION="CLI and shell for the Linux SCSI target"
+HOMEPAGE="http://linux-iscsi.org/wiki/targetcli"
+
+LICENSE="Apache-2.0"
SLOT="0"
-KEYWORDS=""
IUSE=""
-DEPEND="
- dev-python/configshell
- dev-python/rtslib
- sys-block/lio-utils
- "
-RDEPEND="${DEPEND}"
-
-CONFIG_CHECK="~TARGET_CORE"
-
-pkg_setup() {
- linux-info_pkg_setup
- python_pkg_setup
+DEPEND="dev-python/configshell[${PYTHON_USEDEP}]
+ dev-python/prettytable[${PYTHON_USEDEP}]
+ dev-python/rtslib[${PYTHON_USEDEP}]"
+RDEPEND="${DEPEND}
+ dev-python/urwid[${PYTHON_USEDEP}]"
+
+pkg_pretend() {
+ if use kernel_linux; then
+ linux-info_get_any_version
+ if ! linux_config_exists; then
+ eerror "Unable to check your kernel for SCSI target support"
+ else
+ CONFIG_CHECK="~TARGET_CORE"
+ check_extra_config
+ fi
+ fi
}