summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /sys-block/tw_cli/tw_cli-10.2.2.1.ebuild
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'sys-block/tw_cli/tw_cli-10.2.2.1.ebuild')
-rw-r--r--sys-block/tw_cli/tw_cli-10.2.2.1.ebuild102
1 files changed, 102 insertions, 0 deletions
diff --git a/sys-block/tw_cli/tw_cli-10.2.2.1.ebuild b/sys-block/tw_cli/tw_cli-10.2.2.1.ebuild
new file mode 100644
index 000000000000..761774b734d9
--- /dev/null
+++ b/sys-block/tw_cli/tw_cli-10.2.2.1.ebuild
@@ -0,0 +1,102 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+DESCRIPTION="3ware SATA/PATA/SAS RAID controller Command Line Interface tool"
+HOMEPAGE="http://www.lsi.com/products/raid-controllers/pages/3ware-sas-9750-8i.aspx"
+
+# This is apparently what the upstream stuff was based on when LSI took over?
+ThreeDM2_PV="9.5.5.1"
+
+SRC_URI_BASE="http://www.lsi.com/downloads/Public/SATA/SATA%20Common%20Files/"
+SRC_URI_A_linux="CLI_linux-from_the_${PV}_${ThreeDM2_PV}_codesets.zip"
+SRC_URI_A_fbsd="CLI_freebsd-from_the_${PV}_${ThreeDM2_PV}_codesets.zip"
+SRC_URI="kernel_linux? ( ${SRC_URI_BASE}/${SRC_URI_A_linux} )
+ kernel_FreeBSD? ( ${SRC_URI_BASE}/${SRC_URI_A_fbsd} )"
+# the minor ver on the end changes...
+RELNOTES="${SRC_URI_BASE}/${PV}_Release_Notes.pdf"
+
+# Note: 3ware gave permission to redistribute the binaries before:
+# Ref: http://bugs.gentoo.org/show_bug.cgi?id=60690#c106
+#
+# Please note that the LSI-tw_cli license does allow redistribution, despite
+# being a EULA:
+# 2. Grant of Rights
+# 2.1 LSI Binary Code. Subject to the terms of this Agreement, LSI grants
+# to Licensee a non-exclusive, world-wide, revocable (for breach in
+# accordance with Section 7), non-transferable limited license, without
+# the right to sublicense except as expressly provided herein, solely to:
+# (c) Distribute the LSI Binary Code as incorporated in Licensee's
+# Products or for use with LSI Devices to its Subsequent Users;
+# (d) Distribute the Explanatory Materials related to LSI Binary Code only
+# for use with LSI Devices;
+#
+# 3. License Restrictions
+# 3.1. LSI Binary Code. The Licenses granted in Section 2.1 for LSI Binary
+# Code and related Explanatory Materials are subject to the following
+# restrictions:
+# (a) Licensee shall not use the LSI Binary Code and related Explanatory
+# Materials for any purpose other than as expressly provided in Article 2;
+# (b) Licensee shall reproduce all copyright notices and other proprietary
+# markings or legends contained within or on the LSI Binary Code and
+# related Explanatory Materials on any copies it makes; and
+LICENSE="LSI-tw_cli"
+SLOT="0"
+
+# This package can never enter stable, it can't be mirrored and upstream
+# can remove the distfiles from their mirror anytime.
+KEYWORDS="-* ~amd64 ~x86 ~x86-fbsd ~amd64-fbsd"
+IUSE=""
+
+RESTRICT="strip primaryuri"
+QA_PREBUILT="/opt/tw_cli/tw_cli"
+
+# binary packages
+DEPEND="app-arch/unzip"
+RDEPEND=""
+
+S=${WORKDIR}
+
+# If you want to fetch it yourself (not from the mirrors), there is an IP-based
+# clickthrough to accept the EULA.
+pkg_nofetch() {
+ einfo "Upstream has implement a mandatory clickthrough EULA for distfile download"
+ einfo "Please visit $SRC_URI in your browser. The clickthrough is IP-based,"
+ einfo "so no wget is possible."
+ einfo "And place $A in ${DISTDIR}"
+}
+
+src_install() {
+ case ${ARCH} in
+ amd64) CLI_BIN=x86_64/tw_cli;;
+ x86) CLI_BIN=x86/tw_cli;;
+ *) die "unsupported ARCH";;
+ esac
+ exeinto /opt/tw_cli
+ # The names have varied in the past, sometimes there is a suffix
+ newexe ${CLI_BIN} tw_cli
+ dosym /opt/tw_cli/tw_cli /usr/sbin/tw_cli
+
+ newman ${PN}.8.nroff ${PN}.8
+ dohtml *.html
+ dodoc *.txt
+
+ # to comply with license requirement 3.1.b
+ insinto /opt/tw_cli
+ newins ${PORTDIR}/licenses/${LICENSE} LICENSE
+}
+
+pkg_postinst() {
+ elog "This binary supports should support ALL cards, including, but not"
+ elog "limited to the following series:"
+ elog ""
+ elog "PATA: 6xxx, 72xx, 74xx, 78xx, 7000, 7500, 7506"
+ elog "SATA: 8006, 8500, 8506, 9500S, 9550SX, 9590SE,"
+ elog " 9550SXU, 9650SE, 9650SE-{24M8,4LPME},"
+ elog " 9690SA, 9750"
+ elog ""
+ elog "Release notes for this version are available at:"
+ elog "${RELNOTES}"
+}