summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /sys-block/tw_cli/tw_cli-9.3.0.4.ebuild
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'sys-block/tw_cli/tw_cli-9.3.0.4.ebuild')
-rw-r--r--sys-block/tw_cli/tw_cli-9.3.0.4.ebuild70
1 files changed, 70 insertions, 0 deletions
diff --git a/sys-block/tw_cli/tw_cli-9.3.0.4.ebuild b/sys-block/tw_cli/tw_cli-9.3.0.4.ebuild
new file mode 100644
index 000000000000..b2801049fa5b
--- /dev/null
+++ b/sys-block/tw_cli/tw_cli-9.3.0.4.ebuild
@@ -0,0 +1,70 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+DESCRIPTION="3ware SATA+PATA RAID controller Command Line Interface tool"
+HOMEPAGE="http://www.3ware.com/"
+LICENSE="3ware"
+SLOT="0"
+# binary packages
+KEYWORDS="-* ~x86 ~amd64"
+IUSE=""
+# stripping seems to break this sometimes
+RESTRICT="fetch strip mirror"
+# binary packages
+DEPEND=""
+RDEPEND=""
+MY_P="${PN}-linux-${ARCH/amd64/x86_64}-${PV}"
+# package has different tarballs for x86 and amd64
+SRC_URI_BASE="http://www.3ware.com/download/Escalade7000Series/${PV}"
+SRC_URI="x86? ( ${SRC_URI_BASE}/${PN}-linux-x86-${PV}.tgz )
+ amd64? ( ${SRC_URI_BASE}/${PN}-linux-x86_64-${PV}.tgz )"
+# x86: http://3ware.com/support/download_9.3.0.2.asp?SNO=616
+# amd64: http://3ware.com/support/download_9.3.0.2.asp?SNO=617
+DOWNLOAD_URL="http://www.3ware.com/support/windows_agree.asp?path=/download/Escalade7000Series/${PV}/${MY_P}.tgz"
+S="${WORKDIR}"
+
+src_unpack() {
+ unpack ${MY_P}.tgz
+}
+
+supportedcards() {
+ einfo "This binary supports should support ALL cards, including, but not"
+ einfo "limited to:"
+ einfo ""
+ einfo "PATA: 6xxx, 7210, 7410, 7450, 7810, 7850, 7000-2, 7500-4, 7500-8,"
+ einfo " 7500-12, 7006-2, 7506-4, 7506-4LP, 7506-8, 7506-12"
+ einfo ""
+ einfo "SATA: 8500-4, 8500-8, 8500-12, 8006-2, 8506-4, 8506-12,"
+ einfo " 8506-8MI, 8506-12MI, 9500S-4LP, 9500S-8, 9500S-12,"
+ einfo " 9500S-8MI, 9500S-12MI"
+}
+
+pkg_setup() {
+ supportedcards
+}
+
+pkg_nofetch() {
+ einfo "Please agree to the license at URL"
+ einfo ""
+ einfo "\t${DOWNLOAD_URL}"
+ einfo ""
+ einfo "And then use the following URL to download the"
+ einfo "correct tarball into ${DISTDIR}"
+ einfo ""
+ einfo "\t${SRC_URI}"
+ einfo ""
+ supportedcards
+}
+
+src_install() {
+ into /
+ dosbin tw_cli
+ dosbin tw_sched
+ insinto /etc
+ doins tw_sched.cfg
+ into /usr
+ newman tw_cli.8.nroff tw_cli.8
+ newman tw_sched.8.nroff tw_sched.8
+ dohtml *.html
+}