summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrey Utkin <andrey_utkin@fastmail.com>2017-01-08 01:37:59 +0000
committerMichael Palimaka <kensington@gentoo.org>2017-01-30 02:22:04 +1100
commitce337f2df79ec528640932932898dce35078e029 (patch)
tree094354708b74dd1eb71b4732df233bb0c67c4061 /sys-block/whdd/whdd-3.0.ebuild
parentsys-block/whdd: 9999: specify ncurses slot in DEPEND (diff)
downloadgentoo-ce337f2df79ec528640932932898dce35078e029.tar.gz
gentoo-ce337f2df79ec528640932932898dce35078e029.tar.bz2
gentoo-ce337f2df79ec528640932932898dce35078e029.zip
sys-block/whdd: add 3.0 ebuild
3.0 ebuild is exact copy of -9999 live ebuild which handles case of tagged releases.
Diffstat (limited to 'sys-block/whdd/whdd-3.0.ebuild')
-rw-r--r--sys-block/whdd/whdd-3.0.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/sys-block/whdd/whdd-3.0.ebuild b/sys-block/whdd/whdd-3.0.ebuild
new file mode 100644
index 000000000000..6c4ff079329a
--- /dev/null
+++ b/sys-block/whdd/whdd-3.0.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+DESCRIPTION="Diagnostic and recovery tool for block devices"
+HOMEPAGE="https://whdd.github.io"
+
+if [[ ${PV} == 9999 ]]
+then
+ EGIT_REPO_URI="https://github.com/${PN}/${PN}"
+ inherit git-r3
+else
+ SRC_URI="https://github.com/${PN}/${PN}/tarball/${PV} -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+ inherit vcs-snapshot
+fi
+
+LICENSE="GPL-3"
+SLOT="0"
+IUSE=""
+
+DEPEND="
+ dev-util/dialog
+ sys-libs/ncurses:0=[unicode]"
+RDEPEND="${DEPEND}
+ sys-apps/smartmontools"