summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-01-28 09:29:13 +0100
committerMichał Górny <mgorny@gentoo.org>2021-01-28 09:35:23 +0100
commit053d3b9d14b36c63cf4c097ff6ac2c755e5dc30f (patch)
treefa5bc41b9f522b09d674e3b9318774a55f83737d /sys-block
parentapp-crypt/openpgp-keys-bcl: Keys for parted (diff)
downloadgentoo-053d3b9d14b36c63cf4c097ff6ac2c755e5dc30f.tar.gz
gentoo-053d3b9d14b36c63cf4c097ff6ac2c755e5dc30f.tar.bz2
gentoo-053d3b9d14b36c63cf4c097ff6ac2c755e5dc30f.zip
sys-block/parted: Bump to 3.4
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'sys-block')
-rw-r--r--sys-block/parted/Manifest2
-rw-r--r--sys-block/parted/parted-3.4.ebuild66
2 files changed, 68 insertions, 0 deletions
diff --git a/sys-block/parted/Manifest b/sys-block/parted/Manifest
index 50657888893e..1cef4cfba32d 100644
--- a/sys-block/parted/Manifest
+++ b/sys-block/parted/Manifest
@@ -1 +1,3 @@
DIST parted-3.3.tar.xz 1757432 BLAKE2B d1e248cd8fdce22d4957055d65f9f93333505229f92174f343897422a31a43f3d35ea06f8f1bdafd254e4629c5890ec38d6b75d3b499c39a9ada4a8d5f9d9d8f SHA512 d1384694a491aa53bab6206fdeccd1d192de2ed379fe25aa865dd6aa06ed945a728e85b2ccc2fb23f5aa9dfee4a8bd8f0f2be1dd386cb8e8861b73382c6a07e4
+DIST parted-3.4.tar.xz 1860300 BLAKE2B c724d3d1490c62d440b9e5dc359fef7ff623bc77ae5f867d8905245cb279ec391fa07a1a774488ad3bf7a2c477007264d7bab2635a544be8f94dc706a654a711 SHA512 e69bd1b610778e980d4595d04892f2ea1faf4ae9bfc98cd62abfc70066423f08ddaa396f9461c7beb1330d023232274606b6b26091a0458aeedd0f3f57536690
+DIST parted-3.4.tar.xz.sig 508 BLAKE2B 112ad0158b1100bd9150a7c87e8f93e67d42870b82a17d4d0aa8bb5e46306f837f3f99feabaf301f8cd640c299174e5f5acf152dd1f20ea2b7ace73d57d31f14 SHA512 6b11812267e66470ba2908ee1cc78b232b0bc2519787f5a17b92cd5f8ba904b1a836833f19c5244b23d4c7810437eeb26fbbd68fac819391b342709682345472
diff --git a/sys-block/parted/parted-3.4.ebuild b/sys-block/parted/parted-3.4.ebuild
new file mode 100644
index 000000000000..24144f506ea7
--- /dev/null
+++ b/sys-block/parted/parted-3.4.ebuild
@@ -0,0 +1,66 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit flag-o-matic verify-sig
+
+DESCRIPTION="Create, destroy, resize, check, copy partitions and file systems"
+HOMEPAGE="https://www.gnu.org/software/parted/"
+SRC_URI="mirror://gnu/${PN}/${P}.tar.xz
+ verify-sig? ( mirror://gnu/${PN}/${P}.tar.xz.sig )"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86"
+IUSE="+debug device-mapper nls readline"
+
+RDEPEND="
+ >=sys-fs/e2fsprogs-1.27
+ device-mapper? ( >=sys-fs/lvm2-2.02.45 )
+ readline? (
+ >=sys-libs/ncurses-5.7-r7:0=
+ >=sys-libs/readline-5.2:0=
+ )
+ elibc_uclibc? ( dev-libs/libiconv )
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ nls? ( >=sys-devel/gettext-0.12.1-r2 )
+ verify-sig? ( app-crypt/openpgp-keys-bcl )
+ virtual/pkgconfig
+"
+
+VERIFY_SIG_OPENPGP_KEY_PATH=${EPREFIX}/usr/share/openpgp-keys/bcl.asc
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-3.2-po4a-mandir.patch
+ "${FILESDIR}"/${PN}-3.3-atari.patch
+)
+
+src_prepare() {
+ default
+ touch doc/pt_BR/Makefile.in || die
+}
+
+src_configure() {
+ use elibc_uclibc && append-libs -liconv
+ local myconf=(
+ $(use_enable debug)
+ $(use_enable device-mapper)
+ $(use_enable nls)
+ $(use_with readline)
+ --disable-rpath
+ --disable-static
+ )
+ econf "${myconf[@]}"
+}
+
+DOCS=(
+ AUTHORS BUGS ChangeLog NEWS README THANKS TODO doc/{API,FAT,USER.jp}
+)
+
+src_install() {
+ default
+ find "${ED}" -type f -name '*.la' -delete || die
+}