summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2022-04-14 21:56:28 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2022-04-14 21:57:29 -0700
commit1b75cdfa9800fd14a18c64c1bb7770d6dfcc87f0 (patch)
tree3b5723de00a77925e78c89ad97e291c5c0921b5c /sys-block
parentapp-portage/eix: add 0.36.2 (diff)
downloadgentoo-1b75cdfa9800fd14a18c64c1bb7770d6dfcc87f0.tar.gz
gentoo-1b75cdfa9800fd14a18c64c1bb7770d6dfcc87f0.tar.bz2
gentoo-1b75cdfa9800fd14a18c64c1bb7770d6dfcc87f0.zip
sys-block/fio: bump
Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> Closes: https://bugs.gentoo.org/837236
Diffstat (limited to 'sys-block')
-rw-r--r--sys-block/fio/Manifest1
-rw-r--r--sys-block/fio/fio-3.30.ebuild154
2 files changed, 155 insertions, 0 deletions
diff --git a/sys-block/fio/Manifest b/sys-block/fio/Manifest
index 1cf9275b8809..a942bd342da5 100644
--- a/sys-block/fio/Manifest
+++ b/sys-block/fio/Manifest
@@ -1 +1,2 @@
DIST fio-3.27.tar.bz2 960330 BLAKE2B 7e7e01a5c1d6af13a6f87139e7738646cbc8f45ebc370d0c45b9efe1f93778613d374daafc6df459f988f27f2be54ff636235e1e5a92a4a6ecf9a60ed573d170 SHA512 9c5f2ab0c9ac24ab78dbc74fb6c5acd60f8189fdc618f4280992141b6c0abe1c235c373fee18ad0c803e7fb25d480f45aec56dc3be2e0d26d181b3418b179f99
+DIST fio-3.30.tar.bz2 6001772 BLAKE2B a4941cd415e6444bb9871274580efdf82281a1e52dc3caaa235f63176e3564fb1dc08e1e4586c555f9c25975d7e6220fe53209ed7218da713b9cb9135de0fc05 SHA512 1fb2ae9c28028147edabceff734fc41bf07ce504af98afdb0951920b724b15d647f2b0852262c177279ad6b4dbbf24be458db7f939d1c80069e0f8e7bc8aa10d
diff --git a/sys-block/fio/fio-3.30.ebuild b/sys-block/fio/fio-3.30.ebuild
new file mode 100644
index 000000000000..16e488400b63
--- /dev/null
+++ b/sys-block/fio/fio-3.30.ebuild
@@ -0,0 +1,154 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{8,9,10} )
+
+inherit python-r1 toolchain-funcs
+
+MY_PV="${PV/_rc/-rc}"
+MY_P="${PN}-${MY_PV}"
+
+DESCRIPTION="Jens Axboe's Flexible IO tester"
+HOMEPAGE="https://brick.kernel.dk/snaps/"
+SRC_URI="https://brick.kernel.dk/snaps/${MY_P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ia64 ~ppc ~ppc64 ~riscv ~x86"
+IUSE="aio curl glusterfs gnuplot gtk io-uring nfs numa python rbd rdma static tcmalloc test zbc zlib"
+REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )
+ gnuplot? ( python )
+ io-uring? ( aio )"
+RESTRICT="!test? ( test )"
+
+BDEPEND="virtual/pkgconfig"
+
+# GTK+:2 does not offer static libaries.
+LIB_DEPEND="aio? ( dev-libs/libaio[static-libs(+)] )
+ curl? (
+ net-misc/curl:=[static-libs(+)]
+ dev-libs/openssl:0=[static-libs(+)]
+ )
+ nfs? ( net-fs/libnfs:=[static-libs(+)] )
+ glusterfs? ( sys-cluster/glusterfs[static-libs(+)] )
+ gtk? ( dev-libs/glib:2[static-libs(+)] )
+ io-uring? ( sys-libs/liburing:=[static-libs(+)] )
+ numa? ( sys-process/numactl[static-libs(+)] )
+ rbd? ( sys-cluster/ceph[static-libs(+)] )
+ rdma? ( sys-cluster/rdma-core[static-libs(+)] )
+ tcmalloc? ( dev-util/google-perftools:=[static-libs(+)] )
+ zbc? ( >=sys-block/libzbc-5 )
+ zlib? ( sys-libs/zlib[static-libs(+)] )"
+RDEPEND="!static? ( ${LIB_DEPEND//\[static-libs(+)]} )
+ gtk? ( x11-libs/gtk+:2 )"
+DEPEND="${RDEPEND}
+ static? ( ${LIB_DEPEND} )
+ test? ( dev-util/cunit )"
+RDEPEND+="
+ python? (
+ ${PYTHON_DEPS}
+ $(python_gen_any_dep 'dev-python/pandas[${PYTHON_USEDEP}]')
+ )
+ gnuplot? ( sci-visualization/gnuplot )"
+
+S="${WORKDIR}/${MY_P}"
+
+PATCHES=(
+ "${FILESDIR}"/fio-2.2.13-libmtd.patch
+)
+
+python_check_deps() {
+ has_version "dev-python/pandas[${PYTHON_USEDEP}]"
+}
+
+src_prepare() {
+ default
+
+ sed -i '/^DEBUGFLAGS/s: -D_FORTIFY_SOURCE=2::g' Makefile || die
+
+ # Many checks don't have configure flags.
+ sed -i \
+ -e "s:\<pkg-config\>:$(tc-getPKG_CONFIG):" \
+ -e '/if compile_prog "" "-lzbc" "libzbc" *; *then/ '"s::if $(usex zbc true false) ; then:" \
+ -e '/if compile_prog "" "-lz" "zlib" *; *then/ '"s::if $(usex zlib true false) ; then:" \
+ -e '/if compile_prog "" "-laio" "libaio" *; *then/'"s::if $(usex aio true false) ; then:" \
+ -e '/if compile_prog "" "-lcunit" "CUnit" *; *then/'"s::if $(usex test true false) ; then:" \
+ configure || die
+}
+
+src_configure() {
+ chmod g-w "${T}"
+ # not a real configure script
+ # TODO: cuda
+ # TODO: libnbd - not packaged in Gentoo
+ # TODO: pmem - not packaged in Gentoo
+ # libnfs option does not work as expected:
+ # $(usex nfs '' '--disable-libnfs') \
+ set -- \
+ ./configure \
+ --disable-optimizations \
+ --extra-cflags="${CFLAGS} ${CPPFLAGS}" \
+ --cc="$(tc-getCC)" \
+ --disable-pmem \
+ $(usex nfs '' '--disable-nfs') \
+ $(usex curl '' '--disable-http') \
+ $(usex glusterfs '' '--disable-gfapi') \
+ $(usex gtk '--enable-gfio' '') \
+ $(usex numa '' '--disable-numa') \
+ $(usex rbd '' '--disable-rbd') \
+ $(usex rdma '' '--disable-rdma') \
+ $(usex static '--build-static' '') \
+ $(usex tcmalloc '' '--disable-tcmalloc')
+ echo "$@" |tr ' ' '\n'
+ "$@" || die 'configure failed'
+}
+
+src_compile() {
+ emake V=1 OPTFLAGS=
+}
+
+src_install() {
+ emake install DESTDIR="${D}" prefix="${EPREFIX}/usr" mandir="${EPREFIX}/usr/share/man"
+
+ local python2_7_files=(
+ "${ED}"/usr/bin/fiologparser_hist.py
+ "${ED}"/usr/bin/fiologparser.py
+ )
+ local python_files=(
+ "${python2_7_files[@]}"
+ "${ED}"/usr/bin/fio_jsonplus_clat2csv
+ )
+ if use python ; then
+ sed -i 's:python2.7:python:g' "${python2_7_files[@]}" || die
+ python_replicate_script "${python2_7_files[@]}"
+ else
+ rm "${python_files[@]}" || die
+ fi
+
+ local gnuplot_python2_7_files=(
+ "${ED}"/usr/bin/fio2gnuplot
+ )
+ local gnuplot_files=(
+ "${gnuplot_python2_7_files[@]}"
+ "${ED}"/usr/bin/fio_generate_plots
+ "${ED}"/usr/share/man/man1/fio_generate_plots.1
+ "${ED}"/usr/share/man/man1/fio2gnuplot.1
+ "${ED}"/usr/share/fio/*.gpm
+ )
+ if use gnuplot ; then
+ sed -i 's:python2.7:python:g' "${gnuplot_python2_7_files[@]}" || die
+ python_replicate_script "${gnuplot_python2_7_files[@]}"
+ else
+ rm "${gnuplot_files[@]}" || die
+ rmdir "${ED}"/usr/share/fio/ || die
+ fi
+
+ # This tool has security/parallel issues -- it hardcodes /tmp/template.fio.
+ rm "${ED}"/usr/bin/genfio || die
+
+ dodoc README REPORTING-BUGS HOWTO
+ docinto examples
+ dodoc examples/*
+}