summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2023-11-01 23:06:41 -0500
committerMatthew Thode <prometheanfire@gentoo.org>2023-11-01 23:06:57 -0500
commit6b5b9116066915602e4245fe81621b2c0e8d36d7 (patch)
tree900fe076c24b9481e20d15184f211baef0c9ed10 /sys-block
parentapp-containers/podman: add 4.7.2, drop 4.7.{0,1}, update live (diff)
downloadgentoo-6b5b9116066915602e4245fe81621b2c0e8d36d7.tar.gz
gentoo-6b5b9116066915602e4245fe81621b2c0e8d36d7.tar.bz2
gentoo-6b5b9116066915602e4245fe81621b2c0e8d36d7.zip
sys-block/tgt: add 1.0.89
Signed-off-by: Matthew Thode <prometheanfire@gentoo.org>
Diffstat (limited to 'sys-block')
-rw-r--r--sys-block/tgt/Manifest1
-rw-r--r--sys-block/tgt/tgt-1.0.89.ebuild58
2 files changed, 59 insertions, 0 deletions
diff --git a/sys-block/tgt/Manifest b/sys-block/tgt/Manifest
index bf8c33bac127..7ce9f61c5895 100644
--- a/sys-block/tgt/Manifest
+++ b/sys-block/tgt/Manifest
@@ -1,2 +1,3 @@
DIST tgt-1.0.87.tar.gz 304798 BLAKE2B e8772a02078204373dd43276cc5534dd9e8996841bdfef613f34a9c59ef2886f866ff6fb56e6bdaea653b4081b477e1ab15cb3ed3d125b7c08b45ab11a63a7cb SHA512 362adfc92f9fc6528b3de0aa9f202e39f6035b92fe3078236a3f75c0aef540a82cb4594077fdc7de2e524acc75601f5696111cc9aebc6de6265c53cd1d073db2
DIST tgt-1.0.88.tar.gz 305767 BLAKE2B d9a35da5c12ba1621473a04f59ffc85364412443854e4b9d88ba7ae7a7120dbbf6cf233852ef33cca2f19bb67acd54dcdd97041812277cc7eb9359d2483289d4 SHA512 b1ac4da634ff65edfd67cfcbd4509772216ba411b8c389cd209d3abe7c72b19f8e261c627e3ad8343faeebe3d8b758855184b50ab9e635d11c707ba3bb79fe70
+DIST tgt-1.0.89.tar.gz 305773 BLAKE2B c128e307246c938ee9b41fa9d0783cfa488e103f38c8907768bc46ec46dfc6fa7b8aad5e14f43dfd111a5b6590b41ce6cf77683c2dc123ab5917f89e7c3d951c SHA512 4a3f2e1e2a9e98fbb6892fb8171633efd15ce131f0e9294d95a7d8b23b6df739f11529e50ed03869d65a8a84a57f7337901f36e010a770a051caaa7ba2b47e7a
diff --git a/sys-block/tgt/tgt-1.0.89.ebuild b/sys-block/tgt/tgt-1.0.89.ebuild
new file mode 100644
index 000000000000..afca5f425e44
--- /dev/null
+++ b/sys-block/tgt/tgt-1.0.89.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit toolchain-funcs systemd
+
+DESCRIPTION="Linux SCSI target framework (tgt)"
+HOMEPAGE="https://github.com/fujita/tgt"
+SRC_URI="https://github.com/fujita/tgt/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm64 ~hppa ~ia64 ~loong ~ppc ~ppc64 ~riscv ~sparc ~x86"
+IUSE="infiniband rbd selinux"
+
+DEPEND="
+ app-text/docbook-xsl-stylesheets
+ dev-libs/libxslt
+ dev-perl/Config-General
+ rbd? ( sys-cluster/ceph )
+ infiniband? ( sys-cluster/rdma-core )
+"
+RDEPEND="
+ ${DEPEND}
+ dev-libs/libaio
+ sys-apps/sg3_utils
+ selinux? ( sec-policy/selinux-tgtd )
+"
+
+pkg_setup() {
+ tc-export CC
+}
+
+src_prepare() {
+ default
+ sed -i -e 's:\($(CC)\) $^:\1 $(LDFLAGS) $^:' usr/Makefile || die
+ # make sure xml docs are generated before trying to install them
+ sed -i -e "s@install: @& all @g" doc/Makefile || die
+ sed -i -e 's|-Werror||g' usr/Makefile || die
+}
+
+src_compile() {
+ local myconf
+ use infiniband && myconf="${myconf} ISCSI_RDMA=1"
+ use rbd && myconf="${myconf} CEPH_RBD=1"
+
+ emake -C usr/ KERNELSRC="${KERNEL_DIR}" ISCSI=1 ${myconf}
+ emake -C doc
+}
+
+src_install() {
+ emake install-programs install-scripts install-doc DESTDIR="${D}" docdir=/usr/share/doc/${PF}
+ newinitd "${FILESDIR}"/tgtd.initd-new tgtd
+ newconfd "${FILESDIR}"/tgtd.confd-new tgtd
+ systemd_dounit "${S}"/scripts/tgtd.service
+ dodir /etc/tgt
+ keepdir /etc/tgt
+}