summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2023-06-05 06:23:37 +0100
committerSam James <sam@gentoo.org>2023-06-05 06:23:37 +0100
commit6fa6af98b0362bfaba051b1dde9299f77baf2a03 (patch)
tree6b92035c9aa3bb5e71423ff07bc5344498e887b7 /sys-block
parentsci-mathematics/pari: Stabilize 2.15.3 x86, #907855 (diff)
downloadgentoo-6fa6af98b0362bfaba051b1dde9299f77baf2a03.tar.gz
gentoo-6fa6af98b0362bfaba051b1dde9299f77baf2a03.tar.bz2
gentoo-6fa6af98b0362bfaba051b1dde9299f77baf2a03.zip
sys-block/nbd: add 3.25
Drops gznbd support, at least for now, given it doesn't compile and upstream haven't touched the dir in 9 years. Closes: https://bugs.gentoo.org/907831 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'sys-block')
-rw-r--r--sys-block/nbd/Manifest1
-rw-r--r--sys-block/nbd/nbd-3.25.ebuild82
-rw-r--r--sys-block/nbd/nbd-9999.ebuild34
3 files changed, 103 insertions, 14 deletions
diff --git a/sys-block/nbd/Manifest b/sys-block/nbd/Manifest
index acfc433a02e0..163fff181c5e 100644
--- a/sys-block/nbd/Manifest
+++ b/sys-block/nbd/Manifest
@@ -1,2 +1,3 @@
DIST nbd-3.21.tar.xz 523472 BLAKE2B 8601306966b75e5000e34d784175f287553d478e8367d488b9a3c1c11bcb7345a4ba898f02a94b8e927fbded1d3a563a4f0369ad7b49b14dcb6f5ea8d91812f3 SHA512 5dc238e6f45eb230a6f92493a8c3b4891dee98fc47e120e59c3ca31c0a698537ca03f78e43c5e7089d93d548a22b5e3853ba228536d2fc688c3edf4a590fdb3f
DIST nbd-3.24.tar.xz 556928 BLAKE2B a07b0d8ce18cdea2e0778afbf9adfbc49f4fdc5746ec6f304f46d390adfc0a9ffb199e7c5cb6a72b3073a12a37f598e3780f0a1374b25c0e0a546653f7657d28 SHA512 b542733ca8bdfb6883591acd5cc82fd8fa64fed7ca85b01a961e0ad69b9655750e5317df9ec510b4147cc8b0b5cdfa0b43da53dd06c42863553555d710a3c85d
+DIST nbd-3.25.tar.xz 566360 BLAKE2B dce56fb91f6358955b0173b589df19ce2682e3cd6810b0bd74eeb973c24e52307ed55e197c13dcb9c2a62ac92e0dddb046fd1f4348862c7f7dc17bc479ba8cad SHA512 e8b83475a698b5c3718331b55a2c28fd10ca031e347aac7c439f1653d78a405fefa5cb2618e60f73b2f170a8c93d68e79a2cd5875e5c6a970cb1ef9d8e08ebda
diff --git a/sys-block/nbd/nbd-3.25.ebuild b/sys-block/nbd/nbd-3.25.ebuild
new file mode 100644
index 000000000000..a0554e3c6d37
--- /dev/null
+++ b/sys-block/nbd/nbd-3.25.ebuild
@@ -0,0 +1,82 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit systemd
+
+DESCRIPTION="Userland client/server for kernel network block device"
+HOMEPAGE="https://nbd.sourceforge.io/"
+
+if [[ ${PV} == 9999 ]] ; then
+ inherit autotools git-r3
+ EGIT_REPO_URI="https://github.com/NetworkBlockDevice/nbd.git"
+else
+ SRC_URI="https://github.com/NetworkBlockDevice/nbd/releases/download/${P}/${P}.tar.xz"
+ SRC_URI+=" mirror://sourceforge/nbd/${P}.tar.xz"
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+fi
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE="debug gnutls netlink zlib"
+
+RDEPEND="
+ >=dev-libs/glib-2.32.0
+ gnutls? ( >=net-libs/gnutls-2.12.0 )
+ netlink? ( >=dev-libs/libnl-3.1 )
+ zlib? ( sys-libs/zlib )
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ sys-devel/bison
+ virtual/pkgconfig
+"
+
+if [[ ${PV} == 9999 ]] ; then
+ BDEPEND+="
+ app-text/docbook-sgml-dtd:4.5
+ app-text/docbook-sgml-utils
+ sys-devel/autoconf-archive
+ "
+fi
+
+src_prepare() {
+ default
+
+ if [[ ${PV} == 9999 ]] ; then
+ emake -C man -f mans.mk \
+ nbd-server.1.sh.in \
+ nbd-server.5.sh.in \
+ nbd-client.8.sh.in \
+ nbd-trdump.1.sh.in \
+ nbd-trplay.1.sh.in \
+ nbdtab.5.sh.in
+
+ emake -C systemd -f Makefile.am nbd@.service.sh.in
+
+ eautoreconf
+ fi
+}
+
+src_configure() {
+ # Needs Bison
+ unset YACC
+
+ local myeconfargs=(
+ --enable-lfs
+ # https://github.com/NetworkBlockDevice/nbd/issues/149
+ --disable-gznbd
+ $(use_enable !debug syslog)
+ $(use_enable debug)
+ $(use_with gnutls)
+ $(use_with netlink libnl)
+ )
+
+ econf "${myeconfargs[@]}"
+}
+
+src_install() {
+ default
+ systemd_dounit systemd/nbd@.service
+}
diff --git a/sys-block/nbd/nbd-9999.ebuild b/sys-block/nbd/nbd-9999.ebuild
index 72e1b43ee6b1..a0554e3c6d37 100644
--- a/sys-block/nbd/nbd-9999.ebuild
+++ b/sys-block/nbd/nbd-9999.ebuild
@@ -1,37 +1,39 @@
-# Copyright 1999-2022 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
inherit systemd
DESCRIPTION="Userland client/server for kernel network block device"
-HOMEPAGE="https://nbd.sourceforge.net/"
-if [[ ${PV} = 9999 ]] ; then
+HOMEPAGE="https://nbd.sourceforge.io/"
+
+if [[ ${PV} == 9999 ]] ; then
inherit autotools git-r3
EGIT_REPO_URI="https://github.com/NetworkBlockDevice/nbd.git"
else
- SRC_URI="https://github.com/NetworkBlockDevice/nbd/releases/download/${P}/${P}.tar.xz
- mirror://sourceforge/nbd/${P}.tar.xz"
- KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+ SRC_URI="https://github.com/NetworkBlockDevice/nbd/releases/download/${P}/${P}.tar.xz"
+ SRC_URI+=" mirror://sourceforge/nbd/${P}.tar.xz"
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
fi
LICENSE="GPL-2"
SLOT="0"
IUSE="debug gnutls netlink zlib"
-BDEPEND="virtual/pkgconfig"
-
RDEPEND="
- >=dev-libs/glib-2.26.0
+ >=dev-libs/glib-2.32.0
gnutls? ( >=net-libs/gnutls-2.12.0 )
netlink? ( >=dev-libs/libnl-3.1 )
zlib? ( sys-libs/zlib )
"
DEPEND="${RDEPEND}"
-BDEPEND="sys-devel/bison"
+BDEPEND="
+ sys-devel/bison
+ virtual/pkgconfig
+"
-if [[ ${PV} = 9999 ]] ; then
+if [[ ${PV} == 9999 ]] ; then
BDEPEND+="
app-text/docbook-sgml-dtd:4.5
app-text/docbook-sgml-utils
@@ -42,7 +44,7 @@ fi
src_prepare() {
default
- if [[ ${PV} = 9999 ]] ; then
+ if [[ ${PV} == 9999 ]] ; then
emake -C man -f mans.mk \
nbd-server.1.sh.in \
nbd-server.5.sh.in \
@@ -58,11 +60,15 @@ src_prepare() {
}
src_configure() {
+ # Needs Bison
+ unset YACC
+
local myeconfargs=(
--enable-lfs
+ # https://github.com/NetworkBlockDevice/nbd/issues/149
+ --disable-gznbd
$(use_enable !debug syslog)
$(use_enable debug)
- $(use_enable zlib gznbd)
$(use_with gnutls)
$(use_with netlink libnl)
)