summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFrancisco Javier Félix <web@inode64.com>2022-11-18 10:00:31 +0200
committerJoonas Niilola <juippis@gentoo.org>2022-11-18 10:17:54 +0200
commit74904d073233386155e4bf331823c33686f6225c (patch)
tree972b254a0fdb913e6bd771eb9465172c88a4c367 /sys-block
parentwww-apps/hugo: drop 0.101.0-r1 (diff)
downloadgentoo-74904d073233386155e4bf331823c33686f6225c.tar.gz
gentoo-74904d073233386155e4bf331823c33686f6225c.tar.bz2
gentoo-74904d073233386155e4bf331823c33686f6225c.zip
sys-block/storcli: add 7.2405
Closes: https://github.com/gentoo/gentoo/pull/28002 Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'sys-block')
-rw-r--r--sys-block/storcli/Manifest1
-rw-r--r--sys-block/storcli/metadata.xml9
-rw-r--r--sys-block/storcli/storcli-7.2405.ebuild50
3 files changed, 59 insertions, 1 deletions
diff --git a/sys-block/storcli/Manifest b/sys-block/storcli/Manifest
index b858314a1549..814a827040ca 100644
--- a/sys-block/storcli/Manifest
+++ b/sys-block/storcli/Manifest
@@ -15,3 +15,4 @@ DIST storcli-7.1508.zip 35678755 BLAKE2B 9fb8da35be491afaea3a288b5c4c1ed0806fa9d
DIST storcli-7.1613.zip 35016341 BLAKE2B 046651c696e5a20bcd0488c3cb495c7260e7665e3cb93052fce7fc79de019cb310ac7b1615f4ee4cc59a3bddcb81e548b82098a5ba051b1ba94f721115e95ff9 SHA512 5c90bce5502ec725a41c670438acd2e1eb07d21edba6e940f00f568f63a2e9e9095817eb50a4995d1ff8482a60ab77a633f01df0dc0a1abe7b767ce24b38b79b
DIST storcli-7.1715.zip 40965278 BLAKE2B 044cf3e7b7bc9853ce7ff06050c59ceb877e88ffece2f6494561fcd416e00b41d033ff1ffe0e18b63e55edf2443296bdd3f817c09c48a0e0d69365d41cdd43fd SHA512 79dbd5f2ded4897a3d867bbab76d415b8532a647fc12f369f667e11e772b398954a2d762a011c37ab7a18b4759c3c1f8408d129ceb9b1ae62bce4671380eb988
DIST storcli-7.1804.zip 41197159 BLAKE2B ade40bce515a3b1715243877f7b255c368296c153232ec268b95d9a61d79b538403da160c0ecfe20e6d5ab80f1d631fd459fba7391cfeb3041c42ed641474b2f SHA512 fd47759c757f61193fd449cb5ea6d33ccfb9ec239176fa4f4d5997afc62e168f0cd24fe9910d8c8fd3a65d2386fbbaa78ac13d53fca2e82c294eea2f45219a3b
+DIST storcli-7.2405.zip 32082928 BLAKE2B 6c1398745a3234b5183772e0f8ba90977ecec16c5b0e1427792571194e3887192655f309243d9e478984f5b231a5dd4348bfb6c9b929c795cbcaec51f7fb0709 SHA512 91591dd4afb96e9ee53bd3f2940fdc95c7e62c94119229508642771c8a1d223a450ab0dfcc7ed57ce70ad3b9454cb1517a696881d894c11ee493753badbbffcb
diff --git a/sys-block/storcli/metadata.xml b/sys-block/storcli/metadata.xml
index 115e9d64a669..c1c095b73fb8 100644
--- a/sys-block/storcli/metadata.xml
+++ b/sys-block/storcli/metadata.xml
@@ -1,5 +1,12 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
- <!-- maintainer-needed -->
+ <maintainer type="person" proxied="yes">
+ <email>web@inode64.com</email>
+ <name>Francisco Javier Félix</name>
+ </maintainer>
+ <maintainer type="project" proxied="proxy">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
+ </maintainer>
</pkgmetadata>
diff --git a/sys-block/storcli/storcli-7.2405.ebuild b/sys-block/storcli/storcli-7.2405.ebuild
new file mode 100644
index 000000000000..9ba4c0bb1174
--- /dev/null
+++ b/sys-block/storcli/storcli-7.2405.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit rpm
+
+# Upstream is still using strange version numbers
+MY_PV="00${PV}.0000.0000"
+MY_P="${PN}-${MY_PV}"
+MY_PN="STORCLI_SAS3.5_P25"
+DESCRIPTION="MegaRAID StorCLI (successor of the MegaCLI)"
+HOMEPAGE="https://www.broadcom.com/support/download-search?dk=storcli"
+SRC_URI="https://docs.broadcom.com/docs-and-downloads/host-bus-adapters/host-bus-adapters-common-files/sas_sata_nvme_12g_p25/${MY_PN}.zip -> ${P}.zip"
+
+LICENSE="Avago LSI BSD"
+SLOT="0"
+KEYWORDS="-* amd64"
+BDEPEND="app-arch/unzip"
+
+S="${WORKDIR}"
+
+QA_PREBUILT="/opt/MegaRAID/storcli/storcli64"
+
+src_unpack() {
+ default
+ rpm_unpack ./${MY_PN}/univ_viva_cli_rel/Unified_storcli_all_os/Linux/${MY_P}-1.noarch.rpm
+ unzip ./${MY_PN}/univ_viva_cli_rel/Unified_storcli_all_os/JSON-Schema/JSON_SCHEMA_FILES.zip
+}
+
+src_prepare() {
+ default
+
+ sed -i -e 's|/home/|/usr/share/storcli/|g' JSON-Schema/*.json
+}
+
+src_install() {
+ insinto /usr/share/storcli
+ doins JSON-Schema/*.xlsx
+ doins ${MY_PN}/univ_viva_cli_rel/Unified_storcli_all_os/storcliconf.ini
+
+ insinto /usr/share/storcli/JSON-Schema/
+ doins JSON-Schema/*.json
+
+ exeinto /opt/MegaRAID/storcli
+ doexe opt/MegaRAID/storcli/storcli64
+
+ dosym ../../opt/MegaRAID/storcli/storcli64 /usr/sbin/storcli
+ dosym ../../opt/MegaRAID/storcli/storcli64 /usr/sbin/storcli64
+}