summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Deutschmann <whissi@gentoo.org>2021-10-15 16:30:36 +0200
committerThomas Deutschmann <whissi@gentoo.org>2021-10-15 16:33:05 +0200
commit838fa825ce2377abd6f16235b236b4ff550169c0 (patch)
treeeae9ee691b49abb886290ec9c4d984ca0f76e5a7 /sys-block
parentdev-db/mariadb-connector-c: bump to v3.2.4 (diff)
downloadgentoo-838fa825ce2377abd6f16235b236b4ff550169c0.tar.gz
gentoo-838fa825ce2377abd6f16235b236b4ff550169c0.tar.bz2
gentoo-838fa825ce2377abd6f16235b236b4ff550169c0.zip
sys-block/mbuffer: bump to v20211004
Package-Manager: Portage-3.0.28, Repoman-3.0.3 Signed-off-by: Thomas Deutschmann <whissi@gentoo.org>
Diffstat (limited to 'sys-block')
-rw-r--r--sys-block/mbuffer/Manifest1
-rw-r--r--sys-block/mbuffer/mbuffer-20211004.ebuild69
2 files changed, 70 insertions, 0 deletions
diff --git a/sys-block/mbuffer/Manifest b/sys-block/mbuffer/Manifest
index 5f5991794413..891af613e640 100644
--- a/sys-block/mbuffer/Manifest
+++ b/sys-block/mbuffer/Manifest
@@ -1,2 +1,3 @@
DIST mbuffer-20210328.tgz 148009 BLAKE2B b369fdae908cfa239e70d092f512f1613215f1a38e5f2dba9403edeb5579fe14a099f0b9950572c1e294c7d5938bd5a363a1cc3239b4553ecd24c6b805fbfe27 SHA512 69f7cac7fe49a86944092d642c6138455ba95da8e6d00abd41b37d126a9f03c3252e69795c5fb5bf8e56d0ce1461bde6b51f48c5eb7073ee49ee4e6df83d834d
DIST mbuffer-20210829.tgz 148786 BLAKE2B af4d47eab143861a10fa5e9f86cc0066594b675baf37dd63ba71dffb4a22a4bd057ea4a03d50ba210af8c1021dad258a33d46525a11c7cc2ad0dd852839f3b9a SHA512 67b7398c27fb4539d36437b5224a7305216c32af140d5dd9d4af734227bb4bb4c9e8c577e05e315534c5e1cf65a87a9a7a32a212cc4faef17e3c387b3895ef47
+DIST mbuffer-20211004.tgz 149261 BLAKE2B 81427f9684266de53a7e76e33378ff94c9af08768d2105ee1481399d88180c3ef358c21c99716d82ef965ba809e3814029a3c9f844c987ab812d8e5624ba8e67 SHA512 d5914b5c59ec1fee92af6915d8abebc71459461a2d8acd0d93060f3799b5a4104f08d29349b3500553d532a279804d22a40ef0ff001c45a2bdb72d3966c2d7a8
diff --git a/sys-block/mbuffer/mbuffer-20211004.ebuild b/sys-block/mbuffer/mbuffer-20211004.ebuild
new file mode 100644
index 000000000000..b5df3c74c1a2
--- /dev/null
+++ b/sys-block/mbuffer/mbuffer-20211004.ebuild
@@ -0,0 +1,69 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools
+
+DESCRIPTION="M(easuring)buffer is a replacement for buffer with additional functionality"
+HOMEPAGE="https://www.maier-komor.de/mbuffer.html"
+SRC_URI="https://www.maier-komor.de/software/mbuffer/${P}.tgz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~x86"
+IUSE="debug ssl test"
+
+REQUIRED_USE="test? ( ssl )"
+
+RESTRICT="!test? ( test )"
+
+RDEPEND="ssl? (
+ dev-libs/openssl:0=
+ )"
+DEPEND="${RDEPEND}"
+
+PATCHES=(
+ "${FILESDIR}/${PN}-20180410-sysconfdir.patch"
+ "${FILESDIR}/${PN}-20200929-find-OBJDUMP.patch"
+)
+
+src_prepare() {
+ ln -s "${DISTDIR}"/${P}.tgz test.tar #258881
+
+ default
+
+ mv configure.in configure.ac || die
+
+ eautoreconf
+}
+
+src_configure() {
+ local myeconfargs=(
+ $(use_enable ssl md5)
+ $(use_enable debug)
+ )
+ econf "${myeconfargs[@]}"
+}
+
+src_test() {
+ if has usersandbox ${FEATURES} || has network-sandbox ${FEATURES}; then
+ ewarn "Some tests may fail with FEATURES=usersandbox or"
+ ewarn "FEATURES=network-sandbox; Skipping tests because"
+ ewarn "test suite would hang forever in such environments!"
+ return 0;
+ fi
+
+ # Enforce MAKEOPTS=-j1 because src_test() spawns multiple listener
+ # using same port and src_install may have problems (with /etc folder)
+ local -x MAKEOPTS=-j1
+
+ default
+}
+
+pkg_postinst() {
+ if ! has_version "app-arch/mt-st"; then
+ elog ""
+ elog "If you want autoloader support you need to install \"app-arch/mt-st\" in addition!"
+ fi
+}