summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2015-12-17 18:46:40 -0500
committerMike Frysinger <vapier@gentoo.org>2015-12-17 19:00:05 -0500
commit8b462df9b928414beb7271fce8e52fb5bd9d5a08 (patch)
tree0b02d2b6d0b27ab23fb4663c326c834b67d76f99 /sys-block
parentsys-block/open-iscsi: do not use ROOT in src_install (diff)
downloadgentoo-8b462df9b928414beb7271fce8e52fb5bd9d5a08.tar.gz
gentoo-8b462df9b928414beb7271fce8e52fb5bd9d5a08.tar.bz2
gentoo-8b462df9b928414beb7271fce8e52fb5bd9d5a08.zip
sys-block/open-iscsi: fix mishandling of MY_PV
The code to set up MY_PV was based on MY_PV which mean successive env loads would generate an incorrect value. Drop the loading of it (as the default PV is what we want) and rename the var to MY_P as that is what it actually represents.
Diffstat (limited to 'sys-block')
-rw-r--r--sys-block/open-iscsi/open-iscsi-2.0.873.ebuild6
1 files changed, 3 insertions, 3 deletions
diff --git a/sys-block/open-iscsi/open-iscsi-2.0.873.ebuild b/sys-block/open-iscsi/open-iscsi-2.0.873.ebuild
index 43baf5276e4a..e3e161b3b67a 100644
--- a/sys-block/open-iscsi/open-iscsi-2.0.873.ebuild
+++ b/sys-block/open-iscsi/open-iscsi-2.0.873.ebuild
@@ -6,11 +6,11 @@ EAPI=5
inherit versionator linux-info eutils flag-o-matic toolchain-funcs
-MY_PV="${PN}-$(replace_version_separator 2 "-" $MY_PV)"
+MY_P="${PN}-$(replace_version_separator 2 "-")"
DESCRIPTION="Open-iSCSI is a high performance, transport independent, multi-platform implementation of RFC3720"
HOMEPAGE="http://www.open-iscsi.org/"
-SRC_URI="http://www.open-iscsi.org/bits/${MY_PV}.tar.gz"
+SRC_URI="http://www.open-iscsi.org/bits/${MY_P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
@@ -22,7 +22,7 @@ RDEPEND="${DEPEND}
sys-fs/lsscsi
sys-apps/util-linux"
-S="${WORKDIR}/${MY_PV}"
+S="${WORKDIR}/${MY_P}"
pkg_setup() {
linux-info_pkg_setup