summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Deutschmann <whissi@gentoo.org>2021-07-24 15:37:09 +0200
committerThomas Deutschmann <whissi@gentoo.org>2021-07-24 15:37:09 +0200
commite1ba4b3b35174502ea3ee39c11661680579beae4 (patch)
tree98333c4c16288056cb73d047daf0aed1750d9927 /sys-block
parentsys-libs/glibc: also find ld.so on arm64 in the last-minute checks (diff)
downloadgentoo-e1ba4b3b35174502ea3ee39c11661680579beae4.tar.gz
gentoo-e1ba4b3b35174502ea3ee39c11661680579beae4.tar.bz2
gentoo-e1ba4b3b35174502ea3ee39c11661680579beae4.zip
sys-block/storcli: bump to v7.1804
Package-Manager: Portage-3.0.21, Repoman-3.0.3 Signed-off-by: Thomas Deutschmann <whissi@gentoo.org>
Diffstat (limited to 'sys-block')
-rw-r--r--sys-block/storcli/Manifest1
-rw-r--r--sys-block/storcli/storcli-7.1804.ebuild61
2 files changed, 62 insertions, 0 deletions
diff --git a/sys-block/storcli/Manifest b/sys-block/storcli/Manifest
index f8c83e5e75a5..b858314a1549 100644
--- a/sys-block/storcli/Manifest
+++ b/sys-block/storcli/Manifest
@@ -14,3 +14,4 @@ DIST storcli-7.1410.zip 34424559 BLAKE2B cb0b613d0ccbf6ac36d1aace9174286ffe89d06
DIST storcli-7.1508.zip 35678755 BLAKE2B 9fb8da35be491afaea3a288b5c4c1ed0806fa9d6831e9a6dbf14d4c00469b1ce6e9d8fe9a98ce64505580420b5c145f002338d3029794af4c54779d9f324ec56 SHA512 43565cc695e9e7a7725474ab8091ea00de8fde7fabffe708c45e4c0e8713b1fcb1a5a25963bba44974b7787bebc06a59f3b8180416fefb0a54b4fd403c6152be
DIST storcli-7.1613.zip 35016341 BLAKE2B 046651c696e5a20bcd0488c3cb495c7260e7665e3cb93052fce7fc79de019cb310ac7b1615f4ee4cc59a3bddcb81e548b82098a5ba051b1ba94f721115e95ff9 SHA512 5c90bce5502ec725a41c670438acd2e1eb07d21edba6e940f00f568f63a2e9e9095817eb50a4995d1ff8482a60ab77a633f01df0dc0a1abe7b767ce24b38b79b
DIST storcli-7.1715.zip 40965278 BLAKE2B 044cf3e7b7bc9853ce7ff06050c59ceb877e88ffece2f6494561fcd416e00b41d033ff1ffe0e18b63e55edf2443296bdd3f817c09c48a0e0d69365d41cdd43fd SHA512 79dbd5f2ded4897a3d867bbab76d415b8532a647fc12f369f667e11e772b398954a2d762a011c37ab7a18b4759c3c1f8408d129ceb9b1ae62bce4671380eb988
+DIST storcli-7.1804.zip 41197159 BLAKE2B ade40bce515a3b1715243877f7b255c368296c153232ec268b95d9a61d79b538403da160c0ecfe20e6d5ab80f1d631fd459fba7391cfeb3041c42ed641474b2f SHA512 fd47759c757f61193fd449cb5ea6d33ccfb9ec239176fa4f4d5997afc62e168f0cd24fe9910d8c8fd3a65d2386fbbaa78ac13d53fca2e82c294eea2f45219a3b
diff --git a/sys-block/storcli/storcli-7.1804.ebuild b/sys-block/storcli/storcli-7.1804.ebuild
new file mode 100644
index 000000000000..f3cd616aa398
--- /dev/null
+++ b/sys-block/storcli/storcli-7.1804.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="7"
+
+inherit pax-utils toolchain-funcs
+
+# Upstream is still using strange version numbers
+MY_PV="00${PV}.0000.0000"
+
+DESCRIPTION="MegaRAID StorCLI (successor of the MegaCLI)"
+HOMEPAGE="https://www.broadcom.com/support/download-search?dk=storcli"
+SRC_URI="https://docs.broadcom.com/docs-and-downloads/raid-controllers/raid-controllers-common-files/${MY_PV}_Unified_StorCLI-PUL.zip -> ${P}.zip"
+
+LICENSE="Avago LSI BSD"
+SLOT="0/${PV:0:4}"
+KEYWORDS="-* amd64"
+IUSE=""
+
+RDEPEND=""
+DEPEND="app-arch/unzip"
+
+MY_STORCLI_BASEDIR="/opt/lsi/storcli"
+
+QA_PRESTRIPPED="${MY_STORCLI_BASEDIR:1}/storcli
+ ${MY_STORCLI_BASEDIR:1}/storcli32"
+QA_PREBUILT=${QA_PRESTRIPPED}
+
+src_unpack() {
+ mkdir srcfiles || die
+ pushd srcfiles &>/dev/null || die
+ default
+ mv Unified_storcli_all_os/Ubuntu/storcli_*.deb "${WORKDIR}" || die "Failed to move storcli_*.deb"
+ popd &>/dev/null || die
+
+ rm -rf srcfiles || die
+
+ # Unpack Ubuntu package which will be our $S content
+ unpack "${WORKDIR}"/storcli_*.deb
+ rm -f storcli_*.deb || die "Failed to cleanup storcli_*.deb package"
+ unpack "${WORKDIR}"/data.tar.xz
+
+ mkdir "${S}" || die "Failed to create '${S}'"
+}
+
+src_prepare() {
+ default
+
+ # Create clean $S
+ mv "${WORKDIR}"/opt/Mega*/storcli/* "${S}" || die "Failed to move storcli_.deb content to '${S}'"
+ rm -rf "${WORKDIR}"/{opt,control.tar.gz,data.tar.gz,debian-binary} || die "Failed to cleanup no longer needed files"
+}
+
+src_install() {
+ exeinto "${MY_STORCLI_BASEDIR}"
+ newexe storcli64 storcli
+
+ dosym "${MY_STORCLI_BASEDIR}"/storcli /usr/sbin/storcli
+
+ pax-mark m "${D}${MY_STORCLI_BASEDIR}"/storcli
+}