summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2021-09-18 12:50:26 -0700
committerMatt Turner <mattst88@gentoo.org>2021-09-18 12:53:18 -0700
commit80a4374e46c3ff5ec7c4fb455396e804e4b20325 (patch)
tree002a4e0ae3282a6eb2e20b4e70cd34ec6a803942 /sys-boot/aboot
parentsys-devel/automake: Stabilize 1.16.4 sparc, #813696 (diff)
downloadgentoo-80a4374e46c3ff5ec7c4fb455396e804e4b20325.tar.gz
gentoo-80a4374e46c3ff5ec7c4fb455396e804e4b20325.tar.bz2
gentoo-80a4374e46c3ff5ec7c4fb455396e804e4b20325.zip
sys-boot/aboot: Version bump to 2.0_pre20210801
Closes: https://bugs.gentoo.org/813001 Signed-off-by: Matt Turner <mattst88@gentoo.org>
Diffstat (limited to 'sys-boot/aboot')
-rw-r--r--sys-boot/aboot/Manifest1
-rw-r--r--sys-boot/aboot/aboot-2.0_pre20210801.ebuild69
-rw-r--r--sys-boot/aboot/aboot-9999.ebuild2
3 files changed, 71 insertions, 1 deletions
diff --git a/sys-boot/aboot/Manifest b/sys-boot/aboot/Manifest
index b25b4ab2df86..e06ee93fc07a 100644
--- a/sys-boot/aboot/Manifest
+++ b/sys-boot/aboot/Manifest
@@ -1,3 +1,4 @@
DIST aboot-1.0_pre20040408.tar.bz2 115062 BLAKE2B 49f1b45abcd4726fd036e24709d10bbfea42cee03293e31b2deb3aec383c1c438602aa97d3909516ec9864986dfcf82612fe7644b47e3e2760bdf377313446a0 SHA512 b1fff7ce806336f89efe8239108a8547053f22727cba93cea742995432c4f35133f8dc619588390ba6e0d114e2fd62b80b730443e6c18900aa2a8832ddd4ebfc
+DIST aboot-2.0_pre20210801.tar.gz 173477 BLAKE2B 54c38a98b9e3e956f08b4fcca6a4f3351364d7774a915916aae8af67237982635a2686c1df0628fc28dcc2443da8ad57be822c8530e1580261c60dde73f00519 SHA512 57181897147bba65e8b216af262bf2d2e57cb76bd809d8207439dbfbe84ff550cf9a43c0f10f9925e54ca21660cfe9441c7607743ff3f7613c1e22e219708081
DIST aboot_gentoo.diff.bz2 9527 BLAKE2B 2492b456f7411630b6ecfb19db775969b69a35c0ef31b2146fd353aac78cf4d3c9ef2162cf54ab4ac025c65607219b3a33a74d2105be196e6dda54dd2509c1f8 SHA512 868a73fee56e9bf6d986175a6a4dc321ed12fb78d74dfb8f1a3e35274577ddc9ea0820768b44836403587b3976ad8dacdcf6562a9ce5c45981c752670901155f
DIST gentoo-headers-base-2.6.22.tar.bz2 4700338 BLAKE2B a264d7999ed7735e42ea21f8cf96b60ca1bdbfcb76dbdfcba14a849043e1f6a9109cd72bf5b91b9ab877dc3025ce6a9270ea914cf277b8f77cecff703646a7ec SHA512 99849928eede0c4b101ddc9179c0974cac6b4f18803dc98b72dcbe80cea88d3062f709beaa1b890edbed9c147be0dd516065d4cee945164b5d9f19f7a3cf249d
diff --git a/sys-boot/aboot/aboot-2.0_pre20210801.ebuild b/sys-boot/aboot/aboot-2.0_pre20210801.ebuild
new file mode 100644
index 000000000000..a54f3bb78897
--- /dev/null
+++ b/sys-boot/aboot/aboot-2.0_pre20210801.ebuild
@@ -0,0 +1,69 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit toolchain-funcs
+
+if [[ ${PV} = 9999* ]]; then
+ EGIT_REPO_URI="https://github.com/mattst88/${PN}.git"
+ inherit git-r3
+else
+ COMMIT_ID="dde7f7b85f7631668f1da7c0b0ecf7ddbbde004e"
+ SRC_URI="https://github.com/mattst88/${PN}/archive/${COMMIT_ID}.tar.gz -> ${P}.tar.gz"
+ S="${WORKDIR}/${PN}-${COMMIT_ID}"
+ KEYWORDS="-* ~alpha"
+fi
+
+DESCRIPTION="Alpha Linux boot loader for SRM"
+HOMEPAGE="https://github.com/mattst88/aboot https://sourceforge.net/projects/aboot/"
+
+LICENSE="GPL-2"
+SLOT="0"
+
+BDEPEND="app-text/docbook-sgml-utils"
+
+src_compile() {
+ emake AR=$(tc-getAR) CC=$(tc-getCC) LD=$(tc-getLD) \
+ all netabootwrap
+
+ einfo "Building man pages"
+ emake -C doc/man
+}
+
+src_install() {
+ dodir /boot /sbin /usr/share/man/man{1,5,8}
+ emake root="${D}" install
+
+ insinto /boot
+ doins net_aboot.nh
+ dobin netabootwrap
+ dodoc ChangeLog INSTALL README TODO aboot.conf
+
+ insinto /etc
+ newins "${FILESDIR}"/aboot.conf aboot.conf.example
+
+}
+
+pkg_postinst() {
+ einfo "To make aboot install a new bootloader on your harddisk follow"
+ einfo "these steps:"
+ einfo ""
+ einfo " - edit the file /etc/aboot.conf"
+ einfo " - cd /boot"
+ einfo " - swriteboot -c2 /dev/sda bootlx"
+ einfo " This will install a new bootsector on /dev/sda and aboot will"
+ einfo " use the second partition on this device to lookup kernel and "
+ einfo " initrd (as described in the aboot.conf file)"
+ einfo ""
+ einfo "IMPORTANT :"
+ einfo ""
+ einfo "The partition table of your boot device has to contain "
+ einfo "a BSD-DISKLABEL and the first 12 megabytes of your boot device"
+ einfo "must not be part of a partition as aboot will write its bootloader"
+ einfo "in there and not as with most x86 bootloaders into the "
+ einfo "master boot sector. If your partition table does not reflect this"
+ einfo "you are going to destroy your installation !"
+ einfo "Also note that aboot currently only supports ext2/3 partitions"
+ einfo "to boot from."
+} \ No newline at end of file
diff --git a/sys-boot/aboot/aboot-9999.ebuild b/sys-boot/aboot/aboot-9999.ebuild
index d3e6321ec031..2e29e829936e 100644
--- a/sys-boot/aboot/aboot-9999.ebuild
+++ b/sys-boot/aboot/aboot-9999.ebuild
@@ -9,7 +9,7 @@ if [[ ${PV} = 9999* ]]; then
EGIT_REPO_URI="https://github.com/mattst88/${PN}.git"
inherit git-r3
else
- SRC_URI="https://github.com/anholt/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+ SRC_URI="https://github.com/mattst88/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
KEYWORDS="-* ~alpha"
fi