summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2017-01-04 13:35:52 +0200
committerDavid Seifert <soap@gentoo.org>2017-01-04 13:40:32 +0200
commiteccf574f16c76954aea90e08575b04eb13229e69 (patch)
tree0f1707c00766170deccdba827d869e9a05f0b000 /sys-boot/cromwell-bin/cromwell-bin-2.40-r1.ebuild
parentsys-boot/cromwell-bin: update HOMEPAGE, #472076 (diff)
downloadgentoo-eccf574f16c76954aea90e08575b04eb13229e69.tar.gz
gentoo-eccf574f16c76954aea90e08575b04eb13229e69.tar.bz2
gentoo-eccf574f16c76954aea90e08575b04eb13229e69.zip
sys-boot/cromwell-bin: Port to EAPI=6
Package-Manager: Portage-2.3.3, Repoman-2.3.1
Diffstat (limited to 'sys-boot/cromwell-bin/cromwell-bin-2.40-r1.ebuild')
-rw-r--r--sys-boot/cromwell-bin/cromwell-bin-2.40-r1.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/sys-boot/cromwell-bin/cromwell-bin-2.40-r1.ebuild b/sys-boot/cromwell-bin/cromwell-bin-2.40-r1.ebuild
new file mode 100644
index 000000000000..7e08e63a21ae
--- /dev/null
+++ b/sys-boot/cromwell-bin/cromwell-bin-2.40-r1.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+inherit mount-boot
+
+DESCRIPTION="Xbox boot loader precompiled binaries from xbox-linux.org"
+HOMEPAGE="https://sourceforge.net/projects/xbox-linux/"
+SRC_URI="mirror://sourceforge/xbox-linux/cromwell-${PV}.tar.gz"
+LICENSE="GPL-2"
+
+SLOT="0"
+KEYWORDS="-* x86"
+IUSE=""
+RESTRICT="${RESTRICT} strip"
+
+DEPEND=""
+RDEPEND=""
+
+S=${WORKDIR}/cromwell-${PV}
+
+src_install () {
+ dodir /boot/${PN}
+ insinto /boot/${PN}
+ doins cromwell{,_1024}.bin xromwell.xbe
+}