summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Gilbert <floppym@gentoo.org>2022-05-30 16:49:58 -0400
committerMike Gilbert <floppym@gentoo.org>2022-05-30 16:52:18 -0400
commitd06fd5424d9027cae92f58505404114bb2fc9216 (patch)
tree55b794f8d01cc820bcc6014e0a4e82da43f22c20 /sys-boot/gnu-efi/gnu-efi-3.0.14.ebuild
parentdev-python/sphinx_rtd_theme: Enable py3.11 (diff)
downloadgentoo-d06fd5424d9027cae92f58505404114bb2fc9216.tar.gz
gentoo-d06fd5424d9027cae92f58505404114bb2fc9216.tar.bz2
gentoo-d06fd5424d9027cae92f58505404114bb2fc9216.zip
sys-boot/gnu-efi: add REQUIRED_USE for ABI_X86 flags
Signed-off-by: Mike Gilbert <floppym@gentoo.org>
Diffstat (limited to 'sys-boot/gnu-efi/gnu-efi-3.0.14.ebuild')
-rw-r--r--sys-boot/gnu-efi/gnu-efi-3.0.14.ebuild12
1 files changed, 8 insertions, 4 deletions
diff --git a/sys-boot/gnu-efi/gnu-efi-3.0.14.ebuild b/sys-boot/gnu-efi/gnu-efi-3.0.14.ebuild
index 76d4ef4d4221..ca53e5d6897f 100644
--- a/sys-boot/gnu-efi/gnu-efi-3.0.14.ebuild
+++ b/sys-boot/gnu-efi/gnu-efi-3.0.14.ebuild
@@ -18,6 +18,10 @@ LICENSE="GPL-2+ BSD BSD-2"
SLOT="0"
KEYWORDS="-* ~amd64 ~arm ~arm64 ~ia64 ~riscv ~x86"
IUSE="abi_x86_32 abi_x86_64 custom-cflags"
+REQUIRED_USE="
+ amd64? ( || ( abi_x86_32 abi_x86_64 ) )
+ x86? ( || ( abi_x86_32 abi_x86_64 ) )
+"
# These objects get run early boot (i.e. not inside of Linux),
# so doing these QA checks on them doesn't make sense.
@@ -63,18 +67,18 @@ src_compile() {
unset CFLAGS CPPFLAGS LDFLAGS
fi
- if [[ ${CHOST} == x86_64* ]]; then
+ if use amd64 || use x86; then
use abi_x86_32 && CHOST=i686 ABI=x86 efimake
- use abi_x86_64 && efimake
+ use abi_x86_64 && CHOST=x86_64 ABI=amd64 efimake
else
efimake
fi
}
src_install() {
- if [[ ${CHOST} == x86_64* ]]; then
+ if use amd64 || use x86; then
use abi_x86_32 && CHOST=i686 ABI=x86 efimake INSTALLROOT="${D}" install
- use abi_x86_64 && efimake INSTALLROOT="${D}" install
+ use abi_x86_64 && CHOST=x86_64 ABI=amd64 efimake INSTALLROOT="${D}" install
else
efimake INSTALLROOT="${D}" install
fi