summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorConrad Kostecki <conikost@gentoo.org>2022-02-09 22:39:23 +0100
committerConrad Kostecki <conikost@gentoo.org>2022-02-09 23:56:46 +0100
commitb62843bb1feb6e778c2bb8abcec99790e76fe764 (patch)
tree1cb9caf6ecbbfbb54451a0b3fd4197571ccf9e7b /sys-boot/netboot
parentsys-boot/netboot: update EAPI 7 -> 8 (diff)
downloadgentoo-b62843bb1feb6e778c2bb8abcec99790e76fe764.tar.gz
gentoo-b62843bb1feb6e778c2bb8abcec99790e76fe764.tar.bz2
gentoo-b62843bb1feb6e778c2bb8abcec99790e76fe764.zip
sys-boot/netboot: drop 0.10.2-r2
Signed-off-by: Conrad Kostecki <conikost@gentoo.org>
Diffstat (limited to 'sys-boot/netboot')
-rw-r--r--sys-boot/netboot/netboot-0.10.2-r2.ebuild78
1 files changed, 0 insertions, 78 deletions
diff --git a/sys-boot/netboot/netboot-0.10.2-r2.ebuild b/sys-boot/netboot/netboot-0.10.2-r2.ebuild
deleted file mode 100644
index 13f09cb9284e..000000000000
--- a/sys-boot/netboot/netboot-0.10.2-r2.ebuild
+++ /dev/null
@@ -1,78 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-inherit toolchain-funcs
-
-DESCRIPTION="Allows to remote boot a computer over an IP network"
-HOMEPAGE="http://netboot.sourceforge.net/"
-SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
-
-LICENSE="GPL-2+"
-SLOT="0"
-KEYWORDS="amd64 x86"
-IUSE="berkdb +bootrom +lzo odbc static-libs"
-
-DEPEND="
- berkdb? ( sys-libs/db:= )
- lzo? ( dev-libs/lzo:2= )
- odbc? ( dev-db/unixODBC:= )
-"
-
-RDEPEND="${DEPEND}"
-
-PATCHES=(
- "${FILESDIR}/${P}-ldflags.patch"
- "${FILESDIR}/${P}-slibtool.patch"
-)
-
-src_prepare() {
- default
-
- # Don't install support binaries into libdir
- sed -e "152s:nblibdir:bindir:" -e "153s:nblibdir:bindir:" -i misc/Makefile || die
-
- # Don't install perl script into libdir
- sed -e 's/nblibdir/nbmiscdir/g' -i mknbi-dos/utils/Makefile || die
-
- # Don't install vim syntax file, as it will be installed manually
- sed -e '/mgl.vim/d' -i mknbi-mgl/Makefile || die
-}
-
-src_configure() {
- local myeconfargs=(
- --datadir="/usr/share/netboot"
- $(use_with berkdb berkeley-db)
- $(use_enable bootrom)
- $(use_with lzo)
- $(use_with odbc)
- $(use_enable static-libs static)
- # Disable compilation of 16-bit assembler files,
- # since it's broken on x86 and not supported on x86_64.
- --with-gnu-as86="no"
- --with-gnu-cc86="no"
- --with-gnu-ld86="no"
- )
-
- econf "${myeconfargs[@]}"
-}
-
-src_compile() {
- # mknbi fails with parallel build
- emake -j1
-}
-
-src_install() {
- emake DESTDIR="${ED}" install
-
- insinto /usr/share/vim/vimfiles/syntax
- doins "${S}"/mknbi-mgl/misc/mgl.vim
-
- dodoc README doc/{HISTORY,PROBLEMS,README.*,Spec.doc}
-
- docinto flashcard
- dodoc FlashCard/README FlashCard/*.ps
-
- find "${D}" -name '*.la' -type f -delete || die
-}