summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2017-02-15 09:00:49 +0100
committerJeroen Roovers <jer@gentoo.org>2017-02-15 09:02:38 +0100
commit32ac85adf155318234f9dcd4e250a9e0d7a27d41 (patch)
treeefa299f8b6b5c4aa837b7856766b427df45a80ef /sys-boot/palo/palo-1.97.ebuild
parentdev-libs/Ice: fix installation with USE=ruby, bug 605942, fix building with l... (diff)
downloadgentoo-32ac85adf155318234f9dcd4e250a9e0d7a27d41.tar.gz
gentoo-32ac85adf155318234f9dcd4e250a9e0d7a27d41.tar.bz2
gentoo-32ac85adf155318234f9dcd4e250a9e0d7a27d41.zip
sys-boot/palo: Version bump.
Package-Manager: Portage-2.3.3, Repoman-2.3.1
Diffstat (limited to 'sys-boot/palo/palo-1.97.ebuild')
-rw-r--r--sys-boot/palo/palo-1.97.ebuild43
1 files changed, 43 insertions, 0 deletions
diff --git a/sys-boot/palo/palo-1.97.ebuild b/sys-boot/palo/palo-1.97.ebuild
new file mode 100644
index 000000000000..d0d7b6f5f950
--- /dev/null
+++ b/sys-boot/palo/palo-1.97.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+inherit eutils flag-o-matic toolchain-funcs
+
+DESCRIPTION="PALO : PArisc Linux Loader"
+HOMEPAGE="http://parisc-linux.org/ https://parisc.wiki.kernel.org/"
+SRC_URI="mirror://debian/pool/main/p/${PN}/${P/-/_}.tar.xz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="-* ~hppa"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-1.96-toolchain.patch
+)
+
+src_compile() {
+ local target
+ for target in '-C palo' '-C ipl' 'iplboot'; do
+ emake AR=$(tc-getAR) CC=$(tc-getCC) LD=$(tc-getLD) ${target}
+ done
+}
+
+src_install() {
+ into /
+ dosbin palo/palo
+
+ doman palo.8
+ dodoc TODO debian/changelog README.html
+
+ insinto /etc
+ doins "${FILESDIR}"/palo.conf
+
+ insinto /usr/share/palo
+ doins iplboot
+
+ insinto /etc/kernel/postinst.d/
+ insopts -m 0744
+ doins "${FILESDIR}"/99palo
+}