summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2018-01-15 18:40:45 +0100
committerJeroen Roovers <jer@gentoo.org>2018-01-15 18:41:06 +0100
commit59b8c1b0cb11fd128e18b7d612edee0eda764150 (patch)
treefb5ebd965d1cf84d4ef101fab039c2f67a45c32a /sys-boot/palo/palo-2.00.ebuild
parentnet-analyzer/ostinato: bump and bug #602098 (diff)
downloadgentoo-59b8c1b0cb11fd128e18b7d612edee0eda764150.tar.gz
gentoo-59b8c1b0cb11fd128e18b7d612edee0eda764150.tar.bz2
gentoo-59b8c1b0cb11fd128e18b7d612edee0eda764150.zip
sys-boot/palo: Version 2.00.
Package-Manager: Portage-2.3.19, Repoman-2.3.6
Diffstat (limited to 'sys-boot/palo/palo-2.00.ebuild')
-rw-r--r--sys-boot/palo/palo-2.00.ebuild42
1 files changed, 42 insertions, 0 deletions
diff --git a/sys-boot/palo/palo-2.00.ebuild b/sys-boot/palo/palo-2.00.ebuild
new file mode 100644
index 000000000000..db1c24ddc6bb
--- /dev/null
+++ b/sys-boot/palo/palo-2.00.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit eutils flag-o-matic toolchain-funcs
+
+DESCRIPTION="PALO : PArisc Linux Loader"
+HOMEPAGE="http://parisc-linux.org/ https://parisc.wiki.kernel.org/"
+SRC_URI="https://git.kernel.org/pub/scm/linux/kernel/git/deller/${PN}.git/snapshot/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="-* ~hppa"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-2.00-toolchain.patch
+)
+
+src_compile() {
+ local target
+ for target in '-C palo' '-C ipl' 'iplboot'; do
+ emake AR=$(tc-getAR) CC=$(tc-getCC) LD=$(tc-getLD) ${target}
+ done
+}
+
+src_install() {
+ into /
+ dosbin palo/palo
+
+ doman palo.8
+ dodoc TODO debian/changelog README.html
+
+ insinto /etc
+ doins "${FILESDIR}"/palo.conf
+
+ insinto /usr/share/palo
+ doins iplboot
+
+ insinto /etc/kernel/postinst.d/
+ insopts -m 0744
+ doins "${FILESDIR}"/99palo
+}