summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2016-10-10 10:33:15 +0200
committerJeroen Roovers <jer@gentoo.org>2016-10-10 10:33:15 +0200
commitcd343d2a2daaa4690372f971a3b6e0773dc69110 (patch)
tree1c594bec7698fd8bcaaa076be52c955df5969c21 /sys-boot/palo
parentdev-python/python-xlib: version bump to 0.17. (diff)
downloadgentoo-cd343d2a2daaa4690372f971a3b6e0773dc69110.tar.gz
gentoo-cd343d2a2daaa4690372f971a3b6e0773dc69110.tar.bz2
gentoo-cd343d2a2daaa4690372f971a3b6e0773dc69110.zip
sys-boot/palo: Version bump.
Package-Manager: portage-2.3.1
Diffstat (limited to 'sys-boot/palo')
-rw-r--r--sys-boot/palo/Manifest1
-rw-r--r--sys-boot/palo/files/palo-1.96-toolchain.patch11
-rw-r--r--sys-boot/palo/palo-1.96.ebuild43
3 files changed, 55 insertions, 0 deletions
diff --git a/sys-boot/palo/Manifest b/sys-boot/palo/Manifest
index d133cd9cb493..f88dd22e2a57 100644
--- a/sys-boot/palo/Manifest
+++ b/sys-boot/palo/Manifest
@@ -1 +1,2 @@
DIST palo_1.95.tar.xz 102884 SHA256 c168df0255e83f06cf5ae4fd5266f9ee51ba3e9412a9c1bf3131ecff52cec9e8 SHA512 91960a7bbf5a4985809a082d4e75ee25670f6030e701bc106807de4f89c3617e47cf39ef857684b62dcaf906571f6f095b3caa371793754495567f4a14cc8a9d WHIRLPOOL cdf119aa0892fecce4c4dae73053dd9f3c9745a17276012b1d6fb649e3e55eea561dec8f40feb52fb6477f5b289a61844d39c0d8d0ab2ba2a2501c1323b28305
+DIST palo_1.96.tar.xz 102480 SHA256 c5ea19dc90834266cf6cbd576c007899ef6628b843ab16c57ed98eecb6e72cf8 SHA512 d287cae0995f4c1f519fac5a83a5f71645b1382c6fbf5117ab416240adda5227bb58eb33ad384b84dfb2622af76948b48f1ccf83fa408e9d2d1c4fe7fbed299f WHIRLPOOL de57336608c2aa0d9b487e0d6cfac05ba608a6c24ed4c0acf59d7027b667cc161616ac3520afc974fa2c8496d93d2025e2dfa353118a941a356cde5a28bb62bc
diff --git a/sys-boot/palo/files/palo-1.96-toolchain.patch b/sys-boot/palo/files/palo-1.96-toolchain.patch
new file mode 100644
index 000000000000..e0ea92643509
--- /dev/null
+++ b/sys-boot/palo/files/palo-1.96-toolchain.patch
@@ -0,0 +1,11 @@
+--- a/palo/Makefile
++++ b/palo/Makefile
+@@ -34,7 +33,7 @@
+ $(CC) $(CFLAGS) $(LDFLAGS) -o palo palo.a build.o
+
+ palo.a: $(OFILES)
+- ar rv palo.a $?
++ $(AR) rv palo.a $?
+
+ mkbootable: $(OFILES2)
+ $(CC) $(CFLAGS) $(LDFLAGS) -o mkbootable $(OFILES2)
diff --git a/sys-boot/palo/palo-1.96.ebuild b/sys-boot/palo/palo-1.96.ebuild
new file mode 100644
index 000000000000..801287873a8d
--- /dev/null
+++ b/sys-boot/palo/palo-1.96.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+inherit eutils flag-o-matic toolchain-funcs
+
+DESCRIPTION="PALO : PArisc Linux Loader"
+HOMEPAGE="http://parisc-linux.org/ https://parisc.wiki.kernel.org/"
+SRC_URI="mirror://debian/pool/main/p/${PN}/${P/-/_}.tar.xz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="-* ~hppa"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-1.96-toolchain.patch
+)
+
+src_compile() {
+ local target
+ for target in '-C palo' '-C ipl' 'iplboot'; do
+ emake AR=$(tc-getAR) CC=$(tc-getCC) LD=$(tc-getLD) ${target}
+ done
+}
+
+src_install() {
+ into /
+ dosbin palo/palo
+
+ doman palo.8
+ dodoc TODO debian/changelog README.html
+
+ insinto /etc
+ doins "${FILESDIR}"/palo.conf
+
+ insinto /usr/share/palo
+ doins iplboot
+
+ insinto /etc/kernel/postinst.d/
+ insopts -m 0744
+ doins "${FILESDIR}"/99palo
+}