summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2019-09-06 08:22:01 +0200
committerJeroen Roovers <jer@gentoo.org>2019-09-06 08:22:38 +0200
commitd9e24583a7a35190736893262ce42bac6105a323 (patch)
treeba36918ba2d435ded24f817733d4814ac8d9ae5b /sys-boot/palo
parentsys-fs/btrfs-progs: Removed old (diff)
downloadgentoo-d9e24583a7a35190736893262ce42bac6105a323.tar.gz
gentoo-d9e24583a7a35190736893262ce42bac6105a323.tar.bz2
gentoo-d9e24583a7a35190736893262ce42bac6105a323.zip
sys-boot/palo: Version 2.12
Package-Manager: Portage-2.3.75, Repoman-2.3.17 Signed-off-by: Jeroen Roovers <jer@gentoo.org>
Diffstat (limited to 'sys-boot/palo')
-rw-r--r--sys-boot/palo/Manifest1
-rw-r--r--sys-boot/palo/palo-2.12.ebuild43
2 files changed, 44 insertions, 0 deletions
diff --git a/sys-boot/palo/Manifest b/sys-boot/palo/Manifest
index aef6a7d9922b..7bdbcb6ec73d 100644
--- a/sys-boot/palo/Manifest
+++ b/sys-boot/palo/Manifest
@@ -1,2 +1,3 @@
DIST palo-2.00.tar.gz 124484 BLAKE2B b46b616acf51534382f6a775b456cdcbd4771d6bc9d7a8339ad788a5c5a4a333e98a6e4815c40a6750408b1e8168a19800da11ddf7125621f77d478a651d9c75 SHA512 b6dab81e6c2641a64a40561a65b5412ee702136ac79dab94619e0094faf011e158c67e681f45d5aa51423f5f162da7c1fd07b391b58e8a2100e1306eb7148056
DIST palo-2.11.tar.gz 129144 BLAKE2B 25ea9462e7a87da333ace52be624aab65cc1fa4d20848bdec4ba1cea468b3ecd850dd7ceb936e9f2bd5761add766df65d054dc1b5d3f9cee991e9b3e4ddf864a SHA512 26e989ce0c652d6fafdc98d3ab3564d4adc5c943e3d44b0275beb8c385ad52cad0a29ad360e4992fb35c0f2036e29d3eee9b8f6594a53eaea9c3b973a60d9029
+DIST palo-2.12.tar.gz 124911 BLAKE2B 79fa572e118e77114dcb3b888abc65163bd56cb44cf69cd25bcaa33a7c6151b8254bf00c459ad17ca1d948f9b440378133f048e2add123a757908c108b802703 SHA512 6ea20490b84bf18a1d1e8037de453f5f480cba8403b267d4d63fceceffb39e18545c6d20c8dd7b07044ff5567eedd2c58b2a626971b53d1d35c5b3a4e8fefbf0
diff --git a/sys-boot/palo/palo-2.12.ebuild b/sys-boot/palo/palo-2.12.ebuild
new file mode 100644
index 000000000000..cf05c9a92a79
--- /dev/null
+++ b/sys-boot/palo/palo-2.12.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit toolchain-funcs
+
+DESCRIPTION="PALO : PArisc Linux Loader"
+HOMEPAGE="http://parisc-linux.org/ https://parisc.wiki.kernel.org/"
+SRC_URI="https://git.kernel.org/pub/scm/linux/kernel/git/deller/${PN}.git/snapshot/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="-* ~hppa"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-2.00-toolchain.patch
+)
+
+src_compile() {
+ local target
+ for target in '-C palo' '-C ipl' 'iplboot'; do
+ emake AR=$(tc-getAR) CC=$(tc-getCC) LD=$(tc-getLD) ${target}
+ done
+}
+
+src_install() {
+ into /
+ dosbin palo/palo
+
+ insinto /usr/share/palo
+ doins iplboot
+
+ insinto /etc
+ doins "${FILESDIR}"/palo.conf
+
+ insinto /etc/kernel/postinst.d
+ insopts -m 0744
+ doins "${FILESDIR}"/99palo
+
+ doman palo.8
+
+ dodoc TODO debian/changelog README.html
+}