summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2018-02-27 14:41:39 +0100
committerLars Wendler <polynomial-c@gentoo.org>2018-02-27 16:03:10 +0100
commit8db352582467fddce2faaaf9a623f9003f73e80e (patch)
treea130d996b903f58fbdf3fd739adfeb9eb0e71a64 /sys-boot/plymouth/plymouth-9999.ebuild
parentx11-misc/lightdm-gtk-greeter: Removed old. (diff)
downloadgentoo-8db352582467fddce2faaaf9a623f9003f73e80e.tar.gz
gentoo-8db352582467fddce2faaaf9a623f9003f73e80e.tar.bz2
gentoo-8db352582467fddce2faaaf9a623f9003f73e80e.zip
sys-boot/plymouth: Don't run eautoreconf in src_configure (QA fix).
Converted myconf variable in an array. Package-Manager: Portage-2.3.24, Repoman-2.3.6 Closes: https://github.com/gentoo/gentoo/pull/7299
Diffstat (limited to 'sys-boot/plymouth/plymouth-9999.ebuild')
-rw-r--r--sys-boot/plymouth/plymouth-9999.ebuild37
1 files changed, 21 insertions, 16 deletions
diff --git a/sys-boot/plymouth/plymouth-9999.ebuild b/sys-boot/plymouth/plymouth-9999.ebuild
index 49ce1012fe83..375f98aabb34 100644
--- a/sys-boot/plymouth/plymouth-9999.ebuild
+++ b/sys-boot/plymouth/plymouth-9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -50,22 +50,27 @@ PATCHES=(
"${FILESDIR}"/0.9.3-glibc-sysmacros.patch
)
-src_configure() {
- local myconf
- myconf="--with-system-root-install=no
- --localstatedir=/var
- --without-rhgb-compat-link
- --enable-systemd-integration
- --with-systemdunitdir="$(systemd_get_systemunitdir)"
- $(use_enable !static-libs shared)
- $(use_enable static-libs static)
- $(use_enable debug tracing)
- $(use_enable gtk gtk)
- $(use_enable libkms drm)
- $(use_enable pango)
- $(use_enable gdm gdm-transition)"
+src_prepare() {
+ default
eautoreconf
- econf ${myconf}
+}
+
+src_configure() {
+ local myconf=(
+ --with-system-root-install=no
+ --localstatedir=/var
+ --without-rhgb-compat-link
+ --enable-systemd-integration
+ --with-systemdunitdir="$(systemd_get_systemunitdir)"
+ $(use_enable !static-libs shared)
+ $(use_enable static-libs static)
+ $(use_enable debug tracing)
+ $(use_enable gtk gtk)
+ $(use_enable libkms drm)
+ $(use_enable pango)
+ $(use_enable gdm gdm-transition)
+ )
+ econf "${myconf[@]}"
}
src_install() {