summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /sys-boot/sgibootcd
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'sys-boot/sgibootcd')
-rw-r--r--sys-boot/sgibootcd/Manifest1
-rw-r--r--sys-boot/sgibootcd/metadata.xml14
-rw-r--r--sys-boot/sgibootcd/sgibootcd-0.12.ebuild29
3 files changed, 44 insertions, 0 deletions
diff --git a/sys-boot/sgibootcd/Manifest b/sys-boot/sgibootcd/Manifest
new file mode 100644
index 000000000000..5e147fc072ad
--- /dev/null
+++ b/sys-boot/sgibootcd/Manifest
@@ -0,0 +1 @@
+DIST sgibootcd-0.12.tar.bz2 3810 SHA256 2b0bfd0ebaa218fec414ff7102b8128dc658110fbeac83a510dc87d6559f299c SHA512 180e4f5a185b14c0b2c8158b368a50a3a55673fa86760e2a424c9533b1bb8ec37824c715ba02fd264621e2e31906ddd310398e9f24cf19147bce3e49fc62da3e WHIRLPOOL a1c98b2b6fc48201f4db47ac3a48cd64bb84becd5d664a8418a02115c47cb462e527aa1ba1dad4c58367441178101fe2661e9e2b08f67f1c8566f73e3c9eb08c
diff --git a/sys-boot/sgibootcd/metadata.xml b/sys-boot/sgibootcd/metadata.xml
new file mode 100644
index 000000000000..cd70548b1fc1
--- /dev/null
+++ b/sys-boot/sgibootcd/metadata.xml
@@ -0,0 +1,14 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>mips</herd>
+ <maintainer>
+ <email>mips@gentoo.org</email>
+ <name>Mips Team</name>
+ </maintainer>
+
+ <longdescription>
+ sgibootcd - Creates a burnable CD image for SGI LiveCDs
+ </longdescription>
+</pkgmetadata>
+
diff --git a/sys-boot/sgibootcd/sgibootcd-0.12.ebuild b/sys-boot/sgibootcd/sgibootcd-0.12.ebuild
new file mode 100644
index 000000000000..a88fa38e0926
--- /dev/null
+++ b/sys-boot/sgibootcd/sgibootcd-0.12.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+inherit eutils toolchain-funcs
+
+DESCRIPTION="Creates burnable CD images for SGI LiveCDs"
+HOMEPAGE="ftp://ftp.linux-mips.org/pub/linux/mips/people/skylark/"
+SRC_URI="ftp://ftp.linux-mips.org/pub/linux/mips/people/skylark/${P}.tar.bz2"
+LICENSE="all-rights-reserved"
+SLOT="0"
+KEYWORDS="-* ~mips"
+IUSE=""
+RDEPEND=""
+DEPEND=""
+RESTRICT=""
+
+src_compile() {
+ local mycc="$(tc-getCC) ${CFLAGS}"
+
+ [ -f "${S}/sgibootcd" ] && rm -f "${S}"/sgibootcd
+ einfo "${mycc} sgibootcd.c -o sgibootcd"
+ ${mycc} sgibootcd.c -o sgibootcd
+}
+
+src_install() {
+ dobin "${S}"/sgibootcd
+}