summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Gilbert <floppym@gentoo.org>2022-01-15 11:12:10 -0500
committerMike Gilbert <floppym@gentoo.org>2022-01-15 11:12:10 -0500
commit093f87aee2396c87ddecadbaa7027730f32f4516 (patch)
tree48c5134460cae66c081f5ebe9ee014c9aa17dd22 /sys-boot/systemd-boot
parentsys-fs/udev: backport cross compile fix (diff)
downloadgentoo-093f87aee2396c87ddecadbaa7027730f32f4516.tar.gz
gentoo-093f87aee2396c87ddecadbaa7027730f32f4516.tar.bz2
gentoo-093f87aee2396c87ddecadbaa7027730f32f4516.zip
sys-boot/systemd-boot: backport cross compile fix
Bug: https://bugs.gentoo.org/831221 Signed-off-by: Mike Gilbert <floppym@gentoo.org>
Diffstat (limited to 'sys-boot/systemd-boot')
-rw-r--r--sys-boot/systemd-boot/files/249.9-cross-compile.patch23
-rw-r--r--sys-boot/systemd-boot/systemd-boot-249.9.ebuild1
2 files changed, 24 insertions, 0 deletions
diff --git a/sys-boot/systemd-boot/files/249.9-cross-compile.patch b/sys-boot/systemd-boot/files/249.9-cross-compile.patch
new file mode 100644
index 000000000000..e063d303c7d8
--- /dev/null
+++ b/sys-boot/systemd-boot/files/249.9-cross-compile.patch
@@ -0,0 +1,23 @@
+From 3d7fd38ea938ab194366f40ed7aa413ad33f2fad Mon Sep 17 00:00:00 2001
+From: Yu Watanabe <watanabe.yu+github@gmail.com>
+Date: Tue, 21 Dec 2021 20:10:09 +0900
+Subject: [PATCH] meson: fix cross compiling
+
+(cherry picked from commit 3112d756a36993900b70fbff98e69a2a43b970a8)
+---
+ meson.build | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/meson.build b/meson.build
+index 02495d16c9..c76cab535d 100644
+--- a/meson.build
++++ b/meson.build
+@@ -442,7 +442,7 @@ conf.set('SIZEOF_DEV_T', cc.sizeof('dev_t', prefix : '#include <sys/types.h>'))
+ conf.set('SIZEOF_INO_T', cc.sizeof('ino_t', prefix : '#include <sys/types.h>'))
+ conf.set('SIZEOF_TIME_T', cc.sizeof('time_t', prefix : '#include <sys/time.h>'))
+ conf.set('SIZEOF_RLIM_T', cc.sizeof('rlim_t', prefix : '#include <sys/resource.h>'))
+-conf.set('SIZEOF_TIMEX_MEMBER', cc.sizeof('((struct timex *)0)->freq', prefix : '#include <sys/timex.h>'))
++conf.set('SIZEOF_TIMEX_MEMBER', cc.sizeof('typeof(((struct timex *)0)->freq)', prefix : '#include <sys/timex.h>'))
+
+ decl_headers = '''
+ #include <uchar.h>
diff --git a/sys-boot/systemd-boot/systemd-boot-249.9.ebuild b/sys-boot/systemd-boot/systemd-boot-249.9.ebuild
index 143c5280b8d8..c0a51a5c2eee 100644
--- a/sys-boot/systemd-boot/systemd-boot-249.9.ebuild
+++ b/sys-boot/systemd-boot/systemd-boot-249.9.ebuild
@@ -54,6 +54,7 @@ QA_EXECSTACK="usr/lib/systemd/boot/efi/*"
PATCHES=(
"${FILESDIR}/249-libshared-static.patch"
+ "${FILESDIR}/249.9-cross-compile.patch"
)
src_configure() {