summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-11-16 12:05:53 +0000
committerSam James <sam@gentoo.org>2021-11-16 12:05:53 +0000
commit55743ff045f0e8fdbfec92d92d7913e45c5663ec (patch)
treec359190270642c0057dc38cd4f48f7b8b73b8a4f /sys-boot/systemd-boot
parentdev-cpp/abseil-cpp: fix 20210324.1 build with glibc-2.34 (diff)
downloadgentoo-55743ff045f0e8fdbfec92d92d7913e45c5663ec.tar.gz
gentoo-55743ff045f0e8fdbfec92d92d7913e45c5663ec.tar.bz2
gentoo-55743ff045f0e8fdbfec92d92d7913e45c5663ec.zip
sys-boot/systemd-boot: fix build with linux-headers-5.15
Closes: https://bugs.gentoo.org/823810 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'sys-boot/systemd-boot')
-rw-r--r--sys-boot/systemd-boot/files/249-linux-headers-5-15.patch22
-rw-r--r--sys-boot/systemd-boot/systemd-boot-249.ebuild1
2 files changed, 23 insertions, 0 deletions
diff --git a/sys-boot/systemd-boot/files/249-linux-headers-5-15.patch b/sys-boot/systemd-boot/files/249-linux-headers-5-15.patch
new file mode 100644
index 000000000000..398119d77432
--- /dev/null
+++ b/sys-boot/systemd-boot/files/249-linux-headers-5-15.patch
@@ -0,0 +1,22 @@
+https://github.com/systemd/systemd-stable/pull/132/commits/92bbfcdc733d39ec4097d8678bc92a7aaaf78ae1.patch
+https://bugs.gentoo.org/823810
+
+From: Chris Packham <chris.packham@alliedtelesis.co.nz>
+Date: Fri, 10 Sep 2021 09:51:36 +1200
+Subject: [PATCH 1/2] basic/linux: Sync if_arp.h with Linux 5.14
+
+ARPHRD_MCTP was added in 5.14. Sync if_arp.h to pick up the definition
+
+Fixes #20694
+
+(cherry picked from commit 7c5b9952c4f6e2b72f90edbe439982528b7cf223)
+--- a/src/basic/linux/if_arp.h
++++ b/src/basic/linux/if_arp.h
+@@ -54,6 +54,7 @@
+ #define ARPHRD_X25 271 /* CCITT X.25 */
+ #define ARPHRD_HWX25 272 /* Boards with X.25 in firmware */
+ #define ARPHRD_CAN 280 /* Controller Area Network */
++#define ARPHRD_MCTP 290
+ #define ARPHRD_PPP 512
+ #define ARPHRD_CISCO 513 /* Cisco HDLC */
+ #define ARPHRD_HDLC ARPHRD_CISCO
diff --git a/sys-boot/systemd-boot/systemd-boot-249.ebuild b/sys-boot/systemd-boot/systemd-boot-249.ebuild
index d9ed991ef5c6..6a1255a2e06b 100644
--- a/sys-boot/systemd-boot/systemd-boot-249.ebuild
+++ b/sys-boot/systemd-boot/systemd-boot-249.ebuild
@@ -50,6 +50,7 @@ S="${WORKDIR}/systemd-${PV}"
PATCHES=(
"${FILESDIR}/249-libshared-static.patch"
+ "${FILESDIR}/249-linux-headers-5-15.patch"
)
src_configure() {