summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2020-06-11 09:05:19 +0200
committerJeroen Roovers <jer@gentoo.org>2020-06-11 09:29:36 +0200
commit536cc39de519db5492585cc6d3423a6ac6116cdc (patch)
treeb6bae3a113b9c36b7c212b570f58ae66eb651870 /sys-boot/unetbootin/unetbootin-681.ebuild
parentwww-apps/wordpress: bumped to 5.4.2 (diff)
downloadgentoo-536cc39de519db5492585cc6d3423a6ac6116cdc.tar.gz
gentoo-536cc39de519db5492585cc6d3423a6ac6116cdc.tar.bz2
gentoo-536cc39de519db5492585cc6d3423a6ac6116cdc.zip
sys-boot/unetbootin: Version 681
Package-Manager: Portage-2.3.100, Repoman-2.3.22 Signed-off-by: Jeroen Roovers <jer@gentoo.org>
Diffstat (limited to 'sys-boot/unetbootin/unetbootin-681.ebuild')
-rw-r--r--sys-boot/unetbootin/unetbootin-681.ebuild113
1 files changed, 113 insertions, 0 deletions
diff --git a/sys-boot/unetbootin/unetbootin-681.ebuild b/sys-boot/unetbootin/unetbootin-681.ebuild
new file mode 100644
index 000000000000..4f0db3c3d742
--- /dev/null
+++ b/sys-boot/unetbootin/unetbootin-681.ebuild
@@ -0,0 +1,113 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit desktop flag-o-matic qmake-utils xdg-utils toolchain-funcs
+
+DESCRIPTION="UNetbootin installs Linux/BSD distributions to a partition or USB drive"
+HOMEPAGE="https://github.com/unetbootin/unetbootin"
+SRC_URI="
+ https://github.com/unetbootin/unetbootin/archive/${PV}.tar.gz -> ${P}.tar.gz
+ https://dev.gentoo.org/~jer/${PN}-675-qt5.patch.xz
+"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~x86"
+
+UNBI_LINGUAS="
+ am ar ast be bg bn ca cs da de el eo es et eu fa fi fo fr gl he hr hu id it
+ ja lt lv ml ms nan nb nl nn pl pt_BR pt ro ru si sk sl sr sv sw tr uk ur vi
+ zh_CN zh_TW
+"
+
+for lingua in ${UNBI_LINGUAS}; do
+ IUSE="${IUSE} l10n_${lingua/_/-}"
+done
+
+S=${WORKDIR}/${P}/src/${PN}
+
+COMMON_DEPEND="
+ dev-qt/qtcore:5
+ dev-qt/qtgui:5
+ dev-qt/qtnetwork:5
+ dev-qt/qtwidgets:5
+"
+BDEPEND="
+ ${COMMON_DEPEND}
+ dev-qt/linguist-tools:5
+"
+RDEPEND="
+ ${COMMON_DEPEND}
+ app-arch/p7zip
+ sys-boot/syslinux
+ sys-fs/mtools
+"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-675-desktop.patch
+ "${WORKDIR}"/${PN}-675-qt5.patch
+)
+
+src_prepare() {
+ default
+
+ # QA check in case linguas are added or removed
+ enum() {
+ echo ${#}
+ }
+ [[ $(enum ${UNBI_LINGUAS}) -eq $(( $(enum $(echo ${PN}_*.ts) ) -1 )) ]] \
+ || die "Numbers of recorded and actual linguas do not match"
+ unset enum
+
+ # Remove localisations
+ local lingua
+ for lingua in ${UNBI_LINGUAS}; do
+ if ! use l10n_${lingua/_/-}; then
+ sed -i ${PN}.pro -e "/\.*${PN}_${lingua}\.ts.*/d" || die
+ rm ${PN}_${lingua}.ts || die
+ fi
+ done
+ append-cflags -DNOSTATIC
+ append-cxxflags -DNOSTATIC
+}
+
+src_configure() {
+ sed -i -e '/^RESOURCES/d' unetbootin.pro || die
+
+ export QMAKE_CXX="$(tc-getCXX)"
+
+ UNBN_QTPATH="$(qt5_get_bindir)/"
+ "${UNBN_QTPATH}"lrelease ${PN}.pro || die
+
+ eqmake5 ${PN}.pro || die
+}
+
+src_install() {
+ dobin ${PN}
+
+ domenu ${PN}.desktop
+
+ for file in ${PN}*.png; do
+ size="${file/${PN}_}"
+ size="${size/.png}x${size/.png}"
+ insinto /usr/share/icons/hicolor/${size}/apps
+ newins ${file} ${PN}.png
+ done
+
+ local lingua
+ for lingua in ${UNBI_LINGUAS}; do
+ if use l10n_${lingua/_/-}; then
+ insinto /usr/share/${PN}
+ doins ${PN}_${lingua}.qm
+ fi
+ done
+}
+
+pkg_postinst() {
+ xdg_icon_cache_update
+}
+
+pkg_postrm() {
+ xdg_icon_cache_update
+}