summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Mair-Keimberger <m.mairkeimberger@gmail.com>2020-11-18 19:37:18 +0100
committerSergei Trofimovich <slyfox@gentoo.org>2020-11-19 07:27:53 +0000
commitd72d224bc91e1011773e6b10023663ed11637f63 (patch)
tree0865d0986afb48245c0dfcfc08ba801663475be6 /sys-boot/yaboot/files
parentnet-im/dino: add new version 0.2.0 (diff)
downloadgentoo-d72d224bc91e1011773e6b10023663ed11637f63.tar.gz
gentoo-d72d224bc91e1011773e6b10023663ed11637f63.tar.bz2
gentoo-d72d224bc91e1011773e6b10023663ed11637f63.zip
sys-boot/yaboot: remove unused patch
Package-Manager: Portage-3.0.9, Repoman-3.0.2 Signed-off-by: Michael Mair-Keimberger <m.mairkeimberger@gmail.com> Closes: https://github.com/gentoo/gentoo/pull/18316 Signed-off-by: Sergei Trofimovich <slyfox@gentoo.org>
Diffstat (limited to 'sys-boot/yaboot/files')
-rw-r--r--sys-boot/yaboot/files/yaboot-nopiessp-gcc4.patch38
1 files changed, 0 insertions, 38 deletions
diff --git a/sys-boot/yaboot/files/yaboot-nopiessp-gcc4.patch b/sys-boot/yaboot/files/yaboot-nopiessp-gcc4.patch
deleted file mode 100644
index ed1755b72b33..000000000000
--- a/sys-boot/yaboot/files/yaboot-nopiessp-gcc4.patch
+++ /dev/null
@@ -1,38 +0,0 @@
-disable ssp usage in yaboot itself
-
-unfortunately, since we link against external libs that themselves were built
-with ssp turned on, we have to provide stubs to keep the linking from failing
-
---- yaboot-1.3.13/Config.gentoo
-+++ yaboot-1.3.13/Config.gentoo
-@@ -0,0 +1,6 @@
-+check_gcc=$(shell if $(CC) $(1) -S -o /dev/null -xc /dev/null > /dev/null 2>&1; \
-+ then echo "$(1)"; else echo "$(2)"; fi)
-+
-+CFLAGS += $(call check_gcc, -fno-stack-protector)
-+CFLAGS += $(call check_gcc, --nopie)
-+
---- yaboot-1.3.13/Makefile
-+++ yaboot-1.3.13/Makefile
-@@ -1,6 +1,7 @@
- ## Setup
-
- include Config
-+include Config.gentoo
-
- VERSION = 1.3.13
- # Debug mode (spam/verbose)
-@@ -79,7 +80,7 @@ HOSTCFLAGS = -O2 $(CFLAGS) -Wall -I/usr/
- OBJS = second/crt0.o second/yaboot.o second/cache.o second/prom.o second/file.o \
- second/partition.o second/fs.o second/cfg.o second/setjmp.o second/cmdline.o \
- second/fs_of.o second/fs_ext2.o second/fs_iso.o second/iso_util.o \
-- lib/nosys.o lib/string.o lib/strtol.o lib/vsprintf.o lib/ctype.o lib/malloc.o lib/strstr.o
-+ lib/nosys.o lib/string.o lib/strtol.o lib/vsprintf.o lib/ctype.o lib/malloc.o lib/strstr.o lib/ssp.o
-
- ifeq ($(USE_MD5_PASSWORDS),y)
- OBJS += second/md5.o
---- yaboot-1.3.14/lib/ssp.c
-+++ yaboot-1.3.14/lib/ssp.c
-@@ -0,0 +1,2 @@
-+void __stack_chk_fail(void) {}
-+void __stack_chk_fail_local(void) {}