summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-06-30 19:38:21 +0100
committerSam James <sam@gentoo.org>2021-06-30 19:38:21 +0100
commit0a82566ca53fa43dbf2711562442a2f980cd3f0b (patch)
treec3b28abfbe068f730f5f6ce093a92add37333c8f /sys-boot
parentwww-apache/pwauth: add missing libcrypt dependency (diff)
downloadgentoo-0a82566ca53fa43dbf2711562442a2f980cd3f0b.tar.gz
gentoo-0a82566ca53fa43dbf2711562442a2f980cd3f0b.tar.bz2
gentoo-0a82566ca53fa43dbf2711562442a2f980cd3f0b.zip
sys-boot/mokutil: add 0.3.0_p20170405 (fix versioning), add libcrypt dependency
The previous "0.4.0" version in tree actually corresponded to commit e19adc575c1f9d8f08b7fbc594a0887ace63f83f which seems to have been between 0.3.0 and 0.4.0. Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'sys-boot')
-rw-r--r--sys-boot/mokutil/Manifest2
-rw-r--r--sys-boot/mokutil/mokutil-0.3.0_p20170405.ebuild (renamed from sys-boot/mokutil/mokutil-0.4.0.ebuild)14
2 files changed, 9 insertions, 7 deletions
diff --git a/sys-boot/mokutil/Manifest b/sys-boot/mokutil/Manifest
index 775b20a0acf0..48a3308653a1 100644
--- a/sys-boot/mokutil/Manifest
+++ b/sys-boot/mokutil/Manifest
@@ -1 +1 @@
-DIST mokutil-0.4.0.tar.gz 32590 BLAKE2B 867574b05a7a7c842869f75bd3b6a0cd0af083862ffc912b25b12fe6283946968ac6872b25a727d37185fb821871d5a2f958afddbb7e2bfefde854c6f434ab8f SHA512 ee64627089efe341bff466249a126dcdcc4a53878b17f651b17423650c3aea76d52dcae01ed689ba5bd317125dd9a669816563aa676d46d8ac36863f38f9ea16
+DIST mokutil-0.3.0_p20170405.tar.gz 32590 BLAKE2B 867574b05a7a7c842869f75bd3b6a0cd0af083862ffc912b25b12fe6283946968ac6872b25a727d37185fb821871d5a2f958afddbb7e2bfefde854c6f434ab8f SHA512 ee64627089efe341bff466249a126dcdcc4a53878b17f651b17423650c3aea76d52dcae01ed689ba5bd317125dd9a669816563aa676d46d8ac36863f38f9ea16
diff --git a/sys-boot/mokutil/mokutil-0.4.0.ebuild b/sys-boot/mokutil/mokutil-0.3.0_p20170405.ebuild
index e7350f82c725..c83be9c0cdf4 100644
--- a/sys-boot/mokutil/mokutil-0.4.0.ebuild
+++ b/sys-boot/mokutil/mokutil-0.3.0_p20170405.ebuild
@@ -1,24 +1,26 @@
# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=7
+
inherit autotools
+# This corresponds to a commit between 0.3.0 and 0.4.0!
+GIT_HASH="e19adc575c1f9d8f08b7fbc594a0887ace63f83f"
DESCRIPTION="The utility to manipulate machines owner keys which managed in shim"
HOMEPAGE="https://github.com/lcp/mokutil"
-GIT_HASH="e19adc575c1f9d8f08b7fbc594a0887ace63f83f"
SRC_URI="https://github.com/lcp/mokutil/archive/${GIT_HASH}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/${PN}-${GIT_HASH}"
LICENSE="GPL-3"
SLOT="0"
KEYWORDS="~amd64 ~x86"
-IUSE=""
DEPEND="dev-libs/openssl:=
- sys-libs/efivar:="
+ sys-libs/efivar:=
+ virtual/libcrypt:="
RDEPEND="${DEPEND}"
-
-S="${WORKDIR}/${PN}-${GIT_HASH}"
+BDEPEND="virtual/pkgconfig"
src_prepare() {
default