summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2016-04-19 02:03:08 -0400
committerMike Frysinger <vapier@gentoo.org>2016-04-19 02:03:15 -0400
commit19ae69e682d94b2317057e4751e4b78555868362 (patch)
treee8a06ea65a3766604c94965494f0504aeccb8447 /sys-boot
parentsys-apps/smartmontools: Fixed installation with USE=minimal. (diff)
downloadgentoo-19ae69e682d94b2317057e4751e4b78555868362.tar.gz
gentoo-19ae69e682d94b2317057e4751e4b78555868362.tar.bz2
gentoo-19ae69e682d94b2317057e4751e4b78555868362.zip
sys-boot/syslinux: fix building w/newer glibc #579928
Diffstat (limited to 'sys-boot')
-rw-r--r--sys-boot/syslinux/files/syslinux-6.03-sysmacros.patch34
-rw-r--r--sys-boot/syslinux/syslinux-6.03.ebuild2
2 files changed, 36 insertions, 0 deletions
diff --git a/sys-boot/syslinux/files/syslinux-6.03-sysmacros.patch b/sys-boot/syslinux/files/syslinux-6.03-sysmacros.patch
new file mode 100644
index 000000000000..af464fe534e1
--- /dev/null
+++ b/sys-boot/syslinux/files/syslinux-6.03-sysmacros.patch
@@ -0,0 +1,34 @@
+https://bugs.gentoo.org/579928
+
+From d84db34dbe39d55b4d7e868764c056689aa0793b Mon Sep 17 00:00:00 2001
+From: Mike Frysinger <vapier@gentoo.org>
+Date: Tue, 19 Apr 2016 01:56:41 -0400
+Subject: [PATCH] extlinux: pull in sys/sysmacros.h for major/minor/makedev
+
+These functions are defined in sys/sysmacros.h, so add the include to
+main.c. This is already handled correctly in mountinfo.c. Otherwise
+we get build failures like:
+
+main.o: In function 'find_device_sysfs':
+extlinux/main.c:1131: undefined reference to 'minor'
+
+Signed-off-by: Mike Frysinger <vapier@gentoo.org>
+---
+ extlinux/main.c | 1 +
+ 1 file changed, 1 insertion(+)
+
+diff --git a/extlinux/main.c b/extlinux/main.c
+index a7ebd49..ebff7ea 100644
+--- a/extlinux/main.c
++++ b/extlinux/main.c
+@@ -38,6 +38,7 @@
+ #include <sysexits.h>
+ #include <sys/ioctl.h>
+ #include <sys/stat.h>
++#include <sys/sysmacros.h>
+ #include <sys/types.h>
+ #include <sys/mount.h>
+ #include <sys/vfs.h>
+--
+2.7.4
+
diff --git a/sys-boot/syslinux/syslinux-6.03.ebuild b/sys-boot/syslinux/syslinux-6.03.ebuild
index 503baaeec619..25ec57bc1fc1 100644
--- a/sys-boot/syslinux/syslinux-6.03.ebuild
+++ b/sys-boot/syslinux/syslinux-6.03.ebuild
@@ -45,6 +45,8 @@ QA_PREBUILT="usr/share/${PN}/*.c32"
src_prepare() {
rm -f gethostip #bug 137081
+ epatch "${FILESDIR}"/${PN}-6.03-sysmacros.patch #579928
+
# Don't prestrip or override user LDFLAGS, bug #305783
local SYSLINUX_MAKEFILES="extlinux/Makefile linux/Makefile mtools/Makefile \
sample/Makefile utils/Makefile"