summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrew Ammerlaan <andrewammerlaan@gentoo.org>2023-07-12 09:37:29 +0200
committerAndrew Ammerlaan <andrewammerlaan@gentoo.org>2023-08-17 09:48:40 +0200
commit2900f329ad5c0e17c6f29458d05418cdd13e9774 (patch)
treee1ff10980aa5defd89b9c93d59d3d7dc88ee0d9b /sys-boot
parentdev-python/line_profiler: Bump to 4.1.0 (diff)
downloadgentoo-2900f329ad5c0e17c6f29458d05418cdd13e9774.tar.gz
gentoo-2900f329ad5c0e17c6f29458d05418cdd13e9774.tar.bz2
gentoo-2900f329ad5c0e17c6f29458d05418cdd13e9774.zip
sys-boot/syslinux: use secureboot.eclass to sign efi exec
Signed-off-by: Andrew Ammerlaan <andrewammerlaan@gentoo.org>
Diffstat (limited to 'sys-boot')
-rw-r--r--sys-boot/syslinux/syslinux-6.04_pre1-r5.ebuild10
-rw-r--r--sys-boot/syslinux/syslinux-6.04_pre3-r1.ebuild10
2 files changed, 16 insertions, 4 deletions
diff --git a/sys-boot/syslinux/syslinux-6.04_pre1-r5.ebuild b/sys-boot/syslinux/syslinux-6.04_pre1-r5.ebuild
index 61289b005cc2..6b5cb5abcf12 100644
--- a/sys-boot/syslinux/syslinux-6.04_pre1-r5.ebuild
+++ b/sys-boot/syslinux/syslinux-6.04_pre1-r5.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2022 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
-inherit toolchain-funcs flag-o-matic
+inherit toolchain-funcs flag-o-matic secureboot
DESCRIPTION="SYSLINUX, PXELINUX, ISOLINUX, EXTLINUX and MEMDISK bootloaders"
HOMEPAGE="https://www.syslinux.org/"
@@ -38,6 +38,10 @@ QA_WX_LOAD="usr/share/syslinux/*"
QA_PRESTRIPPED="usr/share/syslinux/.*"
QA_FLAGS_IGNORED=".*"
+pkg_setup() {
+ use efi && secureboot_pkg_setup
+}
+
src_prepare() {
local PATCHES=(
"${FILESDIR}/syslinux-6.03-sysmacros.patch"
@@ -85,4 +89,6 @@ src_install() {
fi
einstalldocs
dostrip -x /usr/share/syslinux
+
+ use efi && secureboot_auto_sign --in-place
}
diff --git a/sys-boot/syslinux/syslinux-6.04_pre3-r1.ebuild b/sys-boot/syslinux/syslinux-6.04_pre3-r1.ebuild
index e42f6139206e..b483d5b273d2 100644
--- a/sys-boot/syslinux/syslinux-6.04_pre3-r1.ebuild
+++ b/sys-boot/syslinux/syslinux-6.04_pre3-r1.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2022 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
-inherit toolchain-funcs flag-o-matic
+inherit toolchain-funcs flag-o-matic secureboot
DESCRIPTION="SYSLINUX, PXELINUX, ISOLINUX, EXTLINUX and MEMDISK bootloaders"
HOMEPAGE="https://www.syslinux.org/"
@@ -41,6 +41,10 @@ QA_WX_LOAD="usr/share/syslinux/*"
QA_PRESTRIPPED="usr/share/syslinux/.*"
QA_FLAGS_IGNORED=".*"
+pkg_setup() {
+ use efi && secureboot_pkg_setup
+}
+
src_prepare() {
local PATCHES=(
"${FILESDIR}/6.04_pre1"
@@ -102,4 +106,6 @@ src_install() {
fi
einstalldocs
dostrip -x /usr/share/syslinux
+
+ use efi && secureboot_auto_sign --in-place
}