summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergei Trofimovich <slyfox@gentoo.org>2021-02-16 17:44:45 +0000
committerSergei Trofimovich <slyfox@gentoo.org>2021-02-16 17:45:34 +0000
commit321303c29d48b84b8691ac2a70d719e2220f0929 (patch)
tree1796e1e3c7f0baa5a0136908a915dab1d3a0c889 /sys-boot
parentmedia-gfx/darktable: remove unused patch (diff)
downloadgentoo-321303c29d48b84b8691ac2a70d719e2220f0929.tar.gz
gentoo-321303c29d48b84b8691ac2a70d719e2220f0929.tar.bz2
gentoo-321303c29d48b84b8691ac2a70d719e2220f0929.zip
sys-boot/elilo: allow ARCH override
Reported-by: Agostino Sarubbo Closes: https://bugs.gentoo.org/770982 Package-Manager: Portage-3.0.14, Repoman-3.0.2 Signed-off-by: Sergei Trofimovich <slyfox@gentoo.org>
Diffstat (limited to 'sys-boot')
-rw-r--r--sys-boot/elilo/elilo-3.16-r4.ebuild3
-rw-r--r--sys-boot/elilo/files/elilo-3.16-ARCH.patch12
2 files changed, 14 insertions, 1 deletions
diff --git a/sys-boot/elilo/elilo-3.16-r4.ebuild b/sys-boot/elilo/elilo-3.16-r4.ebuild
index c4cd5a90dd8a..2670fdcaf7a1 100644
--- a/sys-boot/elilo/elilo-3.16-r4.ebuild
+++ b/sys-boot/elilo/elilo-3.16-r4.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -29,6 +29,7 @@ PATCHES=(
"${FILESDIR}"/${PN}-3.16-gnu-efi-3.0.6-ia64.patch
"${FILESDIR}"/${PN}-3.16-strncpy-clash.patch
"${FILESDIR}"/${PN}-3.16-FLAGS.patch
+ "${FILESDIR}"/${PN}-3.16-ARCH.patch
)
src_unpack() {
diff --git a/sys-boot/elilo/files/elilo-3.16-ARCH.patch b/sys-boot/elilo/files/elilo-3.16-ARCH.patch
new file mode 100644
index 000000000000..935cf7adbe4e
--- /dev/null
+++ b/sys-boot/elilo/files/elilo-3.16-ARCH.patch
@@ -0,0 +1,12 @@
+Allow for easier override from make's commandline.
+--- a/Make.defaults
++++ b/Make.defaults
+@@ -64,7 +64,7 @@ TOPDIR =
+ ALLSUBDIRS = ia32 ia64 x86_64 fs choosers devschemes tools
+
+ HOSTARCH = $(shell dpkg-architecture -qDEB_BUILD_ARCH | sed s,i[3456789]86,ia32, | sed s,amd64,x86_64, )
+-ARCH := $(shell dpkg-architecture -qDEB_BUILD_ARCH | sed s,i[3456789]86,ia32, | sed s,amd64,x86_64, )
++ARCH = $(shell dpkg-architecture -qDEB_BUILD_ARCH | sed s,i[3456789]86,ia32, | sed s,amd64,x86_64, )
+ INCDIR = -I. -I$(TOPDIR) -I$(EFIINC) -I$(EFIINC)/$(ARCH) -I$(EFIINC)/protocol -I$(TOPDIR)/efi110
+ CPPFLAGS = -DCONFIG_$(ARCH)
+