summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGeorgy Yakovlev <gyakovlev@gentoo.org>2018-11-12 11:59:48 -0800
committerGeorgy Yakovlev <gyakovlev@gentoo.org>2018-11-12 13:07:55 -0800
commit381c8330770d424a37f1f8800e5d0075c578e612 (patch)
tree88a4275987a9115067a897ec3f9acd55de7e1937 /sys-boot
parentmedia-libs/fontconfig: stable 2.13.0-r4 for hppa, bug #664108 (diff)
downloadgentoo-381c8330770d424a37f1f8800e5d0075c578e612.tar.gz
gentoo-381c8330770d424a37f1f8800e5d0075c578e612.tar.bz2
gentoo-381c8330770d424a37f1f8800e5d0075c578e612.zip
sys-boot/plymouth-openrc-plugin: EAPI revbump, fixes
Add patch fixing early exit which prevented showing splash on reboot. EAPI 4->7 Fix license, it clearly says GPL-2 or later. Touch up ebuild. While this package is no longer developed it still works fine, and especially useful at fixing weird plymouth behaviour on boot under openrc. Package-Manager: Portage-2.3.51, Repoman-2.3.12 Signed-off-by: Georgy Yakovlev <gyakovlev@gentoo.org>
Diffstat (limited to 'sys-boot')
-rw-r--r--sys-boot/plymouth-openrc-plugin/files/plymouth-openrc-plugin-0.1.2-exit-at-mount-ro.patch25
-rw-r--r--sys-boot/plymouth-openrc-plugin/plymouth-openrc-plugin-0.1.2-r1.ebuild34
2 files changed, 59 insertions, 0 deletions
diff --git a/sys-boot/plymouth-openrc-plugin/files/plymouth-openrc-plugin-0.1.2-exit-at-mount-ro.patch b/sys-boot/plymouth-openrc-plugin/files/plymouth-openrc-plugin-0.1.2-exit-at-mount-ro.patch
new file mode 100644
index 000000000000..7dc5feb2fc1f
--- /dev/null
+++ b/sys-boot/plymouth-openrc-plugin/files/plymouth-openrc-plugin-0.1.2-exit-at-mount-ro.patch
@@ -0,0 +1,25 @@
+From 9d3485d73244eea61205c4c84b2c37d489d5bbcb Mon Sep 17 00:00:00 2001
+From: tlhonmey <lperkins@zagmail.gonzaga.edu>
+Date: Wed, 31 Jan 2018 11:10:48 -0800
+Subject: [PATCH] Exit plymouth when we hit mount-ro rather than localmount.
+
+Newer versions of openrc appear to run localmount almost immediately upon shutdown, causing the plugin to send Plymouth the quit command before the splash is even displayed, resulting in no splash on shutdown.
+
+The job that cuts us off from writing to /var is now mount-ro, which runs near the end like it should and gives Plymouth time to show the splash.
+---
+ plymouth.c | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/plymouth.c b/plymouth.c
+index e657e82..e9c925b 100644
+--- a/plymouth.c
++++ b/plymouth.c
+@@ -240,7 +240,7 @@ int rc_plugin_hook(RC_HOOK hook, const char *name)
+
+ case RC_HOOK_SERVICE_STOP_IN:
+ /* Quit Plymouth when we're going to lost write access to /var/... */
+- if(strcmp(name, "localmount") == 0 &&
++ if(strcmp(name, "mount-ro") == 0 &&
+ strcmp(runlevel, RC_LEVEL_SHUTDOWN) == 0) {
+ DBG("ply_quit(PLY_MODE_SHUTDOWN)");
+ if(!ply_quit(PLY_MODE_SHUTDOWN))
diff --git a/sys-boot/plymouth-openrc-plugin/plymouth-openrc-plugin-0.1.2-r1.ebuild b/sys-boot/plymouth-openrc-plugin/plymouth-openrc-plugin-0.1.2-r1.ebuild
new file mode 100644
index 000000000000..a073ee75df03
--- /dev/null
+++ b/sys-boot/plymouth-openrc-plugin/plymouth-openrc-plugin-0.1.2-r1.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="Plymouth plugin for OpenRC"
+HOMEPAGE="https://github.com/aidecoe/plymouth-openrc-plugin"
+SRC_URI="https://dev.gentoo.org/~aidecoe/distfiles/${CATEGORY}/${PN}/${P}.tar.bz2"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE=""
+
+DEPEND="sys-apps/openrc:="
+RDEPEND="${DEPEND}
+ sys-boot/plymouth"
+
+PATCHES=( "${FILESDIR}/${P}-exit-at-mount-ro.patch" )
+
+src_install() {
+ insinto /$(get_libdir)/rc/plugins
+ doins plymouth.so
+}
+
+pkg_postinst() {
+ ewarn "You need to disable 'rc_interactive' feature in /etc/rc.conf to make"
+ ewarn "Plymouth work properly with OpenRC init system."
+
+ if has_version sys-apps/systemd; then
+ eerror "sys-apps/systemd is installed, please uninstall this package if you"
+ eerror "are booting with systemd"
+ fi
+}