summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristopher Byrne <salah.coronya@gmail.com>2022-02-24 14:58:28 -0600
committerSam James <sam@gentoo.org>2022-02-26 02:26:13 +0000
commit5ed2ffc8f5bd62efbabd3aa76bf238f41d9a60e3 (patch)
tree3c91637b639da546715c8fe09b7d98a0d59a2498 /sys-boot
parentsys-boot/tboot: Bump to 1.10.4 (diff)
downloadgentoo-5ed2ffc8f5bd62efbabd3aa76bf238f41d9a60e3.tar.gz
gentoo-5ed2ffc8f5bd62efbabd3aa76bf238f41d9a60e3.tar.bz2
gentoo-5ed2ffc8f5bd62efbabd3aa76bf238f41d9a60e3.zip
sys-boot/tboot: Remove old
Package-Manager: Portage-3.0.30, Repoman-3.0.3 Signed-off-by: Christopher Byrne <salah.coronya@gmail.com> Closes: https://github.com/gentoo/gentoo/pull/24339 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'sys-boot')
-rw-r--r--sys-boot/tboot/Manifest1
-rw-r--r--sys-boot/tboot/tboot-1.10.3.ebuild76
2 files changed, 0 insertions, 77 deletions
diff --git a/sys-boot/tboot/Manifest b/sys-boot/tboot/Manifest
index c4e612c45eaa..249d776b4c9c 100644
--- a/sys-boot/tboot/Manifest
+++ b/sys-boot/tboot/Manifest
@@ -1,2 +1 @@
-DIST tboot-1.10.3.tar.gz 906732 BLAKE2B 4015ba84fbc273d1f1ea3f302dd11e62d1866049a31674b8967a9c1be645f88f2fdbc8614e1f7d824010e8280484885392b34aedb2d9f32654a3065e75e0bd42 SHA512 998501cfb23511adf63c0e2a70f203b3a92328cba39948a6be2e0dc6600aaaf9fcc18dc1ffcdd00c43a5d2c688c34c912c7525fd54a5c673a764c34141be4b77
DIST tboot-1.10.4.tar.gz 908050 BLAKE2B 8c793e2ec29cc3c3aa8199ac5058e9b3521eb0a72609c8b5ae21e0843571ae765be74bb48184178e2641ff8eec05680f81e45b12b80fd7d2727c82f9c8702411 SHA512 6fe93cabd5fc10cba7797048cad2cce4c490e0112c5c877f3367d78873cb55ba3d84eb703f2fcdba807eb21f1bef6a838d315b32d6418fb88b2589ff66e99491
diff --git a/sys-boot/tboot/tboot-1.10.3.ebuild b/sys-boot/tboot/tboot-1.10.3.ebuild
deleted file mode 100644
index 4cedba3fabfc..000000000000
--- a/sys-boot/tboot/tboot-1.10.3.ebuild
+++ /dev/null
@@ -1,76 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-inherit mount-boot toolchain-funcs
-
-DESCRIPTION="Performs a measured and verified boot using Intel Trusted Execution Technology"
-HOMEPAGE="https://sourceforge.net/projects/tboot/"
-SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="-* ~amd64 ~x86"
-IUSE="custom-cflags selinux"
-
-# requires patching the kernel src
-RESTRICT="test"
-
-DEPEND="dev-libs/openssl:0=[-bindist(-)]"
-
-RDEPEND="${DEPEND}
- sys-boot/grub:2
- selinux? ( sec-policy/selinux-tboot )"
-
-DOCS=( README.md COPYING CHANGELOG )
-PATCHES=( "${FILESDIR}/${PN}-1.10.3-disable-Werror.patch"
- "${FILESDIR}/${PN}-1.10.3-disable-strip.patch"
- "${FILESDIR}/${PN}-1.10.3-dont-call-toolchain-directly.patch" )
-
-pkg_setup() {
- if tc-is-clang; then
- eerror "tboot is a freestanding application that uses gcc"
- eerror "extensions in fundemental ways, include VLAIS"
- eerror "(Variable Length Arrays in Structs) and will not"
- eerror "compile with clang witout upstream action"
- die "Cannot compile with clang. See bug #832020"
- fi
-}
-
-src_configure() {
- tc-export AS LD CC CPP AR RANLIB NM OBJCOPY OBJDUMP STRIP
-
- default
-}
-
-src_compile() {
- use custom-cflags && export TBOOT_CFLAGS=${CFLAGS} || unset CCASFLAGS CFLAGS CPPFLAGS LDFLAGS
-
- if use amd64; then
- export MAKEARGS="TARGET_ARCH=x86_64"
- else
- export MAKEARGS="TARGET_ARCH=i686"
- fi
-
- default
-}
-
-src_install() {
- emake DISTDIR="${D}" install
-
- dodoc "${DOCS[@]}"
- dodoc docs/*.{txt,md}
-
- cd "${ED}" || die
- mkdir -p usr/lib/tboot/ || die
- mv boot usr/lib/tboot/ || die
-}
-
-pkg_postinst() {
- cp "${ROOT}/usr/lib/tboot/boot/"* "${ROOT}/boot/" || die
-
- ewarn "Please remember to download the SINIT AC Module relevant"
- ewarn "for your platform from:"
- ewarn "http://software.intel.com/en-us/articles/intel-trusted-execution-technology/"
-}