summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2021-12-25 20:38:44 -0600
committerMatthew Thode <prometheanfire@gentoo.org>2021-12-25 20:38:53 -0600
commit6036c7d3263b530cd52158fa143d2b6c0b635e7f (patch)
tree9094c66bc0fe4e7c4cd4a6bbf7d031f2a5dd38a5 /sys-boot
parentsys-fs/unionfs-fuse: add missing git-r3 inherit to 9999 (diff)
downloadgentoo-6036c7d3263b530cd52158fa143d2b6c0b635e7f.tar.gz
gentoo-6036c7d3263b530cd52158fa143d2b6c0b635e7f.tar.bz2
gentoo-6036c7d3263b530cd52158fa143d2b6c0b635e7f.zip
sys-boot/plymouth: 0.9.6 pre release due to upstream not tagging
https://gitlab.freedesktop.org/plymouth/plymouth/-/issues/158 Package-Manager: Portage-3.0.28, Repoman-3.0.3 Signed-off-by: Matthew Thode <prometheanfire@gentoo.org>
Diffstat (limited to 'sys-boot')
-rw-r--r--sys-boot/plymouth/Manifest1
-rw-r--r--sys-boot/plymouth/plymouth-0.9.6_p20211225.ebuild114
-rw-r--r--sys-boot/plymouth/plymouth-9999.ebuild6
3 files changed, 118 insertions, 3 deletions
diff --git a/sys-boot/plymouth/Manifest b/sys-boot/plymouth/Manifest
index 15fafdde46ea..a195adf94890 100644
--- a/sys-boot/plymouth/Manifest
+++ b/sys-boot/plymouth/Manifest
@@ -1,2 +1,3 @@
DIST gentoo-logo.png 14501 BLAKE2B e7236c16b96a2d35a6f062b89bc0a6c6fc696a803b7da734ff9ae255fcd65e549d9bc3d510c283e235a770f42edcbdffc1d5cc4c2fcdec9cc931eb0acf504859 SHA512 059a555931b6d2a910bcd887f5ea0cc17c6edf2d2d45c03a1fec1bdda0138ba6bca6bdf90a65c6520a3f8f1b51ecf6f7956098f45ed6c1276f29c835e729163c
DIST plymouth-0.9.5.tar.xz 1186200 BLAKE2B 8fd073703773fcf7f3e26454c860f094fb4b3d712c56c9df6716ef11815a79f7d5b078ab6c6567b76421026d84a086f95865bf9f3e4ae6363cb1ffc2caa68537 SHA512 686220e8d5b1a8be298156786d979d0e3fb9e010b930d0e8082a2bb152cf07c1bf493d820c243838a1771ee859dc0b4723bd9f10ee434a94a096ce9236c36ce9
+DIST plymouth-5b91b9ed84cc91759c986634a4d64d474e6092cf.tar.gz 1132049 BLAKE2B 0e224aad93fef4039a1a023ece051a64e1fa854f29a814957673c7ba68eb3f2348ca075f59a17f7bad692152ddcc402b2246db413886ac73ad77a36a6fb2cb3c SHA512 3d81ce379d0a11af5b557bfe86e336a40e5abdbb6dbd6cd5e046ede9a46cf2782af75b8e32e3fb2232b8a22efee1890ecb47394742041d9dcb499b38476a814c
diff --git a/sys-boot/plymouth/plymouth-0.9.6_p20211225.ebuild b/sys-boot/plymouth/plymouth-0.9.6_p20211225.ebuild
new file mode 100644
index 000000000000..6f1b09a81b37
--- /dev/null
+++ b/sys-boot/plymouth/plymouth-0.9.6_p20211225.ebuild
@@ -0,0 +1,114 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit flag-o-matic
+SRC_URI="https://dev.gentoo.org/~aidecoe/distfiles/${CATEGORY}/${PN}/gentoo-logo.png"
+
+if [[ ${PV} == 9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://gitlab.freedesktop.org/plymouth/plymouth"
+else
+ PRE_RELEASE_SHA="5b91b9ed84cc91759c986634a4d64d474e6092cf"
+ SRC_URI="${SRC_URI} https://gitlab.freedesktop.org/${PN}/${PN}/-/archive/${PRE_RELEASE_SHA}/${PN}-${PRE_RELEASE_SHA}.tar.gz"
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~ppc ~ppc64 ~riscv ~sparc ~x86"
+ S="${WORKDIR}/${PN}-${PRE_RELEASE_SHA}"
+fi
+
+inherit autotools readme.gentoo-r1 systemd
+
+DESCRIPTION="Graphical boot animation (splash) and logger"
+HOMEPAGE="https://cgit.freedesktop.org/plymouth/"
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE="debug +gtk +libkms +pango +split-usr static-libs +udev"
+
+CDEPEND="
+ >=media-libs/libpng-1.2.16:=
+ gtk? (
+ dev-libs/glib:2
+ >=x11-libs/gtk+-3.14:3
+ x11-libs/cairo
+ )
+ libkms? ( x11-libs/libdrm[libkms] )
+ pango? ( >=x11-libs/pango-1.21 )
+"
+DEPEND="${CDEPEND}
+ elibc_musl? ( sys-libs/rpmatch-standalone )
+ app-text/docbook-xsl-stylesheets
+ dev-libs/libxslt
+ virtual/pkgconfig
+"
+# Block due bug #383067
+RDEPEND="${CDEPEND}
+ udev? ( virtual/udev )
+ !<sys-kernel/dracut-0.37-r3
+"
+
+DOC_CONTENTS="
+ Follow the following instructions to set up Plymouth:\n
+ https://wiki.gentoo.org/wiki/Plymouth#Configuration
+"
+
+PATCHES=(
+ "${FILESDIR}"/0.9.3-glibc-sysmacros.patch
+)
+
+src_prepare() {
+ use elibc_musl && append-ldflags -lrpmatch
+ default
+ eautoreconf
+}
+
+src_configure() {
+ local myconf=(
+ --with-system-root-install=no
+ --localstatedir=/var
+ --without-rhgb-compat-link
+ --enable-documentation
+ --enable-systemd-integration
+ --with-systemdunitdir="$(systemd_get_systemunitdir)"
+ $(use_enable !static-libs shared)
+ $(use_enable static-libs static)
+ $(use_enable debug tracing)
+ $(use_enable gtk gtk)
+ $(use_enable libkms drm)
+ $(use_enable pango)
+ $(use_with udev)
+ )
+ econf "${myconf[@]}"
+}
+
+src_install() {
+ default
+
+ insinto /usr/share/plymouth
+ newins "${DISTDIR}"/gentoo-logo.png bizcom.png
+
+ if use split-usr ; then
+ # Install compatibility symlinks as some rdeps hardcode the paths
+ dosym ../usr/bin/plymouth /bin/plymouth
+ dosym ../usr/sbin/plymouth-set-default-theme /sbin/plymouth-set-default-theme
+ dosym ../usr/sbin/plymouthd /sbin/plymouthd
+ fi
+
+ readme.gentoo_create_doc
+
+ # looks like make install create /var/run/plymouth
+ # this is not needed for systemd, same should hold for openrc
+ # so remove
+ rm -rf "${D}"/var/run
+
+ # fix broken symlink
+ dosym ../../bizcom.png /usr/share/plymouth/themes/spinfinity/header-image.png
+}
+
+pkg_postinst() {
+ readme.gentoo_print_elog
+ if ! has_version "sys-kernel/dracut" && ! has_version "sys-kernel/genkernel-next[plymouth]"; then
+ ewarn "If you want initramfs builder with plymouth support, please emerge"
+ ewarn "sys-kernel/dracut or sys-kernel/genkernel-next[plymouth]."
+ fi
+}
diff --git a/sys-boot/plymouth/plymouth-9999.ebuild b/sys-boot/plymouth/plymouth-9999.ebuild
index 3c47d67a881e..3f303786005d 100644
--- a/sys-boot/plymouth/plymouth-9999.ebuild
+++ b/sys-boot/plymouth/plymouth-9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -11,10 +11,10 @@ if [[ ${PV} == 9999 ]]; then
EGIT_REPO_URI="https://gitlab.freedesktop.org/plymouth/plymouth"
else
SRC_URI="${SRC_URI} https://www.freedesktop.org/software/plymouth/releases/${P}.tar.xz"
- KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~ppc ~ppc64 ~riscv ~sparc ~x86"
fi
-inherit autotools readme.gentoo-r1 systemd toolchain-funcs
+inherit autotools readme.gentoo-r1 systemd
DESCRIPTION="Graphical boot animation (splash) and logger"
HOMEPAGE="https://cgit.freedesktop.org/plymouth/"