summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJason Zaman <perfinion@gentoo.org>2016-11-05 22:22:34 +0800
committerJason Zaman <perfinion@gentoo.org>2016-11-06 19:20:58 +0800
commit616d425ff490bbdeea4a8cbb7e1129506d254269 (patch)
treeb459cb2daa8b02b4a217886ce9c00d68dfa9fc45 /sys-boot
parentdev-java/jna: Remove old 3.4.0 (diff)
downloadgentoo-616d425ff490bbdeea4a8cbb7e1129506d254269.tar.gz
gentoo-616d425ff490bbdeea4a8cbb7e1129506d254269.tar.bz2
gentoo-616d425ff490bbdeea4a8cbb7e1129506d254269.zip
sys-boot/tboot: snapshot version from 20161101
To support kernels after 4.5.x Package-Manager: portage-2.3.0
Diffstat (limited to 'sys-boot')
-rw-r--r--sys-boot/tboot/Manifest1
-rw-r--r--sys-boot/tboot/tboot-1.9.4_p20161101.ebuild71
2 files changed, 72 insertions, 0 deletions
diff --git a/sys-boot/tboot/Manifest b/sys-boot/tboot/Manifest
index 2d382a524f70..a627cacda386 100644
--- a/sys-boot/tboot/Manifest
+++ b/sys-boot/tboot/Manifest
@@ -1 +1,2 @@
DIST tboot-1.9.4.tar.gz 2107175 SHA256 7167e5615def4ac0f25b2f9139b3d361a0a20d91386d80b1d865107b3f552f39 SHA512 93db95be54a1286dffe87cf6f5d1e31ac0c4a452b11a11789fec66255c847a9e14251579de0f6ba4c5c122423b45e83751a8287d37e27ea3acba608774d7ac0b WHIRLPOOL 2bf9220317dc5bbc927fb10d07a1d7f5cef2d5351fbf81e45f276b5f317785c1cfc1f1e4b78ac426bceb66641339d7179bff8fbbb867b67aa215544193a5baa1
+DIST tboot-1.9.4_p20161101.tar.gz 578097 SHA256 d6a399488fde1d0993a65bcb283cec218c7c8572972d2fdda8422fc2a1b5513f SHA512 6a38148d7be4faf8ec86f2f8e3c342321b7d8d4920a631b0e1b74bd27578039f4ae20faffae877ed8db5dd14500c059a3efd3eed24f22099820e87a67d3ecc17 WHIRLPOOL 316e3ac4965108a63ebf6075b50fb24b5c0a0c1527cb43309b95c64e60a0b6e5b3287e4b19faa8405ab10cf268b975cfd93d6348253a2d3fa07e78f38ef1eac8
diff --git a/sys-boot/tboot/tboot-1.9.4_p20161101.ebuild b/sys-boot/tboot/tboot-1.9.4_p20161101.ebuild
new file mode 100644
index 000000000000..3a509f038b8f
--- /dev/null
+++ b/sys-boot/tboot/tboot-1.9.4_p20161101.ebuild
@@ -0,0 +1,71 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+inherit flag-o-matic mount-boot
+
+DESCRIPTION="Performs a measured and verified boot using Intel Trusted Execution Technology"
+HOMEPAGE="https://sourceforge.net/projects/tboot/"
+SRC_URI="http://dev.gentoo.org/~perfinion/distfiles/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 -*"
+IUSE="custom-cflags selinux"
+
+# requires patching the kernel src
+RESTRICT="test"
+
+DEPEND="app-crypt/trousers
+app-crypt/tpm-tools
+dev-libs/openssl:0=[-bindist]"
+
+RDEPEND="${DEPEND}
+sys-boot/grub:2
+selinux? ( sec-policy/selinux-tboot )"
+
+DOCS=(README COPYING CHANGELOG)
+
+src_prepare() {
+ sed -i 's/ -Werror//g' Config.mk || die
+ sed -i 's/^INSTALL_STRIP = -s$//' Config.mk || die # QA Errors
+
+ default
+}
+
+src_compile() {
+ use custom-cflags && export TBOOT_CFLAGS=${CFLAGS} || unset CCASFLAGS CFLAGS CPPFLAGS LDFLAGS
+
+ if use amd64; then
+ MAKEARGS="TARGET_ARCH=x86_64"
+ else
+ MAKEARGS="TARGET_ARCH=i686"
+ fi
+
+ default
+}
+
+src_install() {
+ emake DISTDIR="${D}" install
+
+ dodoc "${DOCS[@]}"
+ dodoc docs/*.txt lcptools/*.{txt,pdf} || die "docs failed"
+
+ cd "${D}"
+ mkdir -p usr/lib/tboot/ || die
+ mv boot usr/lib/tboot/ || die
+}
+
+pkg_postinst() {
+ mount-boot_mount_boot_partition
+
+ cp ${ROOT%/}/usr/lib/tboot/boot/* ${ROOT%/}/boot/
+
+ mount-boot_pkg_postinst
+
+ ewarn "Please remember to download the SINIT AC Module relevant"
+ ewarn "for your platform from:"
+ ewarn "http://software.intel.com/en-us/articles/intel-trusted-execution-technology/"
+}