summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorStéphane Veyret <sveyret@gmail.com>2019-06-02 20:26:27 +0200
committerMichał Górny <mgorny@gentoo.org>2019-07-05 22:31:23 +0200
commit6c0eea48a98798c7185ca4de951ca8c8bcf92c5e (patch)
tree536b46b4e54c22ad3acfa1dfb833d2df0730b708 /sys-boot
parentsys-boot/udk: Simplify udk installation (diff)
downloadgentoo-6c0eea48a98798c7185ca4de951ca8c8bcf92c5e.tar.gz
gentoo-6c0eea48a98798c7185ca4de951ca8c8bcf92c5e.tar.bz2
gentoo-6c0eea48a98798c7185ca4de951ca8c8bcf92c5e.zip
sys-boot/refind: Bump to version 0.11.4
Signed-off-by: Stéphane VEYRET <sveyret@gmail.com> Closes: https://bugs.gentoo.org/684914 Package-Manager: Portage-2.3.66, Repoman-2.3.11 Closes: https://github.com/gentoo/gentoo/pull/12172 Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'sys-boot')
-rw-r--r--sys-boot/refind/Manifest1
-rw-r--r--sys-boot/refind/files/makefile.patch27
-rw-r--r--sys-boot/refind/refind-0.11.4.ebuild168
3 files changed, 196 insertions, 0 deletions
diff --git a/sys-boot/refind/Manifest b/sys-boot/refind/Manifest
index c1bfe87d3f82..a294c06247e8 100644
--- a/sys-boot/refind/Manifest
+++ b/sys-boot/refind/Manifest
@@ -1,3 +1,4 @@
DIST refind-src-0.10.4.tar.gz 3970380 BLAKE2B 0d14c005d3e93a1f0008b6c65e34eb6391c4a4a488b4fa7842c8f0b68eb2cc5be150c8718f01a65454db7b86ffa5873a3d1a96429eaed0cb92c1d29c8d2f7dcd SHA512 a75a6210ee51427c474e69c2de8c719545b2599c19f1c7541048b77ab1996a0e4b4b5fd4840f6240cd6704e5f5338cbaff432d7dc5ec4042854e26d6df18bed5
DIST refind-src-0.11.2.tar.gz 4533034 BLAKE2B fa05781fc1d87d314677f8e670bd7282b591fd3b6f4a5863e81cb962fdb773c774faabb6c45544b0659c8d5c4ef7ce1dba8d798a4caa97364ad7aa2532a42050 SHA512 796d86f05152d93340773c2dfbae0ca50ab036373ebed60fcc80404ee269ef4bc100df4b141d555d3363b820c3e9234fc0cf637791061281c86329958dca3479
DIST refind-src-0.11.3.tar.gz 3792206 BLAKE2B 369b25dbc97d83f9143ccbe19e89b5975f0796f1e4a2decfc124e4b45c5ef1db8f3e2bb83413f596ca28e82e67b0b9c5682b557a5422e3146780cec151d2a36e SHA512 96907b79e1c9c8199c62058bb6851fa5d6f158802f3777ba19a62c6c0d7d5b49132754bcafa925510fd21c8bafe8ce393117070a628baf4c277fa5f8f536b797
+DIST refind-src-0.11.4.tar.gz 3812192 BLAKE2B 7219eeffffb63961a7ba8f7617546a12021cfe80df80a83c4dbd47cd40b0d8afbdc510abb44de3029ff15ed49372bd59e0b156f4c27eab3ef7bd6ccc3c7e02db SHA512 529962ae432edaf1895ba98deb00a23c66bd742578e1a367f70f7ed22dd7be7daf1960df8af410fba79ca775169120499a4c10119331b2b12b55a002d4354de1
diff --git a/sys-boot/refind/files/makefile.patch b/sys-boot/refind/files/makefile.patch
new file mode 100644
index 000000000000..5db6f75b1919
--- /dev/null
+++ b/sys-boot/refind/files/makefile.patch
@@ -0,0 +1,27 @@
+diff --git a/Makefile b/Makefile
+--- a/Makefile
++++ b/Makefile
+@@ -161,8 +161,9 @@ fs_edk2: build_edk2
+ done
+
+ build_edk2: $(EDK2BASE)/RefindPkg
+- cd $(EDK2BASE) && \
+- . ./edksetup.sh BaseTools && \
++ +cd $(EDK2BASE) && \
++ . udk-workspace && \
++ build -a $(UC_ARCH) -p MdePkg/MdePkg.dsc && \
+ build -a $(UC_ARCH) -p RefindPkg/RefindPkg.dsc
+ mkdir -p ./drivers_$(FILENAME_CODE)
+
+diff --git a/filesystems/Makefile b/filesystems/Makefile
+index 99452ed..9bc984d 100644
+--- a/filesystems/Makefile
++++ b/filesystems/Makefile
+@@ -5,6 +5,7 @@
+ # name of the driver to be built. This is done because of a dependency
+ # in the fsw_efi.c file on the filesystem type; this file must be
+ # recompiled for each new filesystem built.
++.NOTPARALLEL:
+
+ # This program is licensed under the terms of the GNU GPL, version 3,
+ # or (at your option) any later version.
diff --git a/sys-boot/refind/refind-0.11.4.ebuild b/sys-boot/refind/refind-0.11.4.ebuild
new file mode 100644
index 000000000000..a45929a31c9c
--- /dev/null
+++ b/sys-boot/refind/refind-0.11.4.ebuild
@@ -0,0 +1,168 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit multiprocessing toolchain-funcs
+
+DESCRIPTION="The UEFI Boot Manager by Rod Smith"
+HOMEPAGE="https://www.rodsbooks.com/refind/"
+SRC_URI="mirror://sourceforge/project/${PN}/${PV}/${PN}-src-${PV}.tar.gz"
+
+LICENSE="BSD GPL-2 GPL-3 FDL-1.3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+FS_USE="btrfs +ext2 +ext4 hfs +iso9660 ntfs reiserfs"
+IUSE="${FS_USE} custom-cflags doc gnuefi"
+
+DEPEND="gnuefi? ( >=sys-boot/gnu-efi-3.0.2 )
+ !gnuefi? ( >=sys-boot/udk-2018-r1 )"
+
+DOCS=(README.txt)
+PATCHES=("${FILESDIR}/makefile.patch")
+UDK_WORKSPACE="${T}/udk"
+
+pkg_pretend() {
+ if use custom-cflags; then
+ ewarn
+ ewarn "You have enabled building with USE=custom-cflags. Be aware that"
+ ewarn "using this can result in EFI binaries that fail to run and may"
+ ewarn "fail to build at all. This is strongly advised against by upstream."
+ ewarn
+ ewarn "See https://bugs.gentoo.org/598587#c3 for more information"
+ ewarn
+ fi
+}
+
+pkg_setup() {
+ if use x86; then
+ export EFIARCH=ia32
+ export BUILDARCH=ia32
+ elif use amd64; then
+ export EFIARCH=x64
+ export BUILDARCH=x86_64
+ fi
+}
+
+src_prepare() {
+ default
+
+ # bug 598647 - PIE not supported
+ sed -e '/^CFLAGS/s:$: -fno-PIE:' -i Make.common || die
+
+ # Prepare UDK workspace
+ if ! use gnuefi; then
+ mkdir "${UDK_WORKSPACE}" || die
+ ln -s "${EPREFIX}/usr/lib/udk/"{Mde,IntelFramework}{,Module}Pkg \
+ "${UDK_WORKSPACE}" || die "Could not link UDK files"
+ fi
+}
+
+src_configure() {
+ if ! use gnuefi; then
+ # Use the side effect of the script which will create configuration files
+ (. udk-workspace "${UDK_WORKSPACE}" || die)
+ sed -e "s:^#\?\s*\(MAX_CONCURRENT_THREAD_NUMBER\s*=\).*$:\1 $(makeopts_jobs):" \
+ -i "${UDK_WORKSPACE}/Conf/target.txt" || die "Failed to configure target file"
+ sed -e "s:\(_\(CC\|ASM\|PP\|VFRPP\|ASLCC\|ASLPP\|DLINK\)_PATH\s*=\).*$:\1 $(tc-getCC):" \
+ -e "s:\(_ASLDLINK_PATH\s*=\).*$:\1 $(tc-getLD):" \
+ -e "s:\(_OBJCOPY_PATH\s*=\).*$:\1 $(tc-getOBJCOPY):" \
+ -e "s:\(_RC_PATH\s*=\).*$:\1 $(tc-getOBJCOPY):" \
+ -e "s:\(_SLINK_PATH\s*=\).*$:\1 $(tc-getAR):" \
+ -e "s:-Werror::" \
+ -i "${UDK_WORKSPACE}/Conf/tools_def.txt" \
+ || die "Failed to prepare tools definition file"
+ fi
+}
+
+src_compile() {
+ # Update fs targets depending on uses
+ local fs fs_names=()
+ for fs in ${FS_USE}; do
+ fs=${fs#+}
+ if use "${fs}"; then
+ fs_names+=(${fs})
+ fi
+ done
+ use gnuefi && fs_names=("${fs_names[@]/%/_gnuefi}")
+
+ # Prepare flags
+ local make_flags=(
+ ARCH="${BUILDARCH}"
+ CC="$(tc-getCC)"
+ AS="$(tc-getAS)"
+ LD="$(tc-getLD)"
+ AR="$(tc-getAR)"
+ RANLIB="$(tc-getRANLIB)"
+ OBJCOPY="$(tc-getOBJCOPY)"
+ GNUEFILIB="/usr/$(get_libdir)"
+ EFILIB="/usr/$(get_libdir)"
+ EFICRT0="/usr/$(get_libdir)"
+ EDK2BASE="${UDK_WORKSPACE}"
+ EDK2_DRIVER_BASENAMES="${fs_names[@]}"
+ FILESYSTEMS="${fs_names[@]}"
+ FILESYSTEMS_GNUEFI="${fs_names[@]}"
+ )
+ if use custom-cflags; then
+ make_flags=(CFLAGS="${CFLAGS}" "${make_flags[@]}")
+ fi
+
+ emake "${make_flags[@]}" all_$(usex gnuefi gnuefi edk2)
+}
+
+src_install() {
+ exeinto "/usr/lib/${PN}"
+ doexe refind-install
+ dosym "../lib/${PN}/refind-install" "/usr/sbin/refind-install"
+
+ if use doc; then
+ doman "docs/man/"*
+ DOCS+=(NEWS.txt docs/refind docs/Styles)
+ fi
+ einstalldocs
+
+ insinto "/usr/lib/${PN}/refind"
+ doins "refind/refind_${EFIARCH}.efi"
+ doins "refind.conf-sample"
+ doins -r images icons fonts banners
+
+ if [[ -d "drivers_${EFIARCH}" ]]; then
+ doins -r "drivers_${EFIARCH}"
+ fi
+
+ insinto "/usr/lib/${PN}/refind/tools_${EFIARCH}"
+ doins "gptsync/gptsync_${EFIARCH}.efi"
+
+ insinto "/etc/refind.d"
+ doins -r "keys"
+
+ dosbin "mkrlconf"
+ dosbin "mvrefind"
+ dosbin "refind-mkdefault"
+}
+
+pkg_postinst() {
+ elog "rEFInd has been built and installed into ${EROOT}/usr/lib/${PN}"
+ elog "You will need to use the command 'refind-install' to install"
+ elog "the binaries into your EFI System Partition"
+ elog ""
+ if [[ -z "${REPLACING_VERSIONS}" ]]; then
+ elog "refind-install requires additional packages to be fully functional:"
+ elog " app-crypt/sbsigntools for binary signing for use with SecureBoot"
+ elog " sys-boot/efibootmgr for writing to NVRAM"
+ elog " sys-block/parted for automatic ESP location and mount"
+ elog ""
+ elog "refind-mkdefault requires >=dev-lang/python-3"
+ elog ""
+ elog "A sample configuration can be found at"
+ elog "${EROOT}/usr/lib/${PN}/refind/refind.conf-sample"
+ else
+ if ver_test "${REPLACING_VERSIONS}" -lt "0.10.3"; then
+ elog "The new refind-mkdefault script requires >=dev-lang/python-3"
+ elog "to be installed"
+ elog ""
+ fi
+ ewarn "Note that this installation will not update any EFI binaries"
+ ewarn "on your EFI System Partition - this needs to be done manually"
+ fi
+}