summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJoshua Kinard <kumba@gentoo.org>2021-08-16 21:47:56 -0400
committerJoshua Kinard <kumba@gentoo.org>2021-08-16 23:58:33 -0400
commit7debbc1b9856e3d994a546b981ee031a5bba3738 (patch)
tree6d5217325ae8f5f96a52b6729b72acd0000bc22e /sys-boot
parentwww-apps/icingaweb2: added another missing dep (diff)
downloadgentoo-7debbc1b9856e3d994a546b981ee031a5bba3738.tar.gz
gentoo-7debbc1b9856e3d994a546b981ee031a5bba3738.tar.bz2
gentoo-7debbc1b9856e3d994a546b981ee031a5bba3738.zip
sys-boot/sgibootcd: Bump version after refactoring code
I finally refactored the code to make it a bit more readable and fix several compiler warnings. The upstream author long ago abandoned this project, so that makes me the maintainer now. Also changed the ebuild to EAPI 8 and fixed some other bits and cut a new version. Signed-off-by: Joshua Kinard <kumba@gentoo.org> Package-Manager: Portage-3.0.20, Repoman-3.0.3
Diffstat (limited to 'sys-boot')
-rw-r--r--sys-boot/sgibootcd/Manifest2
-rw-r--r--sys-boot/sgibootcd/metadata.xml5
-rw-r--r--sys-boot/sgibootcd/sgibootcd-0.12.ebuild30
-rw-r--r--sys-boot/sgibootcd/sgibootcd-0.13.ebuild40
4 files changed, 46 insertions, 31 deletions
diff --git a/sys-boot/sgibootcd/Manifest b/sys-boot/sgibootcd/Manifest
index 828a3fbd7a5b..1b7eb70f936c 100644
--- a/sys-boot/sgibootcd/Manifest
+++ b/sys-boot/sgibootcd/Manifest
@@ -1 +1 @@
-DIST sgibootcd-0.12.tar.bz2 3810 BLAKE2B 973c6e01f1e90b9009b57725e59e295e8cbdcc30595735eab1a4cd3929aa71edde66d352bb04b61670eb7ad464916d0e4b83f6fabbc8f641c150edcf96f4985c SHA512 180e4f5a185b14c0b2c8158b368a50a3a55673fa86760e2a424c9533b1bb8ec37824c715ba02fd264621e2e31906ddd310398e9f24cf19147bce3e49fc62da3e
+DIST sgibootcd-0.13.tar.xz 3736 BLAKE2B 793825c9ad88449b187ceab28d474e5676d45d3ea2c649dbbf669f00cf6dc9d55bc1e9900a4bf321a7dfddd8f5bc65e5e2fbc61fe913e7be43df9064118efcac SHA512 aa7780e360e0b5d4c9c0d6b5894897fa5f6ff13b1a389ba913f27cbdf8173db123e59426391d2a0e154f836277a780dc004617608adb88e7e6f3e8b6348729f9
diff --git a/sys-boot/sgibootcd/metadata.xml b/sys-boot/sgibootcd/metadata.xml
index 73a6ab039600..62beb542de0a 100644
--- a/sys-boot/sgibootcd/metadata.xml
+++ b/sys-boot/sgibootcd/metadata.xml
@@ -5,4 +5,9 @@
<email>mips@gentoo.org</email>
<name>Mips Team</name>
</maintainer>
+
+ <longdescription>
+ sgibootcd is a small utility used to create the burnable,
+ non-ISO9660 image format for bootable CDs for SGI systems.
+ </longdescription>
</pkgmetadata>
diff --git a/sys-boot/sgibootcd/sgibootcd-0.12.ebuild b/sys-boot/sgibootcd/sgibootcd-0.12.ebuild
deleted file mode 100644
index c9545e0a82f1..000000000000
--- a/sys-boot/sgibootcd/sgibootcd-0.12.ebuild
+++ /dev/null
@@ -1,30 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI="7"
-inherit toolchain-funcs
-
-DESCRIPTION="Creates burnable CD images for SGI LiveCDs"
-HOMEPAGE="ftp://ftp.linux-mips.org/pub/linux/mips/people/skylark/"
-SRC_URI="ftp://ftp.linux-mips.org/pub/linux/mips/people/skylark/${P}.tar.bz2"
-
-LICENSE="all-rights-reserved"
-SLOT="0"
-KEYWORDS="-* ~mips"
-
-IUSE=""
-RDEPEND=""
-DEPEND=""
-RESTRICT=""
-
-src_compile() {
- local mycc="$(tc-getCC) ${CFLAGS}"
-
- [ -f "${S}/sgibootcd" ] && rm -f "${S}"/sgibootcd
- einfo "${mycc} sgibootcd.c -o sgibootcd"
- ${mycc} sgibootcd.c -o sgibootcd
-}
-
-src_install() {
- dobin "${S}"/sgibootcd
-}
diff --git a/sys-boot/sgibootcd/sgibootcd-0.13.ebuild b/sys-boot/sgibootcd/sgibootcd-0.13.ebuild
new file mode 100644
index 000000000000..4ecf329c44a2
--- /dev/null
+++ b/sys-boot/sgibootcd/sgibootcd-0.13.ebuild
@@ -0,0 +1,40 @@
+# Copyright 2005-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="8"
+inherit toolchain-funcs
+
+DESCRIPTION="Creates burnable CD images for SGI LiveCDs"
+HOMEPAGE="ftp://ftp.linux-mips.org/pub/linux/mips/people/skylark/"
+SRC_URI="https://dev.gentoo.org/~kumba/distfiles/${P}.tar.xz"
+
+LICENSE="all-rights-reserved"
+SLOT="0"
+KEYWORDS="-* ~mips"
+
+IUSE=""
+RDEPEND=""
+DEPEND=""
+RESTRICT=""
+
+# sgibootcd is a small utility used to build the image that is burned to a
+# CD and used to boot SGI systems. Its compilation does not involve the
+# external linker, 'ld', and thus this makes it difficult to reliably pass
+# user LDFLAGS. See Bug #725836.
+QA_FLAGS_IGNORED="/usr/bin/sgibootcd"
+
+src_compile() {
+ local mycc="$(tc-getCC) ${CFLAGS}"
+
+ # There is no Makefile, so check for an existing binary
+ # and remove it if necessary
+ [[ -f "${S}/sgibootcd" ]] && rm -f "${S}"/sgibootcd
+
+ # Compile sgibootcd.c to a standalone executable.
+ einfo "${mycc} sgibootcd.c -o sgibootcd"
+ ${mycc} sgibootcd.c -o sgibootcd
+}
+
+src_install() {
+ dobin "${S}"/sgibootcd
+}