summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2022-04-19 16:27:20 +0100
committerSam James <sam@gentoo.org>2022-05-14 00:45:31 +0000
commitb72e496529fc13862f2f5fc2b3871d93b485c0cd (patch)
treec2339423a7895c4e5f93371a55f73fb32a02c6fe /sys-boot
parentwww-client/w3m: bump to latest release (20220429) (diff)
downloadgentoo-b72e496529fc13862f2f5fc2b3871d93b485c0cd.tar.gz
gentoo-b72e496529fc13862f2f5fc2b3871d93b485c0cd.tar.bz2
gentoo-b72e496529fc13862f2f5fc2b3871d93b485c0cd.zip
sys-boot/elilo: [QA] inline ESYSROOT
ESYSROOT is SYSROOT/EPREFIX in >= EAPI 7 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'sys-boot')
-rw-r--r--sys-boot/elilo/elilo-3.16-r5.ebuild6
1 files changed, 3 insertions, 3 deletions
diff --git a/sys-boot/elilo/elilo-3.16-r5.ebuild b/sys-boot/elilo/elilo-3.16-r5.ebuild
index fed811421390..1aa5387103e1 100644
--- a/sys-boot/elilo/elilo-3.16-r5.ebuild
+++ b/sys-boot/elilo/elilo-3.16-r5.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -62,7 +62,7 @@ src_compile() {
# "prefix" on the next line specifies where to find gcc, as, ld,
# etc. It's not the usual meaning of "prefix". By blanking it we
# allow PATH to be searched.
- local libdir="${SYSROOT}${EPREFIX}/usr/$(get_libdir)"
+ local libdir="${ESYSROOT}/usr/$(get_libdir)"
emake -j1 \
prefix= \
AS="$(tc-getAS)" \
@@ -71,7 +71,7 @@ src_compile() {
OBJCOPY="$(tc-getOBJCOPY)" \
HOSTARCH=${iarch} \
ARCH=${iarch} \
- EFIINC="${SYSROOT}${EPREFIX}/usr/include/efi" \
+ EFIINC="${ESYSROOT}/usr/include/efi" \
GNUEFILIB="${libdir}" \
EFILIB="${libdir}" \
EFICRT0="${libdir}" \