summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick McLean <patrick.mclean@sony.com>2021-04-02 21:15:20 -0700
committerPatrick McLean <chutzpah@gentoo.org>2021-04-02 21:20:03 -0700
commitb2d98f7c634994ea1f55511ab74e3280fcc44775 (patch)
tree4d4336c1c967b83bd881c9b63eb488b76e8b740b /sys-cluster/ceph/files/ceph-16.2.0-liburing.patch
parentacct-user/unbound-telemetry: Remove old (diff)
downloadgentoo-b2d98f7c634994ea1f55511ab74e3280fcc44775.tar.gz
gentoo-b2d98f7c634994ea1f55511ab74e3280fcc44775.tar.bz2
gentoo-b2d98f7c634994ea1f55511ab74e3280fcc44775.zip
sys-cluster/ceph-16.2.0: Version bump
Copyright: Sony Interactive Entertainment Inc. Package-Manager: Portage-3.0.17, Repoman-3.0.2 Signed-off-by: Patrick McLean <chutzpah@gentoo.org>
Diffstat (limited to 'sys-cluster/ceph/files/ceph-16.2.0-liburing.patch')
-rw-r--r--sys-cluster/ceph/files/ceph-16.2.0-liburing.patch35
1 files changed, 35 insertions, 0 deletions
diff --git a/sys-cluster/ceph/files/ceph-16.2.0-liburing.patch b/sys-cluster/ceph/files/ceph-16.2.0-liburing.patch
new file mode 100644
index 000000000000..dd248d51ac61
--- /dev/null
+++ b/sys-cluster/ceph/files/ceph-16.2.0-liburing.patch
@@ -0,0 +1,35 @@
+diff --git a/cmake/modules/Finduring.cmake b/cmake/modules/Finduring.cmake
+index 10c8de4255..c0a4dadfe4 100644
+--- a/cmake/modules/Finduring.cmake
++++ b/cmake/modules/Finduring.cmake
+@@ -8,10 +8,10 @@ find_path(URING_INCLUDE_DIR liburing.h)
+ find_library(URING_LIBRARIES liburing.a liburing)
+
+ include(FindPackageHandleStandardArgs)
+-find_package_handle_standard_args(uring DEFAULT_MSG URING_LIBRARIES URING_INCLUDE_DIR)
++pkg_check_modules(URING REQUIRED liburing)
+
+ if(uring_FOUND AND NOT TARGET uring::uring)
+- add_library(uring::uring UNKNOWN IMPORTED)
++ add_library(uring::uring ALIAS ${URING_LIBRARIES})
+ set_target_properties(uring::uring PROPERTIES
+ INTERFACE_INCLUDE_DIRECTORIES "${URING_INCLUDE_DIR}"
+ IMPORTED_LINK_INTERFACE_LANGUAGES "C"
+diff --git a/src/blk/CMakeLists.txt b/src/blk/CMakeLists.txt
+index dc4f9b82ae..e39d690394 100644
+--- a/src/blk/CMakeLists.txt
++++ b/src/blk/CMakeLists.txt
+@@ -52,10 +52,11 @@ endif()
+
+ if(WITH_LIBURING)
+ if(WITH_SYSTEM_LIBURING)
+- find_package(uring REQUIRED)
++ list(APPEND CMAKE_MODULE_PATH "${CMAKE_SOURCE_DIR}../../cmake/modules/")
++ pkg_check_modules(URING REQUIRED liburing)
+ else()
+ include(Builduring)
+ build_uring()
+ endif()
+- target_link_libraries(blk PRIVATE uring::uring)
++ target_link_libraries(blk PRIVATE ${URING_LIBRARIES})
+ endif()