summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorOliver Freyermuth <o.freyermuth@googlemail.com>2019-05-22 22:38:59 +0200
committerMichał Górny <mgorny@gentoo.org>2019-07-07 20:31:03 +0200
commit82c98494938307bbec93a7399ded30955069e39e (patch)
tree57657a2f7167e76dab386cf60ff37a971e3affa3 /sys-cluster/charliecloud/files
parentmedia-gfx/gimp: 2.10.12 (diff)
downloadgentoo-82c98494938307bbec93a7399ded30955069e39e.tar.gz
gentoo-82c98494938307bbec93a7399ded30955069e39e.tar.bz2
gentoo-82c98494938307bbec93a7399ded30955069e39e.zip
sys-cluster/charliecloud: Version bump to 0.9.10
Package-Manager: Portage-2.3.66, Repoman-2.3.12 Signed-off-by: Oliver Freyermuth <o.freyermuth@googlemail.com> Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'sys-cluster/charliecloud/files')
-rw-r--r--sys-cluster/charliecloud/files/charliecloud-0.9.10-fix-flags.patch37
-rw-r--r--sys-cluster/charliecloud/files/charliecloud-0.9.10-fix-hardcoded-gcc.patch21
2 files changed, 58 insertions, 0 deletions
diff --git a/sys-cluster/charliecloud/files/charliecloud-0.9.10-fix-flags.patch b/sys-cluster/charliecloud/files/charliecloud-0.9.10-fix-flags.patch
new file mode 100644
index 000000000000..24f2f2d72532
--- /dev/null
+++ b/sys-cluster/charliecloud/files/charliecloud-0.9.10-fix-flags.patch
@@ -0,0 +1,37 @@
+From f0b867bb3bb527150e86a891c0c84dff3acc39e8 Mon Sep 17 00:00:00 2001
+From: Peter Wienemann <wienemann@physik.uni-bonn.de>
+Date: Mon, 1 Jul 2019 19:17:25 +0200
+Subject: [PATCH] PR #462 from @wiene: Add missing compiler flags for examples
+
+This patch ensures that CFLAGS, CPPFLAGS and LDFLAGS settings are
+respected when compiling/linking (lib)sotest, pivot_root and userns.
+---
+ examples/syscalls/Makefile | 2 +-
+ test/Makefile | 4 ++--
+ 2 files changed, 3 insertions(+), 3 deletions(-)
+
+diff --git a/examples/syscalls/Makefile b/examples/syscalls/Makefile
+index 4dbef21b..177ab42a 100644
+--- a/examples/syscalls/Makefile
++++ b/examples/syscalls/Makefile
+@@ -10,4 +10,4 @@ clean:
+ $(BINS): Makefile
+
+ %: %.c
+- gcc $(CFLAGS) $< -o $@
++ gcc $(CFLAGS) $(CPPFLAGS) $(LDFLAGS) $< -o $@
+diff --git a/test/Makefile b/test/Makefile
+index 50f24596..97a9316b 100644
+--- a/test/Makefile
++++ b/test/Makefile
+@@ -81,8 +81,8 @@ sotest/lib/libsotest.so.1.0: sotest/libsotest.so.1.0
+ # the container. (Issue #227.)
+
+ sotest/sotest: sotest/sotest.c sotest/libsotest.so.1.0
+- gcc -o $@ -L./sotest -lsotest $^
++ gcc -o $@ $(CFLAGS) $(CPPFLAGS) $(LDFLAGS) -L./sotest -lsotest $^
+ sotest/libsotest.so.1.0: sotest/libsotest.c
+- gcc -o $@ -shared -fPIC -Wl,-soname,libsotest.so.1 -lc $^
++ gcc -o $@ $(CFLAGS) $(CPPFLAGS) $(LDFLAGS) -shared -fPIC -Wl,-soname,libsotest.so.1 -lc $^
+ ln -f -s libsotest.so.1.0 sotest/libsotest.so
+ ln -f -s libsotest.so.1.0 sotest/libsotest.so.1
diff --git a/sys-cluster/charliecloud/files/charliecloud-0.9.10-fix-hardcoded-gcc.patch b/sys-cluster/charliecloud/files/charliecloud-0.9.10-fix-hardcoded-gcc.patch
new file mode 100644
index 000000000000..5654e71da5ad
--- /dev/null
+++ b/sys-cluster/charliecloud/files/charliecloud-0.9.10-fix-hardcoded-gcc.patch
@@ -0,0 +1,21 @@
+From d42f3201bb91c582d4533c732e167961030091f9 Mon Sep 17 00:00:00 2001
+From: Oliver Freyermuth <o.freyermuth@googlemail.com>
+Date: Sat, 6 Jul 2019 17:01:06 +0200
+Subject: [PATCH] examples/syscall/Makefile: Fix hardcoded call to gcc.
+
+To be open for choice of different C compilers,
+honour CC variable.
+---
+ examples/syscalls/Makefile | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/examples/syscalls/Makefile b/examples/syscalls/Makefile
+index 177ab42a..7dc9a4b8 100644
+--- a/examples/syscalls/Makefile
++++ b/examples/syscalls/Makefile
+@@ -10,4 +10,4 @@ clean:
+ $(BINS): Makefile
+
+ %: %.c
+- gcc $(CFLAGS) $(CPPFLAGS) $(LDFLAGS) $< -o $@
++ $(CC) $(CFLAGS) $(CPPFLAGS) $(LDFLAGS) $< -o $@