summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorOliver Freyermuth <o.freyermuth@googlemail.com>2023-01-26 23:29:39 +0100
committerNicolas Bock <nicolasbock@gentoo.org>2023-01-27 09:55:59 -0700
commitffe65d0e92e55ecb9e15456dc08ef1d9203d1d2e (patch)
treeace55df9686cabf2e8c167aef41deaf47c028a69 /sys-cluster/charliecloud
parentsys-cluster/charliecloud: add 0.31 (diff)
downloadgentoo-ffe65d0e92e55ecb9e15456dc08ef1d9203d1d2e.tar.gz
gentoo-ffe65d0e92e55ecb9e15456dc08ef1d9203d1d2e.tar.bz2
gentoo-ffe65d0e92e55ecb9e15456dc08ef1d9203d1d2e.zip
sys-cluster/charliecloud: drop 0.29
Closes: https://github.com/gentoo/gentoo/pull/29287 Signed-off-by: Oliver Freyermuth <o.freyermuth@googlemail.com> Signed-off-by: Nicolas Bock <nicolasbock@gentoo.org>
Diffstat (limited to 'sys-cluster/charliecloud')
-rw-r--r--sys-cluster/charliecloud/Manifest1
-rw-r--r--sys-cluster/charliecloud/charliecloud-0.29.ebuild83
2 files changed, 0 insertions, 84 deletions
diff --git a/sys-cluster/charliecloud/Manifest b/sys-cluster/charliecloud/Manifest
index f2c1ca0554f3..811aae998e40 100644
--- a/sys-cluster/charliecloud/Manifest
+++ b/sys-cluster/charliecloud/Manifest
@@ -1,3 +1,2 @@
-DIST charliecloud-0.29.tar.gz 506974 BLAKE2B 2f5ce5f6addf1abbb3274f8e8a9d33cc7ec73ba275efc4d750806b5fc2358ad9491da453ae4dcad712567b5719a4b179644e630b64fe9c29cfc2525a06e533a0 SHA512 a8f334cf1ac9fa1117b69f1282b74a3bce313b8fd892373dd7cfa642f664fcd623a8e8d2b81aa9757e43f972cd31fca9185e00d2280b40def2c63c725cea7256
DIST charliecloud-0.30.tar.gz 524870 BLAKE2B 0eadb4abda47554117aa657c3335d0ad95c71a3ccae67af000beeb8e375058002821783824142208ab58dcf7a62141d1eee45ac4241fe53cd2b206bbbbbb10b4 SHA512 a7188594482b712521930b141e10a981f7536b979f14c3a206f02895f8404a9095b17fc6764f937bdb466624ca6074cc0cbc84f33d59b4453b55be5691f4fbd4
DIST charliecloud-0.31.tar.gz 534662 BLAKE2B 08f95f4e37e4de3590344f14cf1ce6e502af414806cc625b8b4be454c1e1e9611d40e599828033a08dfba8ff6fa6fbcee107f19c38ce247addace6a91876dea8 SHA512 9fdcabbf533ab42556bcd8552c42dce3096dffd1f863e2a7a2e87a4596e1df601d55e56fde48cfd88fac62b31bad4257d1b1cdbb9a82df3e32ad4b5f1842307e
diff --git a/sys-cluster/charliecloud/charliecloud-0.29.ebuild b/sys-cluster/charliecloud/charliecloud-0.29.ebuild
deleted file mode 100644
index db6df71719a9..000000000000
--- a/sys-cluster/charliecloud/charliecloud-0.29.ebuild
+++ /dev/null
@@ -1,83 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-PYTHON_COMPAT=( python3_{9..11} )
-
-inherit autotools optfeature python-single-r1
-
-if [[ ${PV} == "9999" ]] ; then
- inherit git-r3
- EGIT_REPO_URI="https://github.com/hpc/${PN}.git"
- S="${WORKDIR}/${P}"
-else
- SRC_URI="https://github.com/hpc/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
- KEYWORDS="~amd64 ~x86 ~x86-linux"
-fi
-
-DESCRIPTION="Lightweight user-defined software stacks for high-performance computing"
-HOMEPAGE="https://hpc.github.io/charliecloud/"
-
-SLOT="0"
-LICENSE="Apache-2.0"
-IUSE="ch-image doc"
-
-# Extensive test suite exists, but downloads container images
-# directly and via Docker and installs packages inside using apt/yum.
-# Additionally, clashes with portage namespacing and sandbox.
-RESTRICT="test"
-
-REQUIRED_USE="${PYTHON_REQUIRED_USE}"
-
-RDEPEND="${PYTHON_DEPS}
- elibc_musl? ( sys-libs/argp-standalone )
-"
-DEPEND="
- ch-image? (
- $(python_gen_cond_dep '
- dev-python/lark[${PYTHON_USEDEP}]
- dev-python/requests[${PYTHON_USEDEP}]
- ')
- )
- doc? (
- $(python_gen_cond_dep '
- dev-python/sphinx[${PYTHON_USEDEP}]
- dev-python/sphinx_rtd_theme[${PYTHON_USEDEP}]
- ')
- net-misc/rsync
- )"
-
-src_prepare() {
- default
- eautoreconf
-}
-
-src_configure() {
- local econf_args=()
- econf_args+=(
- $(use_enable doc html)
- $(use_enable ch-image)
- # Libdir is used as a libexec-style destination.
- --libdir="${EPREFIX}"/usr/lib
- # Attempts to call python-exec directly otherwise.
- --with-sphinx-python="${EPYTHON}"
- # This disables -Werror, see also: https://github.com/hpc/charliecloud/pull/808
- --enable-buggy-build
- # Do not use bundled version of dev-python/lark.
- --disable-bundled-lark
- # Use correct shebang.
- --with-python="${PYTHON}"
- )
- econf "${econf_args[@]}"
-}
-
-pkg_postinst() {
- elog "Various builders are supported, as alternative to the internal ch-image."
- optfeature "Building with Buildah" app-containers/buildah
- optfeature "Building with Docker" app-containers/docker
- optfeature "Progress bars during long operations" sys-apps/pv
- optfeature "Pack and unpack squashfs images" sys-fs/squashfs-tools
- optfeature "Mount and umount squashfs images" sys-fs/squashfuse
- optfeature "Build versioning with ch-image" dev-vcs/git
-}