summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJames Le Cuirot <chewi@gentoo.org>2017-10-22 14:16:07 +0100
committerJames Le Cuirot <chewi@gentoo.org>2017-10-22 15:16:43 +0100
commitbbe740704477875c80a724ad69f0c8dcd1540861 (patch)
treee2ed1bd712836cdf4b476ff0ece8b4b3d55b3b68 /sys-cluster/glusterfs/files
parentapp-backup/flexbackup: stable 1.2.1-r13 for ppc, bug #635042 (diff)
downloadgentoo-bbe740704477875c80a724ad69f0c8dcd1540861.tar.gz
gentoo-bbe740704477875c80a724ad69f0c8dcd1540861.tar.bz2
gentoo-bbe740704477875c80a724ad69f0c8dcd1540861.zip
sys-cluster/glusterfs: Bump to 3.12.2, EAPI 6, fix #616760, and more
* Fix URLs. * Prefix fixes. * Migration away from autotools-utils.eclass. * Create user and group for statedumps. * Use upstream tmpfiles.d file. * Fix poisoned sysmacros.h issue (#616760). Package-Manager: Portage-2.3.8, Repoman-2.3.2 Closes: https://bugs.gentoo.org/631392
Diffstat (limited to 'sys-cluster/glusterfs/files')
-rw-r--r--sys-cluster/glusterfs/files/glusterd-r3.initd32
-rw-r--r--sys-cluster/glusterfs/files/glusterfs-3.12.2-poisoned-sysmacros.patch11
-rw-r--r--sys-cluster/glusterfs/files/glusterfs-3.12.2-silent_rules.patch22
3 files changed, 65 insertions, 0 deletions
diff --git a/sys-cluster/glusterfs/files/glusterd-r3.initd b/sys-cluster/glusterfs/files/glusterd-r3.initd
new file mode 100644
index 000000000000..27682d06216d
--- /dev/null
+++ b/sys-cluster/glusterfs/files/glusterd-r3.initd
@@ -0,0 +1,32 @@
+#!/sbin/openrc-run
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+description="Gluster elastic volume management daemon"
+command="/usr/sbin/glusterd"
+pidfile="/var/run/${SVCNAME}.pid"
+command_args="-N"
+
+command_background="yes"
+
+depend() {
+ need net
+ before netmount
+}
+
+start_pre() {
+ # Ensure that the GlusterFS auxiliary mount parent directory exists
+ checkpath --directory --owner gluster:gluster --mode 0775 /var/run/gluster
+}
+
+start_post() {
+ local c=0
+ ebegin "Waiting for glusterd to start up"
+ while ! /usr/sbin/gluster volume list &>/dev/null && [ "${c}" -lt "${glusterd_max_wait_start-60}" ]; do
+ (( ++c ))
+ done
+ [ "${c}" -lt "${glusterd_max_wait_start-60}" ]
+ eend $?
+
+ return 0
+}
diff --git a/sys-cluster/glusterfs/files/glusterfs-3.12.2-poisoned-sysmacros.patch b/sys-cluster/glusterfs/files/glusterfs-3.12.2-poisoned-sysmacros.patch
new file mode 100644
index 000000000000..341535163747
--- /dev/null
+++ b/sys-cluster/glusterfs/files/glusterfs-3.12.2-poisoned-sysmacros.patch
@@ -0,0 +1,11 @@
+diff --git a/libglusterfs/src/compat.h b/libglusterfs/src/compat.h
+index 1d0ac27e8..b1a7c0a93 100644
+--- a/libglusterfs/src/compat.h
++++ b/libglusterfs/src/compat.h
+@@ -510,6 +510,7 @@ int gf_mkostemp (char *tmpl, int suffixlen, int flags);
+ /* Use run API, see run.h */
+ #include <stdlib.h> /* system(), mkostemp() */
+ #include <stdio.h> /* popen() */
++#include <sys/sysmacros.h>
+ #pragma GCC poison system mkostemp popen
+ #endif
diff --git a/sys-cluster/glusterfs/files/glusterfs-3.12.2-silent_rules.patch b/sys-cluster/glusterfs/files/glusterfs-3.12.2-silent_rules.patch
new file mode 100644
index 000000000000..d5e2727aa8df
--- /dev/null
+++ b/sys-cluster/glusterfs/files/glusterfs-3.12.2-silent_rules.patch
@@ -0,0 +1,22 @@
+--- a/configure.ac 2017-08-30 13:46:34.075359703 +0100
++++ b/configure.ac 2017-09-07 21:28:48.110879291 +0100
+@@ -19,19 +19,6 @@
+ #but libglusterfs fails to build with contrib (Then are not set up that way?)
+ #AM_INIT_AUTOMAKE([subdir-objects])
+
+-m4_ifdef([AM_SILENT_RULES], [AM_SILENT_RULES(yes)])
+-
+-if make --help 2>&1 | grep -q no-print-directory; then
+- AM_MAKEFLAGS="$AM_MAKEFLAGS --no-print-directory";
+-fi
+-
+-if make --help 2>&1 | grep -q quiet; then
+- AM_MAKEFLAGS="$AM_MAKEFLAGS --quiet"
+-fi
+-
+-if libtool --help 2>&1 | grep -q quiet; then
+- AM_LIBTOOLFLAGS="--quiet";
+-fi
+
+ AC_CONFIG_HEADERS([config.h site.h])
+