summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-07-31 02:33:43 +0100
committerSam James <sam@gentoo.org>2021-07-31 02:37:11 +0100
commite68166f39e0c03b05b98cafc019b92b3e1a04807 (patch)
treea34125d931eb370b67d1d768d6d5d15241fcc2ea /sys-cluster/glusterfs/glusterfs-8.3-r1.ebuild
parentapp-crypt/nitrocli: Bump version to 0.4.1 (diff)
downloadgentoo-e68166f39e0c03b05b98cafc019b92b3e1a04807.tar.gz
gentoo-e68166f39e0c03b05b98cafc019b92b3e1a04807.tar.bz2
gentoo-e68166f39e0c03b05b98cafc019b92b3e1a04807.zip
sys-cluster/glusterfs: consistently call tmpfiles_process in pkg_postinst
We weren't always calling tmpfiles_process in pkg_postinst, nor we were always using the correct filename. Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'sys-cluster/glusterfs/glusterfs-8.3-r1.ebuild')
-rw-r--r--sys-cluster/glusterfs/glusterfs-8.3-r1.ebuild12
1 files changed, 7 insertions, 5 deletions
diff --git a/sys-cluster/glusterfs/glusterfs-8.3-r1.ebuild b/sys-cluster/glusterfs/glusterfs-8.3-r1.ebuild
index c6fc8ce35bc6..79808b9e3ff6 100644
--- a/sys-cluster/glusterfs/glusterfs-8.3-r1.ebuild
+++ b/sys-cluster/glusterfs/glusterfs-8.3-r1.ebuild
@@ -98,7 +98,7 @@ src_configure() {
$(use_enable xml xml-output) \
$(use libtirpc || echo --without-libtirpc) \
$(use ipv6 && echo --with-ipv6-default) \
- --with-tmpfilesdir="${EPREFIX}"/etc/tmpfiles.d \
+ --with-tmpfilesdir="${EPREFIX}"/usr/lib/tmpfiles.d \
--localstatedir="${EPREFIX}"/var
}
@@ -107,6 +107,10 @@ src_compile() {
use emacs && elisp-compile extras/glusterfs-mode.el
}
+src_test() {
+ ./run-tests.sh || die
+}
+
src_install() {
default
@@ -158,11 +162,9 @@ src_install() {
python_optimize "${ED}"
}
-src_test() {
- ./run-tests.sh || die
-}
-
pkg_postinst() {
+ tmpfiles_process gluster.conf
+
elog "Starting with ${PN}-3.1.0, you can use the glusterd daemon to configure your"
elog "volumes dynamically. To do so, simply use the gluster CLI after running:"
elog " /etc/init.d/glusterd start"