summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJaco Kroon <jaco@uls.co.za>2022-06-15 10:49:49 +0200
committerJoonas Niilola <juippis@gentoo.org>2022-06-15 16:32:10 +0300
commit8cffcdeb67a222db2f726567beca821618b3481f (patch)
tree15b1be491984fea84d2796525e987f5e67e40039 /sys-cluster/glusterfs
parentnet-libs/libnftnl: fix build w/ Clang and FORTIFY_SOURCE=2 (diff)
downloadgentoo-8cffcdeb67a222db2f726567beca821618b3481f.tar.gz
gentoo-8cffcdeb67a222db2f726567beca821618b3481f.tar.bz2
gentoo-8cffcdeb67a222db2f726567beca821618b3481f.zip
sys-cluster/glusterfs: version 10.2
No major changes, mostly minor bug fixes, except for one SSE related issue where certain structures needs to be aligned. Closes: https://bugs.gentoo.org/852077 Package-Manager: Portage-3.0.30, Repoman-3.0.3 Signed-off-by: Jaco Kroon <jaco@uls.co.za> Closes: https://github.com/gentoo/gentoo/pull/25907 Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'sys-cluster/glusterfs')
-rw-r--r--sys-cluster/glusterfs/Manifest1
-rw-r--r--sys-cluster/glusterfs/files/glusterd-10.2.initd32
-rw-r--r--sys-cluster/glusterfs/files/glusterfsd-10.2.initd121
-rw-r--r--sys-cluster/glusterfs/glusterfs-10.2.ebuild199
4 files changed, 353 insertions, 0 deletions
diff --git a/sys-cluster/glusterfs/Manifest b/sys-cluster/glusterfs/Manifest
index e511f730095d..788e05693802 100644
--- a/sys-cluster/glusterfs/Manifest
+++ b/sys-cluster/glusterfs/Manifest
@@ -1,4 +1,5 @@
DIST glusterfs-10.1.tar.gz 8273640 BLAKE2B a29eb83fbc3a65e5f5a1db3694e6f46519973256a10f5e16419c832cb308a36961a4e3569fffd3f6e21e47b4b1ff78bcd2e687fce7b9710dfb25d88fca2d622f SHA512 38bec8ae33128641b17c645733589c32d554ebb771bda50a11d35019e71654f3b75ca95d24d0c0d1ec4eb460edd99983e843a7218092d422d2185a227345de42
+DIST glusterfs-10.2.tar.gz 8278598 BLAKE2B 48e70a244e34cc41a5befbe94635e945c95b87f26e5e1892b099d23a13c6fb70eefb2a66b247a564b03eeb0707ee480b50096b154b3ac5d2a13051e6371995b3 SHA512 290c701fbd3f100096ef26b589ee0714449fc620c35e62bcb5fe2fe8de5f64963b40d7d5fe1b97b274ba791fa45f4175305b6a112f184f6ce11a1e0dc9f7ea30
DIST glusterfs-8.6.tar.gz 7826147 BLAKE2B 3a8a488c9a8e4b1daf3ed01fa5e52a62cf791349c1169aaf8609252bfb8bc0a0534f9fc23fac27cfab11ac6fb5e3e1d9588b4ec8080b02cf97e679bf2c8fb5c2 SHA512 bb1125e5d6b4d424234bc40786847f217e7a05cecad1462dd91248cf9559569914f04e1f909e829051cb1db4079ecf906440a38af9de2bbf3bcf53ca8fa1f349
DIST glusterfs-9.4.tar.gz 8173625 BLAKE2B c35c63696717bf09f8fbf77dca16a6f45de278253e768c6ffc40c0c097da9ea1b32888233da412a5333281995e89e08d9ed23fd47aba7c506de84b08f9f80cea SHA512 2a17197bd2b425117e34af004a6177b7c5012807cd99b9c6d37a1081e0ab9def6b013bedd0ba4122d149969755e0e2985bef8aed9cf612a27a6452b8719a33bf
DIST glusterfs-9.5.tar.gz 8174643 BLAKE2B d7527b7749b753768bde086e88e146564b461f835bb9108ce24da9626d7d87e7e4da1b2a340c6497da2d8bafe0cd43e87c01d4ba6639635ff96d8788997a8042 SHA512 3483068ba6d72a9c63cc6fcb2dbcb38dd5001564d755cc3a30dbf6402eeab9a7c80759a535be1c5c06eae88b61156a336444c89b12bbecdabf56a87f00328a44
diff --git a/sys-cluster/glusterfs/files/glusterd-10.2.initd b/sys-cluster/glusterfs/files/glusterd-10.2.initd
new file mode 100644
index 000000000000..af8f941d87d7
--- /dev/null
+++ b/sys-cluster/glusterfs/files/glusterd-10.2.initd
@@ -0,0 +1,32 @@
+#!/sbin/openrc-run
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+description="Gluster elastic volume management daemon"
+command="/usr/sbin/glusterd"
+pidfile="/run/${SVCNAME}.pid"
+command_args="-N"
+
+command_background="yes"
+
+depend() {
+ need net
+ before netmount
+}
+
+start_pre() {
+ # Ensure that the GlusterFS auxiliary mount parent directory exists
+ checkpath --directory --owner gluster:gluster --mode 0775 /run/gluster
+}
+
+start_post() {
+ local c=0
+ ebegin "Waiting for glusterd to start up"
+ while ! /usr/sbin/gluster volume list >/dev/null 2>&1 && [ "${c}" -lt "${glusterd_max_wait_start-60}" ]; do
+ $(( c=c+1 ))
+ done
+ [ "${c}" -lt "${glusterd_max_wait_start-60}" ]
+ eend $?
+
+ return 0
+}
diff --git a/sys-cluster/glusterfs/files/glusterfsd-10.2.initd b/sys-cluster/glusterfs/files/glusterfsd-10.2.initd
new file mode 100644
index 000000000000..c8b6562e02a2
--- /dev/null
+++ b/sys-cluster/glusterfs/files/glusterfsd-10.2.initd
@@ -0,0 +1,121 @@
+#!/sbin/openrc-run
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+if [ "${SVCNAME}" != "glusterfs" ]
+then
+ GLUSTERFS_NAME="${SVCNAME#glusterfs.}"
+else
+ GLUSTERFS_NAME="glusterfs"
+fi
+
+GLUSTERFS_PIDFILE="/var/run/${SVCNAME}.pid"
+
+eval 'GLUSTERFS_LOGFILE="${'${GLUSTERFS_NAME}'_log:-/var/log/glusterfs/'${GLUSTERFS_NAME}'.log}"'
+eval 'GLUSTERFS_VOLFILE="${'${GLUSTERFS_NAME}'_vol:-/etc/glusterfs/'${GLUSTERFS_NAME}'.vol}"'
+eval 'GLUSTERFS_SERVER="${'${GLUSTERFS_NAME}'_server}"'
+eval 'GLUSTERFS_PORT="${'${GLUSTERFS_NAME}'_port:-6996}"'
+eval 'GLUSTERFS_TRANSPORT="${'${GLUSTERFS_NAME}'_transport:-socket}"'
+eval 'GLUSTERFS_OPTS="${'${GLUSTERFS_NAME}'_opts}"'
+eval 'GLUSTERFS_MOUNTPOINT="${'${GLUSTERFS_NAME}'_mountpoint}"'
+
+depend() {
+ need net
+ [ -n "${GLUSTERFS_MOUNTPOINT}" ] && need fuse
+ use dns
+ before netmount
+ after firewall ntp-client ntpd
+}
+
+checkconfig() {
+ if [ -z "${GLUSTERFS_NAME}" ]
+ then
+ eerror "The service name is not properly formatted."
+ return 1
+ fi
+
+ if [ -z "${GLUSTERFS_SERVER}" ]
+ then
+ if [ -z "${GLUSTERFS_VOLFILE}" ]
+ then
+ eerror "No GlusterFS volume file source has been defined. Edit /etc/conf.d/glusterfs"
+ eerror "and configure a volume file source for ${SVCNAME}."
+ return 1
+ else
+ if [ ! -f "${GLUSTERFS_VOLFILE}" ]
+ then
+ eerror "Cannot find volume file: ${GLUSTERFS_VOLFILE}"
+ return 1
+ fi
+ fi
+ fi
+
+ if [ -n "${GLUSTERFS_MOUNTPOINT}" -a ! -d "${GLUSTERFS_MOUNTPOINT}" ]
+ then
+ eerror "The mountpoint ${GLUSTERFS_MOUNTPOINT} does not exist."
+ return 1
+ fi
+}
+
+start() {
+ local status daemon
+
+ checkconfig || return 1
+
+ ebegin "Starting GlusterFS (${SVCNAME})"
+ eindent
+
+ if [ -z "${GLUSTERFS_MOUNTPOINT}" ]
+ then
+ einfo "Starting in server mode ..."
+ daemon="glusterfsd"
+ else
+ einfo "Starting in client mode. Mounting filesystem ..."
+ daemon="glusterfs"
+ fi
+
+ if [ -n "${GLUSTERFS_SERVER}" ]
+ then
+ einfo "Using server supplied volume file"
+ start-stop-daemon --start --pidfile ${GLUSTERFS_PIDFILE} \
+ --exec /usr/sbin/${daemon} -- \
+ --pid-file=${GLUSTERFS_PIDFILE} \
+ --log-file=${GLUSTERFS_LOGFILE} \
+ --volfile-server=${GLUSTERFS_SERVER} \
+ --volfile-server-port=${GLUSTERFS_PORT} \
+ --volfile-server-transport=${GLUSTERFS_TRANSPORT} \
+ ${GLUSTERFS_OPTS} ${GLUSTERFS_MOUNTPOINT}
+ status="$?"
+ else
+ einfo "Using local volume file"
+ start-stop-daemon --start --pidfile ${GLUSTERFS_PIDFILE} \
+ --exec /usr/sbin/${daemon} -- \
+ --pid-file=${GLUSTERFS_PIDFILE} \
+ --log-file=${GLUSTERFS_LOGFILE} \
+ --volfile=${GLUSTERFS_VOLFILE} \
+ ${GLUSTERFS_OPTS} ${GLUSTERFS_MOUNTPOINT}
+ status="$?"
+ fi
+
+ eoutdent
+ eend ${status}
+}
+
+stop() {
+ local status
+
+ ebegin "Stopping GlusterFS (${SVCNAME})"
+ eindent
+ if [ -z "${GLUSTERFS_MOUNTPOINT}" ]
+ then
+ einfo "Stopping server process ..."
+ start-stop-daemon --stop --pidfile ${GLUSTERFS_PIDFILE}
+ status="$?"
+ else
+ einfo "Unmounting ${GLUSTERFS_MOUNTPOINT} ..."
+ umount "${GLUSTERFS_MOUNTPOINT}"
+ status="$?"
+ fi
+ eoutdent
+ eend ${status}
+}
diff --git a/sys-cluster/glusterfs/glusterfs-10.2.ebuild b/sys-cluster/glusterfs/glusterfs-10.2.ebuild
new file mode 100644
index 000000000000..2551faf99a31
--- /dev/null
+++ b/sys-cluster/glusterfs/glusterfs-10.2.ebuild
@@ -0,0 +1,199 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit autotools elisp-common python-single-r1 tmpfiles systemd
+
+DESCRIPTION="GlusterFS is a powerful network/cluster filesystem"
+HOMEPAGE="https://www.gluster.org/ https://github.com/gluster/glusterfs/"
+SRC_URI="https://download.gluster.org/pub/gluster/${PN}/$(ver_cut 1)/${PV}/${P}.tar.gz"
+
+LICENSE="|| ( GPL-2 LGPL-3+ )"
+SLOT="0/${PV%%.*}"
+KEYWORDS="~amd64 ~arm ~arm64 ~loong ~ppc ~ppc64 ~riscv ~x86"
+
+IUSE="debug emacs +fuse +georeplication ipv6 +libtirpc rsyslog static-libs tcmalloc test +xml"
+
+REQUIRED_USE="georeplication? ( ${PYTHON_REQUIRED_USE} xml )
+ ipv6? ( libtirpc )"
+
+# the tests must be run as root
+RESTRICT="test"
+
+# sys-apps/util-linux is required for libuuid
+RDEPEND="
+ acct-group/gluster
+ acct-user/gluster
+ dev-libs/libaio
+ dev-libs/openssl:=[-bindist(-)]
+ net-libs/rpcsvc-proto
+ dev-libs/userspace-rcu:=
+ sys-apps/util-linux
+ sys-libs/liburing:=
+ sys-libs/readline:=
+ !elibc_glibc? ( sys-libs/argp-standalone )
+ emacs? ( >=app-editors/emacs-23.1:* )
+ fuse? ( >=sys-fs/fuse-2.7.0:0 )
+ georeplication? ( ${PYTHON_DEPS} )
+ libtirpc? ( net-libs/libtirpc:= )
+ !libtirpc? ( elibc_glibc? ( sys-libs/glibc[rpc(-)] ) )
+ tcmalloc? ( dev-util/google-perftools )
+ xml? ( dev-libs/libxml2 )
+"
+DEPEND="
+ ${RDEPEND}
+ sys-devel/bison
+ sys-devel/flex
+ virtual/acl
+ test? ( >=dev-util/cmocka-1.0.1
+ app-benchmarks/dbench
+ dev-vcs/git
+ net-fs/nfs-utils
+ virtual/perl-Test-Harness
+ dev-libs/yajl
+ sys-fs/xfsprogs
+ sys-apps/attr )
+"
+BDEPEND="
+ virtual/pkgconfig
+"
+
+SITEFILE="50${PN}-mode-gentoo.el"
+
+DOCS=( AUTHORS ChangeLog NEWS README.md THANKS )
+
+# Maintainer notes:
+# * The build system will always configure & build argp-standalone but it'll never use it
+# if the argp.h header is found in the system. Which should be the case with
+# glibc or if argp-standalone is installed.
+
+pkg_setup() {
+ python_setup "python3*"
+ python-single-r1_pkg_setup
+}
+
+src_prepare() {
+ default
+
+ # build rpc-transport and xlators only once as shared libs
+ find rpc/rpc-transport xlators -name Makefile.am -exec \
+ sed -i 's|.*$(top_srcdir).*\.sym|\0 -shared|' {} + || die
+
+ # fix execution permissions
+ chmod +x libglusterfs/src/gen-defaults.py || die
+
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ --disable-fusermount \
+ --disable-lto \
+ $(use_enable debug) \
+ $(use_enable fuse fuse-client) \
+ $(use_enable georeplication) \
+ $(use_enable static-libs static) \
+ $(use_enable test cmocka) \
+ $(use_enable xml xml-output) \
+ $(usex ipv6 --with-ipv6-default "") \
+ $(usex libtirpc "" --without-libtirpc) \
+ $(usex tcmalloc "" --without-tcmalloc) \
+ --with-tmpfilesdir="${EPREFIX}"/usr/lib/tmpfiles.d \
+ --localstatedir="${EPREFIX}"/var
+}
+
+src_compile() {
+ default
+ use emacs && elisp-compile extras/glusterfs-mode.el
+}
+
+src_test() {
+ ./run-tests.sh || die
+}
+
+src_install() {
+ default
+
+ rm \
+ "${ED}"/etc/glusterfs/glusterfs-{georep-,}logrotate \
+ "${ED}"/etc/glusterfs/gluster-rsyslog-*.conf \
+ "${ED}"/usr/share/doc/${PF}/glusterfs{-mode.el,.vim} || die "removing false files failed"
+
+ insinto /etc/logrotate.d
+ newins "${FILESDIR}"/glusterfs.logrotate glusterfs
+
+ if use rsyslog ; then
+ insinto /etc/rsyslog.d
+ newins extras/gluster-rsyslog-7.2.conf 60-gluster.conf
+ fi
+
+ if use emacs ; then
+ elisp-install ${PN} extras/glusterfs-mode.el*
+ elisp-site-file-install "${FILESDIR}/${SITEFILE}"
+ fi
+
+ insinto /usr/share/vim/vimfiles/ftdetect; doins "${FILESDIR}"/${PN}.vim
+ insinto /usr/share/vim/vimfiles/syntax; doins extras/${PN}.vim
+
+ # insert some other tools which might be useful
+ insinto /usr/share/glusterfs/scripts
+ doins \
+ extras/backend-{cleanup,xattr-sanitize}.sh \
+ extras/clear_xattrs.sh \
+ extras/migrate-unify-to-distribute.sh
+
+ # correct permissions on installed scripts
+ # fperms 0755 /usr/share/glusterfs/scripts/*.sh
+ chmod 0755 "${ED}"/usr/share/glusterfs/scripts/*.sh || die
+
+ newinitd "${FILESDIR}/glusterfsd-10.2.initd" glusterfsd
+ newinitd "${FILESDIR}/glusterd-10.2.initd" glusterd
+ newconfd "${FILESDIR}/${PN}.confd" glusterfsd
+
+ keepdir /var/log/${PN}
+ keepdir /var/lib/glusterd/{events,glusterfind/.keys}
+
+ systemd_dounit extras/systemd/{glusterd,glustereventsd,glusterfssharedstorage,gluster-ta-volume}.service
+
+ # QA
+ rm -r "${ED}/var/run/" || die
+ if ! use static-libs; then
+ find "${D}" -type f -name '*.la' -delete || die
+ fi
+
+ python_optimize "${ED}"
+}
+
+pkg_postinst() {
+ tmpfiles_process gluster.conf
+
+ elog "Starting with ${PN}-3.1.0, you can use the glusterd daemon to configure your"
+ elog "volumes dynamically. To do so, simply use the gluster CLI after running:"
+ elog " /etc/init.d/glusterd start"
+ echo
+ elog "For static configurations, the glusterfsd startup script can be multiplexed."
+ elog "The default startup script uses /etc/conf.d/glusterfsd to configure the"
+ elog "separate service. To create additional instances of the glusterfsd service"
+ elog "simply create a symlink to the glusterfsd startup script."
+ echo
+ elog "Example:"
+ elog " # ln -s glusterfsd /etc/init.d/glusterfsd2"
+ elog " # ${EDITOR} /etc/glusterfs/glusterfsd2.vol"
+ elog "You can now treat glusterfsd2 like any other service"
+ echo
+ ewarn "You need to use a ntp client to keep the clocks synchronized across all"
+ ewarn "of your servers. Setup a NTP synchronizing service before attempting to"
+ ewarn "run GlusterFS."
+ echo
+ elog "If you are upgrading from a previous version of ${PN}, please read:"
+ elog " http://docs.gluster.org/en/latest/Upgrade-Guide/upgrade_to_$(ver_cut '1-2')/"
+
+ use emacs && elisp-site-regen
+}
+
+pkg_postrm() {
+ use emacs && elisp-site-regen
+}