summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2017-05-27 00:18:11 +0200
committerDavid Seifert <soap@gentoo.org>2017-05-27 00:53:11 +0200
commitb7c546d8d87c81081b2b90cee5dc651e1710c8e4 (patch)
treea8a9201460cc6c82d0fb9a6bf167cccc15fd1c78 /sys-cluster/hpx/hpx-1.0.0.ebuild
parentnet-proxy/hatop: [QA] Add missing python metadata variables (diff)
downloadgentoo-b7c546d8d87c81081b2b90cee5dc651e1710c8e4.tar.gz
gentoo-b7c546d8d87c81081b2b90cee5dc651e1710c8e4.tar.bz2
gentoo-b7c546d8d87c81081b2b90cee5dc651e1710c8e4.zip
sys-cluster/hpx: [QA] Add missing python metadata variables
Package-Manager: Portage-2.3.6, Repoman-2.3.2
Diffstat (limited to 'sys-cluster/hpx/hpx-1.0.0.ebuild')
-rw-r--r--sys-cluster/hpx/hpx-1.0.0.ebuild6
1 files changed, 3 insertions, 3 deletions
diff --git a/sys-cluster/hpx/hpx-1.0.0.ebuild b/sys-cluster/hpx/hpx-1.0.0.ebuild
index f9748b81ba22..93c3d5be3feb 100644
--- a/sys-cluster/hpx/hpx-1.0.0.ebuild
+++ b/sys-cluster/hpx/hpx-1.0.0.ebuild
@@ -15,7 +15,7 @@ else
S="${WORKDIR}/${PN}_${PV}"
fi
-inherit cmake-utils fortran-2 multilib python-single-r1
+inherit cmake-utils fortran-2 multilib python-any-r1
DESCRIPTION="C++ runtime system for parallel and distributed applications"
HOMEPAGE="http://stellar.cct.lsu.edu/tag/hpx/"
@@ -38,14 +38,14 @@ DEPEND="${RDEPEND}
test? ( ${PYTHON_DEPS} )
doc? ( >=dev-libs/boost-1.56.0-r1:=[tools] )
"
-REQUIRED_USE="test? ( ${PYTHON_REQUIRED_USE} )
+REQUIRED_USE="
jemalloc? ( !perftools !tbb )
perftools? ( !jemalloc !tbb )
tbb? ( !jemalloc !perftools )
"
pkg_setup() {
- use test && python-single-r1_pkg_setup
+ use test && python-any-r1_pkg_setup
}
src_configure() {