summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKurt Kanzenbach <kurt@kmk-computers.de>2022-05-30 20:51:48 +0200
committerFlorian Schmaus <flow@gentoo.org>2022-06-03 10:35:03 +0200
commit64d66a0d31a271b0c8614e968f70c90b83a2bf29 (patch)
treed369556ab30373c8c2bbffa74bb7c52ff10a709f /sys-cluster/hpx
parentapp-editors/retext: add 7.2.3 (diff)
downloadgentoo-64d66a0d31a271b0c8614e968f70c90b83a2bf29.tar.gz
gentoo-64d66a0d31a271b0c8614e968f70c90b83a2bf29.tar.bz2
gentoo-64d66a0d31a271b0c8614e968f70c90b83a2bf29.zip
sys-cluster/hpx: add 1.8.0
Signed-off-by: Kurt Kanzenbach <kurt@kmk-computers.de> Signed-off-by: Florian Schmaus <flow@gentoo.org>
Diffstat (limited to 'sys-cluster/hpx')
-rw-r--r--sys-cluster/hpx/Manifest1
-rw-r--r--sys-cluster/hpx/files/hpx-1.8.0-python.patch30
-rw-r--r--sys-cluster/hpx/hpx-1.8.0.ebuild105
3 files changed, 136 insertions, 0 deletions
diff --git a/sys-cluster/hpx/Manifest b/sys-cluster/hpx/Manifest
index 32cfd01e4d9c..0e04f6bf71bc 100644
--- a/sys-cluster/hpx/Manifest
+++ b/sys-cluster/hpx/Manifest
@@ -1 +1,2 @@
DIST hpx-1.7.1.tar.gz 4751163 BLAKE2B 21e417dab5c118b16ab8d2955b0d65a95ca7d0e2f777496306855e4098cfb400962dd9e0cf03ebbab5e3348f2f985d1053d0a70124c0925c77859e8ada209cec SHA512 6bdb294da393a198abf81d5f63799a066334755eed0fda40bbfc4e9a774b6e19a3e5ad7ab45c989d31f3797e7b547bb552c29f51b552d9a79d166f86aee375a3
+DIST hpx-1.8.0.tar.gz 5209106 BLAKE2B aab9d3743cc2d73c2d3a6a2f2323e35dbe38cf506618475ea627d9c0d92855632f646404f5b257e2260eabe6bb22e8090bc3db2aafd9f4f71a0eeb62d7286247 SHA512 80afc93d517144d5c11164f82d7f0dd6fd71c079fb65930532c4fd96b6a5497cdf972bee8a6251035548a3662579a3bee5c04802569f47bc3c042ca868716cb7
diff --git a/sys-cluster/hpx/files/hpx-1.8.0-python.patch b/sys-cluster/hpx/files/hpx-1.8.0-python.patch
new file mode 100644
index 000000000000..21b7ce3ceeff
--- /dev/null
+++ b/sys-cluster/hpx/files/hpx-1.8.0-python.patch
@@ -0,0 +1,30 @@
+From 3d8d3acf0daad9cec8b092d67f7187265f7704e3 Mon Sep 17 00:00:00 2001
+From: Kurt Kanzenbach <kurt@kmk-computers.de>
+Date: Tue, 17 Mar 2020 16:20:35 +0100
+Subject: [PATCH 1/4] cmake: python: Use standard python interpreter
+
+These scripts are needed during build and run time. So, use a python interpreter
+which works for both cases.
+
+Signed-off-by: Kurt Kanzenbach <kurt@kmk-computers.de>
+---
+ cmake/templates/hpxcxx.in | 2 +-
+ cmake/templates/hpxrun.py.in | 2 +-
+ 2 files changed, 2 insertions(+), 2 deletions(-)
+
+--- a/cmake/templates/hpxcxx.in
++++ b/cmake/templates/hpxcxx.in
+@@ -1,4 +1,4 @@
+-#! @PYTHON_EXECUTABLE@
++#! /usr/bin/env python
+ #
+ # Copyright (c) 2014 Steven R. Brandt
+ #
+--- a/cmake/templates/hpxrun.py.in
++++ b/cmake/templates/hpxrun.py.in
+@@ -1,4 +1,4 @@
+-#! @PYTHON_EXECUTABLE@
++#! /usr/bin/env python
+ #
+ # Copyright (c) 2014 Thomas Heller
+ #
diff --git a/sys-cluster/hpx/hpx-1.8.0.ebuild b/sys-cluster/hpx/hpx-1.8.0.ebuild
new file mode 100644
index 000000000000..a1b86f1f953f
--- /dev/null
+++ b/sys-cluster/hpx/hpx-1.8.0.ebuild
@@ -0,0 +1,105 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..11} )
+
+if [[ ${PV} == 9999 ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/STEllAR-GROUP/hpx.git"
+else
+ SRC_URI="https://github.com/STEllAR-GROUP/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+fi
+inherit check-reqs cmake multiprocessing python-single-r1
+
+DESCRIPTION="C++ runtime system for parallel and distributed applications"
+HOMEPAGE="https://hpx.stellar-group.org/"
+
+SLOT="0"
+LICENSE="Boost-1.0"
+IUSE="examples jemalloc mpi papi +perftools tbb zlib"
+# tests fail to compile
+RESTRICT="test"
+
+REQUIRED_USE="
+ ${PYTHON_REQUIRED_USE}
+ ?? ( jemalloc perftools tbb )
+"
+
+BDEPEND="
+ virtual/pkgconfig
+"
+RDEPEND="
+ ${PYTHON_DEPS}
+ >=dev-cpp/asio-1.12.0
+ dev-libs/boost:=
+ sys-apps/hwloc:=
+ jemalloc? ( dev-libs/jemalloc:= )
+ mpi? ( virtual/mpi )
+ papi? ( dev-libs/papi )
+ perftools? ( dev-util/google-perftools:= )
+ tbb? ( dev-cpp/tbb:= )
+ zlib? ( sys-libs/zlib )
+"
+DEPEND="${RDEPEND}"
+
+PATCHES=(
+ "${FILESDIR}/${P}-python.patch"
+)
+
+hpx_memory_requirement() {
+ # HPX needs enough main memory for compiling
+ # rule of thumb: 1G per job
+ if [[ -z ${MAKEOPTS} ]] ; then
+ echo "2G"
+ else
+ local jobs=$(makeopts_jobs "${MAKEOPTS}" "$(get_nproc)")
+ echo "${jobs}G"
+ fi
+}
+
+pkg_pretend() {
+ local CHECKREQS_MEMORY=$(hpx_memory_requirement)
+ check-reqs_pkg_setup
+}
+
+pkg_setup() {
+ local CHECKREQS_MEMORY=$(hpx_memory_requirement)
+ check-reqs_pkg_setup
+ python-single-r1_pkg_setup
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DHPX_WITH_EXAMPLES=OFF
+ -DHPX_WITH_DOCUMENTATION=OFF
+ -DHPX_WITH_PARCELPORT_MPI=$(usex mpi)
+ -DHPX_WITH_PAPI=$(usex papi)
+ -DHPX_WITH_GOOGLE_PERFTOOLS=$(usex perftools)
+ -DHPX_WITH_COMPRESSION_ZLIB=$(usex zlib)
+ -DHPX_WITH_TESTS=OFF
+ )
+ if use jemalloc; then
+ mycmakeargs+=( -DHPX_WITH_MALLOC=jemalloc )
+ elif use perftools; then
+ mycmakeargs+=( -DHPX_WITH_MALLOC=tcmalloc )
+ elif use tbb; then
+ mycmakeargs+=( -DHPX_WITH_MALLOC=tbbmalloc )
+ else
+ mycmakeargs+=( -DHPX_WITH_MALLOC=system )
+ fi
+
+ cmake_src_configure
+}
+
+src_compile() {
+ cmake_src_compile
+}
+
+src_install() {
+ cmake_src_install
+ use examples && dodoc -r examples/
+ python_fix_shebang "${ED}"
+}