summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorUltrabug <ultrabug@gentoo.org>2016-01-27 13:49:22 +0100
committerUltrabug <ultrabug@gentoo.org>2016-01-27 13:49:44 +0100
commit4bd40f6bfcb7513b1c58b05c5b764bf0e4b1e5bc (patch)
tree4b6bea9b73344ee67d47504e6a70b93eba58bae2 /sys-cluster/ipvsadm/ipvsadm-1.27-r1.ebuild
parentnet-misc/curl: version bump 7.47.0 (diff)
downloadgentoo-4bd40f6bfcb7513b1c58b05c5b764bf0e4b1e5bc.tar.gz
gentoo-4bd40f6bfcb7513b1c58b05c5b764bf0e4b1e5bc.tar.bz2
gentoo-4bd40f6bfcb7513b1c58b05c5b764bf0e4b1e5bc.zip
sys-cluster/ipvsadm: fix libnl3 detection #497890, version bump fix #565464
Package-Manager: portage-2.2.27
Diffstat (limited to 'sys-cluster/ipvsadm/ipvsadm-1.27-r1.ebuild')
-rw-r--r--sys-cluster/ipvsadm/ipvsadm-1.27-r1.ebuild17
1 files changed, 12 insertions, 5 deletions
diff --git a/sys-cluster/ipvsadm/ipvsadm-1.27-r1.ebuild b/sys-cluster/ipvsadm/ipvsadm-1.27-r1.ebuild
index 3ff6de56459a..ac46190fbbaa 100644
--- a/sys-cluster/ipvsadm/ipvsadm-1.27-r1.ebuild
+++ b/sys-cluster/ipvsadm/ipvsadm-1.27-r1.ebuild
@@ -1,8 +1,8 @@
-# Copyright 1999-2013 Gentoo Foundation
+# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
-EAPI=4
+EAPI=6
inherit eutils linux-info toolchain-funcs
@@ -15,8 +15,8 @@ SLOT="0"
KEYWORDS="~amd64 ~ia64 ~ppc ~ppc64 ~s390 ~sparc ~x86"
IUSE="static-libs"
-RDEPEND=">=sys-libs/ncurses-5.2
- dev-libs/libnl
+RDEPEND=">=sys-libs/ncurses-5.2:*
+ dev-libs/libnl:=
>=dev-libs/popt-1.16"
DEPEND="${RDEPEND}
virtual/pkgconfig"
@@ -29,6 +29,7 @@ pkg_pretend() {
}
src_prepare() {
+ default
epatch "${FILESDIR}"/${PN}-1.27-buildsystem.patch
# Merged upstream in 1.27
#epatch "${FILESDIR}"/${PN}-1.26-stack_smashing.patch # bug 371903
@@ -37,8 +38,14 @@ src_prepare() {
}
src_compile() {
+ local libnl_include
+ if has_version ">=dev-libs/libnl-3.0"; then
+ libnl_include=$(pkg-config --cflags libnl-3.0)
+ else
+ libnl_include=""
+ fi
emake -e \
- INCLUDE="-I.. -I." \
+ INCLUDE="-I.. -I. ${libnl_include}" \
CC="$(tc-getCC)" \
HAVE_NL=1 \
STATIC=${STATIC} \