summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWilliam Hubbs <williamh@gentoo.org>2021-03-13 14:28:13 -0600
committerWilliam Hubbs <williamh@gentoo.org>2021-03-13 14:28:13 -0600
commite8f6d3e858a4d320583788229f5596d5bc683604 (patch)
treecf734803ee003f7f4901558b8fbee37af25a6e72 /sys-cluster/kubectl/kubectl-1.19.7.ebuild
parentsys-cluster/kube-controller-manager: remove 1.19.7 (diff)
downloadgentoo-e8f6d3e858a4d320583788229f5596d5bc683604.tar.gz
gentoo-e8f6d3e858a4d320583788229f5596d5bc683604.tar.bz2
gentoo-e8f6d3e858a4d320583788229f5596d5bc683604.zip
sys-cluster/kubectl: remove 1.19.7
Signed-off-by: William Hubbs <williamh@gentoo.org>
Diffstat (limited to 'sys-cluster/kubectl/kubectl-1.19.7.ebuild')
-rw-r--r--sys-cluster/kubectl/kubectl-1.19.7.ebuild34
1 files changed, 0 insertions, 34 deletions
diff --git a/sys-cluster/kubectl/kubectl-1.19.7.ebuild b/sys-cluster/kubectl/kubectl-1.19.7.ebuild
deleted file mode 100644
index 1f18731b5eb7..000000000000
--- a/sys-cluster/kubectl/kubectl-1.19.7.ebuild
+++ /dev/null
@@ -1,34 +0,0 @@
-# Copyright 2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-inherit bash-completion-r1 go-module
-
-DESCRIPTION="CLI to run commands against Kubernetes clusters"
-HOMEPAGE="https://kubernetes.io"
-SRC_URI="https://github.com/kubernetes/kubernetes/archive/v${PV}.tar.gz -> kubernetes-${PV}.tar.gz"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="amd64 ~arm64"
-IUSE="hardened"
-
-DEPEND="!sys-cluster/kubernetes"
-BDEPEND=">=dev-lang/go-1.15"
-
-RESTRICT+=" test"
-S="${WORKDIR}/kubernetes-${PV}"
-
-src_compile() {
- CGO_LDFLAGS="$(usex hardened '-fno-PIC ' '')" \
- emake -j1 GOFLAGS="" GOLDFLAGS="" LDFLAGS="" WHAT=cmd/${PN}
-}
-
-src_install() {
- dobin _output/bin/${PN}
- _output/bin/${PN} completion bash > ${PN}.bash || die
- _output/bin/${PN} completion zsh > ${PN}.zsh || die
- newbashcomp ${PN}.bash ${PN}
- insinto /usr/share/zsh/site-functions
- newins ${PN}.zsh _${PN}
-}