summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-12-26 03:33:21 +0000
committerSam James <sam@gentoo.org>2021-12-26 03:38:37 +0000
commit72fc7e4e490df50f470b12af8b4e6dd4735487b2 (patch)
tree2148e0740db53c4bb6ed91d1e0e2cc8741f8a95c /sys-cluster/legion
parentsys-cluster/legion: bump to EAPI 8 and legion-21.09.0 (diff)
downloadgentoo-72fc7e4e490df50f470b12af8b4e6dd4735487b2.tar.gz
gentoo-72fc7e4e490df50f470b12af8b4e6dd4735487b2.tar.bz2
gentoo-72fc7e4e490df50f470b12af8b4e6dd4735487b2.zip
sys-cluster/legion: tidy up
CMake sets the shared libs bits for us and let's make use of Bashisms. Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'sys-cluster/legion')
-rw-r--r--sys-cluster/legion/legion-21.09.0.ebuild9
-rw-r--r--sys-cluster/legion/legion-9999.ebuild9
2 files changed, 10 insertions, 8 deletions
diff --git a/sys-cluster/legion/legion-21.09.0.ebuild b/sys-cluster/legion/legion-21.09.0.ebuild
index 9487e8eb0a59..a271def3a1d2 100644
--- a/sys-cluster/legion/legion-21.09.0.ebuild
+++ b/sys-cluster/legion/legion-21.09.0.ebuild
@@ -7,13 +7,14 @@ inherit cmake
DESCRIPTION="A data-centric parallel programming system"
HOMEPAGE="https://legion.stanford.edu/"
-if [[ ${PV} = 9999 ]]; then
+if [[ ${PV} == 9999 ]]; then
inherit git-r3
EGIT_REPO_URI="git://StanfordLegion/${PN}.git https://github.com/StanfordLegion/${PN}.git"
else
SRC_URI="https://github.com/StanfordLegion/${PN}/archive/${P}.tar.gz"
+ S="${WORKDIR}"/${PN}-${P}
+
KEYWORDS="~amd64"
- S="${WORKDIR}/${PN}-${P}"
fi
LICENSE="BSD"
@@ -29,14 +30,14 @@ DEPEND="
RDEPEND="${DEPEND}"
src_configure() {
- mycmakeargs=(
+ local mycmakeargs=(
-DLegion_USE_HWLOC=$(usex hwloc)
-DLegion_USE_GASNet=$(usex gasnet)
-DLegion_ENABLE_TESTING=$(usex test)
- -DBUILD_SHARED_LIBS=ON
-DLegion_BUILD_EXAMPLES=ON
-DLegion_BUILD_TESTS=ON
-DLegion_BUILD_TUTORIAL=ON
)
+
cmake_src_configure
}
diff --git a/sys-cluster/legion/legion-9999.ebuild b/sys-cluster/legion/legion-9999.ebuild
index 9487e8eb0a59..a271def3a1d2 100644
--- a/sys-cluster/legion/legion-9999.ebuild
+++ b/sys-cluster/legion/legion-9999.ebuild
@@ -7,13 +7,14 @@ inherit cmake
DESCRIPTION="A data-centric parallel programming system"
HOMEPAGE="https://legion.stanford.edu/"
-if [[ ${PV} = 9999 ]]; then
+if [[ ${PV} == 9999 ]]; then
inherit git-r3
EGIT_REPO_URI="git://StanfordLegion/${PN}.git https://github.com/StanfordLegion/${PN}.git"
else
SRC_URI="https://github.com/StanfordLegion/${PN}/archive/${P}.tar.gz"
+ S="${WORKDIR}"/${PN}-${P}
+
KEYWORDS="~amd64"
- S="${WORKDIR}/${PN}-${P}"
fi
LICENSE="BSD"
@@ -29,14 +30,14 @@ DEPEND="
RDEPEND="${DEPEND}"
src_configure() {
- mycmakeargs=(
+ local mycmakeargs=(
-DLegion_USE_HWLOC=$(usex hwloc)
-DLegion_USE_GASNet=$(usex gasnet)
-DLegion_ENABLE_TESTING=$(usex test)
- -DBUILD_SHARED_LIBS=ON
-DLegion_BUILD_EXAMPLES=ON
-DLegion_BUILD_TESTS=ON
-DLegion_BUILD_TUTORIAL=ON
)
+
cmake_src_configure
}